Transitioning from FP2 to FP4


Following on this thread, in order to get the accessories for FP5, I would love to get some clarification on specifications.

Fairphone does mention a USB-certified cable,

I have a few USB-C cables lying around, no idea the brand or anything, plus some old chargers that would fit.

Is there any possibility of making any harm to a new phone with devices like that, or will it just make charging slower?

1 Like

Just try and use it, all I have work with the FP3 and FP4 and I never checked any specifications.

Because yes it just influences together with the charger how fast its being charged


Thanks so much again, Patrick. Looking at it, I think I too will go for the 8GB/256GB model of FP4.
Warm regards, Andrea

1 Like

I also recently went from FP2 to FP4 about a month ago. I ordered the headphone jack adaptor (earbuds don’t work for me) and the cable and charger as all the USBC cables in my house were already spoken for. Generally speaking I’m happy with my FP4.

I flashed it with Calyx OS. My current gripe is the fact I can’t seem to be able to download anything and then open the download, e.g. restaurant menus and public transport maps from websites via Duckduckgo browser, or even from e-mails. Not sure if the documents are simply not downloading, or if they are downloading but being saved somewhere really obscure where I can’t find them. (Not in a downloads folder). If anyone else has come across this, please let me know the solution. (Mods, feel free to move my post to a more appropriate thread if you want).


Have you checked whether (and how) the Downloads are listed in the list of Downloads in DuckDuckGo? You can reach that by searching something, kicking on the three dots, and then selecting ‘Downloads’ from the list (second entry from the bottom). If there’s something in the list it should also tell you whether the download is successful, and you should be able to open, share, and delete downloaded files from there, as long as they haven’t been moved from their original location. Or does only the opening fail, despite the file being listed? What about sharing?

When I click on the 3 dots in Duckduckgo and select downloads, only one download is shown, which is a png file (a picture of a QR code for an airline boarding pass. I forget whether the link to that was from an e-mail or a text message. None of the other items where I clicked to download (I remember trying to download some bus timetables, metro maps from websites where the website made it look like I’d downloaded, but the download itself was nowhere to be seen). The unsuccessful downloads would probably have been pdf format.

What do you mean by that? Did you see an overlay by DuckDuckGo that indicated that Download has started or succeeded or were you simply redirected to another page?

If the problem consistently occurs with PDF files, the problem may not be with DuckDuckGo, but your default PDF viewer. Have you checked whether a default app to open .pdf files/file-links is set? Maybe the opening of that application fails. Have you tried installing a different PDF viewer? Which one do you use at the moment?

Also what about other file formats. Have you tried saving pictures from a website by long-pressing and saving them?

Also have you tried a different browser yet? Firefox mobile maybe?

The pdf software on my FP4 is Mu.pdf. I used Mu.pdf without a problem on FP2. It is not playing ball on FP4. Can you recommend another open source pdf viewer (ideally one available through F-droid)?

The Mu.pdf app opens, it’s just the only thing I can see in it is the boarding pass, not the pdfs I’d tried downloading from Duckduckgo browser.

I have just tried downloading a pdf metro map through Chromium (the other browser on my FP4) and was asked to select where to download to, and was able to download (logically) to my downloads folder.

I can’t see where in Duckduckgo browser I can select where documents are downloaded to.

Have you tried both MuPDF viewer and MuPDF mini?
Also you might wanna clear all defaults of apps that may open pdf files in the system settings.

Have you tried navigating to the downloaded pdf with a file explorer app and opening it with MuPDF from there? Are the files in question in the same folder?

Librera Reader has a reasonable touch UI and an integrated file browser. Its development has been temporarily halted/slowed though according to its GitHub Readme, since its developer is from Ukraine.

You could also try KOReader. It works, but its UI has rather been made for eBook Readers with eInk Displays than for regular mutitouch screens, so the UX isn’t exactly great for regular phones.

Yeah, DuckDuckGo is nice for privacy, but it seems less configurable than other Browsers when it comes to Stuff like that. But afaik it differentiates a few file formats. On my device it put some jpg files I downloaded into ‘Pictures’, while pdf files landed in ‘Downloads’.

1 Like

Really helpful to know you’ve been through this transition too.
Can I ask:

  1. was the headphone jack adaptor this one from the FP website? USB-C to Mini Audio Jack Adapter (3.5mm) - Accessory | Fairphone
    (Actually, I realise I’m clear this is the one I need as Urs put the link above, but still interested if it’s the one you got too :slight_smile: )
  2. did you get this cable?
    USB-C to USB-C Cable 2.0 - Accessory | Fairphone
  3. and this charger (I see you are also in UK)
    Dual-port 30W Charger (UK) - Accessory | Fairphone
    Thanks so much, Andrea

Hi AndreaStC - my answer is yes to all 3 questions about the accessories. I bought my FP4 through Your Co-op and bought the charger and cable from them along with the phone. I had to order the USB-C to Mini Audio Jack directly from the Fairphone website as they were not available from Your Co-op.

1 Like

Many thanks, MrsLuddite, that’s really helpful. From the wee pictures on the FP website, I couldn’t see how the cable and charger could connect! Now, having done a very wee reccy on the different types of USB connectors, I see you could use your cable with its USB-C port in the charger for fast charging, or you could have the USB-A adaptor hood on and plug into a computer or to the (presumably) slower 18W charge slot on the charger.

[I read somewhere that whilst fast charging very convenient for certain purposes, slow charging is good for battery life - but perhaps that’s just batteries of the FP2 sort…]

Thanks so much again- think I’ll go ahead and order this tomorrow then :smile:

Happy to help AndreaStC. Yes, the cable allows the choice of plugging in a USB C-USB C cable for fast charging, or putting the extra bit on the end for ordinary USB - USB C charging.

I was able to back up my contacts off my FP2 by exporting to a vcf file, copying that onto my laptop with a USB cable, and then importing them onto the FP4. Similarly I used the SMS backup app successfully to copy across my ordinary SMS and Telegraph messages. I copied off the FP2 onto my laptop, and then from my laptop to my FP4 the various files with documents and photos that I wanted to have on my new phone.

1 Like

Ah, great to know I’ll be able to do this. :smile: I’ll come back to your response here when my new phone arrives! Thanks again, Andrea

One more thing I just thought of: Have you tried pulling the pdf files downloaded via DuckDuckGo from your phon to your Computer (e.g. via adb) and opening them there? If that works we could at least rule out that the files were somehow corrupted or downloaded incompletely.

When you add the Iode repo you can download their PDFViewerPlus fork

@AndreaChris - the problem is I cannot see to which file on my phone the pdfs have downloaded. If I could find the downloaded pdfs I wouldn’t have had to post a query in the first place. I can’t copy them to my computer without knowing where to find them on my phone.

@yvmuell - I thought Iode was a different alternative operating system, not the same as Calyx OS. I have Calyx OS.

Okay, another idea:

Install LogcatReader on your device. Then grant it the permission to read the logs. For this you need to perform the following steps:

  • enable the android developer options by navigating to ‘Settings > About Phone > Build Number’ and tapping the build number multiple times.
  • enable USB-debugging via ‘Settings > System > Developer Options > USB-Debugging’
  • install adb (android debug bridge) on your PC
  • connect your device to the PC via USB, open a terminal and enter adb devices
  • a popup should appear on your device aski g whether youwant to allow the connected device to access your phone via USB debugging. Click allow.
  • Then enter the following command into the terminal: adb shell "pm grant com.dp.logcatapp android.permission.READ_LOGS && am force-stop com.dp.logcatapp"

Now you should be able to display debug logs in the app.

Open the LogReader app. Then open DuckDuckGo, navigate to Downloads, click on the PDF file in the list to open it, and go back to the LogReader app. Then search for the filename in the list. Some of the events should contain the file path DuckDuckGo tries to open. With this you should be able to figure out where the file is stored.

For example:

1 Like

What kind of charger do you already have? Maybe an adapter from Micro to USB-C is sufficient for you. So you can continue to use your charger from FP2, maybe only charging lasts a bit longer

1 Like

Many thanks, Benjamin, that’s a point.
My current charger is a Devia model LX10C-0502108, which I can’t find on Devia’s website so perhaps it is discontinued. It’s described as a “travel charger”. Other information on the back:
USB1 output 5V=2.1A
Total 10W(max)

Mmm sounds pretty basic, though charges my FP2 just fine!