Titanium doesn`t work correctly on my rooted fairphone 2

Hello! Yesterday I rooted my FP2 with this wonderfull instruction (How to root … with superuser) by Max_S. I was very anxious about my poor fairphone, but everything worked great!! After 5 minutes it was rooted. Thank you very much. But now I have a problem with Titanium, because it doesn`t show me my application. Just that, what You see on the screenshot. Does anyone have an idea what to do?

1 Like

Maybe you have a Filter or Search active?

No, I don’t think so. The Screenshot shows the condition directly after the installation.

What do your settings say? Did you point it to the correct place? Whats in “Übersicht”?

I have another screenshot of my “Übersicht”.

This screenshot looks OK.

I would also guess a kind of filter, as all your “system settings” are available.
In the last posted screenshot got to “Sichern/widerherstellen” --> “Menü” --> “Filter” --> “Löschen” in the right upper corner and the green hook.

Does your app lists looks differente then?

Yes it looks the same, no app is shown. I deinstalled and reinstalled titanium 3 times. I really have no idea. Somthing must refusing the access to my apps, I guess. I have an old tablet, samsung tab 2, with CyanogenMod 10 and there is no problem with titanium. So I thought it is mabye a problem with android 5.1. But I have found nothing in the internet. So, maybe in my settings is somthing wrong?

Maybe you can try the privacy impact trick?

No that didnt work. Maybe it is a bug as keesj wrote in the answer of the first post following the link you gave me above. But it is pretty bad that one of my favorite app wont run. Is it possible that I have to substitute superuser with superSu?

Might be worth it, as the text under “problems” states you might get all kind of problems with a non functional superuser app. And tibu does work on the fp2, no problems here with SuperSU

I cannot answer this. But for me with exatly following step 1B and 2B I have not this problem.

I did it following step 2B and it works well. Everything appears. But I have the Pro version. Maybe there’s a problem with the free one…

I am using the TB Free version without this problem…

I used the boot-fairphone-fp2-su-eng-r162.img version, as it was suggested to provide maximum rights.

I solved my problem and found a solution !!!

First: thank you for all your advices and suggestions. That shows me, that I am not allone.

Problem yesterday: I was confused, because it seemed to me, that I haven`t enough root rights (if that is possible). Those were my observations:

  • Sd Maid and AFWall+ were running under root
  • Titanium showed me that it had root right, but didn`t show me my apps
  • superuser was running, but superSU not

Today I repeated the rooting. But instead of installing the suggested image by Max_S in his instruction I flashed boot-fairphone-fp2-su-eng-r163.img. And now everything works fine.

My final quesion is: Does anyone know an app to restrict the permissions of the other installed apps? I haven`t found anything in the internet as far as Android 5.1 is concerned.

Thank you

8 posts were split to a new topic: App to restrict permissions