Threema & signal calls: callee hears echo - low mic volume in handsfree mode - awful sound bluetooth headset

I suppose you will have to see what your support brings up, surely you don’t expect anyone on the forum to know?

Can you confirm the update number.

There were a number of topics on this but the issue was resolved long before the last update 0134

However I did notice it again a few days ago so I imagine it is a network or weather related issue.

You may want to

  • Check the memory left
  • Ensure you do not have an SD card formatted as internal
  • clear the cache of at least the apps you have a problem with
  • check you don’t have interference

You say next to nothing about the situation you are in

  • Which network you are using
  • Is this happening on 4G etc
  • Is it any different using Wifi
  • Using WiFi with network and blue tooth off

etc.

So there are numerous setups you could be using so it is difficult to know if down to that

The problem, as I see it, is that it may not be down to the OS and hence a software update is not the solution.

Do you know bluetooth and 2.4GHz wifi use the same band, ensure your network is set to 4G only when using bluetooth for example.

Can you try a safe mode start, and initiate just of the apps in turn.

I use exactly the same setup as with my former smartphone. The same wifi, the same network provider, the same sim, the same couch on which I use to have my calls :wink:

Build 8901.3.A.0134.20211116
No I don’t use my storage card as internal storage, but either way this feature should work, shouldn’t it?

My FP3 has upgraded cameras.

More than 40gb free storage

As I already pointed out, I’m not the only one having this problem as you can see via a simple forum search

1 Like

A search only shows old complaints, apart from yours do you have a link to another?

1 Like

how can you claim that? the search above shows mostly unsolved problems that are identical with mine and those threads are only closed because of inactivity, probably because the authors just gave up on fairphone:
here are some examples:

you even replied to those posts admitting that those issues exist.
apart from that, what are you trying to insinuate? that the problem is me the user although my problem is very well documented in the forum?

1 Like

Those links are from quite a while ago;

For example:
I have voice echo in the Signal app which uses fairphone 3(Feb to Jun 2021)

Echo in VOIP calls - FP3 - #14 by alquimista(Jan - May 2021) RESOLVED

Whatsapp echo on caller side - #4 by Margriet1(Jan to Mar 2021)

That was many updates ago.

1 Like

the issue with the low audio in handsfree mode is described by you in this post:

the last reply was in July’21 which states that the problem is still unsolved. No further posts about which update was supposed to solve it. What was the response to your support ticket 425463 that you mentioned in that thread?

There is also this thread here from Aug’21. @OneZ had similar problems (I can also confirm his 40% problems with the fingerprint reader):

Even in this thread there is no post about an update with which the issues were supposed to be resolved.

Yes I’m very aware of my post and the issue I had ~ a year ago ? but that was resolved long ago.

There have been OS updates and most people seem to have not continued to mention they have the problem.

1 Like

Bottom line is: This is a community forum, not the company.
If there’s nothing else in the forum, your support request is already the best way to find out what’s going on.

Hello all!

Hope you are having a good time.

Just wanted to share my experience. None of my problems were solved! And thus I sold it to a person who didn’t care about these issues and I bought a used phone.
Sadly it wasn’t a good experience.

3 Likes

Thanks for the update, I hate to ask what the problems were. At what point did you give up, my daughter lasted all of 9 months max :slight_smile:

The major problem was people not hearing me well during hands-free calls. Add to this android auto not working on my car and the fingerprint sensor not recognizing me 40-50% of the time.

1 Like

Just wanted to add, that my FP3 suffers the same issue. Caller hears noises while speaking in hands-free mode and without. Have not tried with a headset.

Should add, that I am running /e/ on it.

1 Like

Support has replied with some standard text about diagnosing my microphone and stuff (all of which I have already tried). It doesn’t seem as they would have read my message thoughtfully because they asked questions about things I already included in my support request in the first place (e.g. build version I’m using)

In the meantime I installed LineageOS on which the issues are not present.
For those who have the same issues as I had and who don’t want to or can’t switch to LineageOS: I hope Fairphone solves those issues soon for you!

2 Likes

Yes I have noted that :roll_eyes: in my comms with Fairphone too. Maybe some pretty dumb AI intercepts the mails and respond to a few target words.

However as I don’t have the problems you have, though I did a year ago, it may have just been a glitch in the OS on your phone rather than an OS issue in general.

I have had this problem since May. Like @HerrBertl, the phone is unusable for me until this problem is fixed. So I put the phone on a shelf in May and updated the software today and checked again. Same problem: in Zoom or GoToMeeting, if you plug in a speaker or headset the sound from your microphone is unintelligible for people in the meeting.

I believe that when you plug in a cord to the audio port, the phone switches to a different microphone? It must be this alternate microphone which is not working right.

Is there a link to some test procedure which can help you diagnose if any of your microphones have a hardware problem?

My build shows as 8901.3.A.0135.20211222

If LineageOS is the recommended solution, why would one not be able to switch to it? (I loaded LineageOS on an Nvidia tablet so I’m sure I could figure it out.) I am not sure what I would miss if I ran LineageOS but it should be better than shelving a $500 piece of hardware.

Hi there is an internal test for many ‘items’
Using the call option dial *#*#66#*#* and select Service tests > Test Single > Microphone

You will find test for two mics. Mic 2 is the top one and is substantially lower than mic1 and is most often used in hands free and video calls.

I’m not sure what the phones protocol is when anything is plugged into the earphone jack socket.

1 Like

@nmgeek fairphone support replied to my support request that they have identified problems with the microphone in messenger apps and will fix this in some future release. let’s hope this will be soon

5 Likes

@nmgeek LineageOS works fine but has some glitches though. Sometimes my phone just powers off (once a week) and also the camera sometimes crashes (but not often).
And be aware that you might not be able to use all your apps because they can detect your unlocked bootloader. I have no problems with my banking apps but the McDonald’s app (!!!) refuses to run on an unlocked phone :laughing:

Superb, thanks for the update @HerrBertl. I’m another with similar issues in my FP3.

At least I have it narrowed to the phone itself. I went through 3 pairs of bluetooth earbuds before accepting my phone was the source of audio issues. Also checked my Jabra 75 buds with my partner’s iphone, with stellar audio picked up through the jabra mic when connected to her phone.
I also downloaded the app Microphone (PC Mehanik) that lets me select the jabra bluetooth mic on the FP3, and I can confirm it DOES connect clearly.

The strangest thing though, I thought it was just defaulting to the speaker mic on the phone since I sounded so far away. But that wasn’t it… The more I tested the more confusing the issue. No volume change when I move the phone close or further from me. So maybe it does pick up the bluetooth mic, but still converts it into ‘noisy tunnel’ mode? Would changing the codec make any difference? (but if it did, why would my audio be clear in a microphone app, but not through whatsapp calls?)