Three major erratic instabilities with FP2 w/ Open OS, help!

Hello,

Due to lots of previous major issues, I finally got a replacement Fairphone 2 after months of waiting for tech support to respond to my ticket. Unfortunately, I’ve been using my replacement FP2 (with the Fairphone Open OS) for a couple months and have been getting more unstable and major problems:

  1. My SD card “disappears” and is forgotten and not recognised when (a) I reboot my phone OR (b) when I shut it down and turn it back on OR (3) when I plug my phone via USB into my computer for charging. In Storage settings, I can see the button to mount my SD card, but pressing it doesn’t do anything! I have to open the back case (while the phone is on), remove the SD card then put it back in a few times before it is recognised and mounted. I suspect this is a software issue, because when the SD card is physically removed, the mount SD card button in Storage settings is greyed out. However, if the SD card is physically plugged in, the mount SD card button is not greyed out, it just doesn’t do anything.

  2. In Display settings, I set my phone to Sleep after 5 minutes of inactivity. However, no matter what I set it to, my phone insists on going to sleep after about 10 seconds!! Nothing I do seem to change this…

  3. Like many other people, my phone also forgets the time and resets it to 1970 whenever I reboot the phone OR shut it down and turn it back on.

These three major problems are very annoying, and started happening after I got this “replacement” Fairphone 2. I tried updating the Open OS several times over the past months to keep up with the updates, but the problem actually got worse… :frowning: Has anyone else experienced these problems and have solutions?? Especially problems 1 and 2? They make my phone incredibly difficult to use… I’ve tried factory resets but that did not help. Official tech support has also not responded after more than two months after I reported them.

What can I possibly do??? Thanks for your help.

Maybe you find some helpful answers here:


Maybe you find some helpful answers here:


Known bug, workaround available here:
https://forum.fairphone.com/t/fp-open-os-clock-resets-after-reboot/17635/66?u=freibadschwimmer&source_topic_id=23049

5 Likes

@freibadschwimmer thank you so much for your tips!! They have solved lots of my woes.

Unfortunately I am still encountering problems after changing my phone’s setting to MTP mode when plugged in via USB. One is that my SD card still spontaneously unmounts and becomes unmountable unless I physically remove and put it back in, and the other is that the MTP shares do not show up on my Manjaro Linux system…

Is there another way to solve the SD card issue? Or is it a known software bug that’s being fixed? Or should I raise this in a new thread??? Thanks!!

Sorry for the late reply.

I don’t think that there’s a bug causing the SD card unmounts. Some people have solved the issue by replacing the SD card. I suggest to continue this discussion in the thread linked above, maybe this will be read by people who experienced the same issue.

As for the MTP issue on Manjaro I could imagine some missing libraries or packages on your Linux install. With my Debian I also had to install a couple of extra packages until it ran smoothly. Maybe you find some answers in a Manjaro forum.

1 Like

Sorry about my late response!

I’ve been testing different SD cards, but they all have the same problem (i.e. SD card disappearing)… Will post on that thread.

Thanks for your tips on this and the MTP issue. I’ll keep trying!

I wrote about this issue some time ago as it was more in focus.

My sd card of a Samsung Pro+ 128GB type acts the same but I found a way to get it mounted which generally does not need removing or similar inconvenience.
But it do need some patience and maybe more than one power on.
As I usually do not have any occasional reboots or instabilities the phone can remain up and running smooth for several weeks.

Generally spoken:

…with a completely different type, brand, manufacturer. Unfortunately a trial & error approach…:disappointed:
But the hit rate for a good match is very high.

First of all use you card(s) with a reader on your computer and get the filesystem checked for errors. This can also take influence when mounting.

I believe it is some kind of timing problem related to initializing all cards.
I may not reboot but only power off - wait a bit - power on again.
Then I patiently unlock each sim card with a delay.
I cannot tell for sure how long the unlock steps should be delayed.
All in one maybe up to 2 min. In most cases after unlocking the phone at last the sd card is available and stays available until I reboot. USB mounting or else does not matter.

I think this is very individual and may not work for everyone. But up to now I could handle it this way. It is planned to replace the card, but as my phone works very stable I do not have this trouble annoying me too often.
Opening the case, removing the card several times would not only stress me but bear the risk of further damage, let alone removing the card while the phone operates. SD cards are not thought for hot-plug operations in general afaik or maybe it is rather related to the used filesystem. FP2 uses Fat32 on it, which should always be properly unmounted.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.