Tethering problem: does not turn on / WiFi defunct afterwards

Hi everyone,

this is rather urgent:
desperately need to use tethering.

I used it before, worked.

Since the last FP OS update it does not work.
Can anyone confirm?

If WiFi is OFF:
select [System settings] [More] [Tethering & portable Hotspot] [Turn on WiFi Hotspot]
–> menu turns grey, says “Turning hotspot on”.
Nothing happens, and I can’t turn WiFi on any longer.

If WiFi is ON
Nothing happens, and WiFi is turned off.

BTW, I have to restart my phone afterwards to get WiFi back working.

I need to use my laptop, b/c some soft is simply not available for android, and I don’t have any other option right now. Anyone who can advise me?

Disclaimer: please don’t tell me to reset to factory settings. I’m in desperate need of my phone right now, and there would be no option to look for help on the internet if something goes wrong and my phone would be bricked, or I had problems restoring my backup.

If anyone got a solution, please consider sending me a ping on twitter (@humorkritik) - this should get through even with this terrible connectivity right now. (Even mails are currently a problem. Living on the very low end of EDGE… :angry: :
I had to hop onto a public WiFi even to send this message, and I can tell you it was kind of a hassle. :confused:

I want to help, but I have to admit that I don’t understand the problem.

If all else fails … you can only try to find a cheap “Wireless Modem Dongle Adapter” somewhere or whatever they are called these days. Assuming that the next free Wi-Fi bar/cafe is far far away, but a store to buy a dongle is still close by :smile:

1 Like

You wrote in another thread that you only have a very weak and unstable EDGE connection. Maybe this is the reason for your tethering problem.

I once tried to give internet access via tethering to a friend to check her Whatsapp when she could’t get any connection at all, but I had at least “a little bit” (one line) of EDGE. It didn’t work. It also got somehow stuck with “Turning hotspot on”, as you described above. Later, when we were back to “civilization”, I tried it again and it worked normally. So I guessed that tethering needs a stable internet connection.

The fact that your wifi turns off when turning the hotspot on and that it doesn’t work when getting stuck, seems quite logical to me, since you can’t have both of it at the same time. The phone can only be a wifi receiver OR a transmitter.

Have you recently tried tethering when you’ve got a better connection?

Have you tried to switch flight mode on and off to get your wifi back? Maybe that could be a workaround for not having to reboot.

1 Like

Yes, I did. With no effect. Trying to tether does not work, and WiFi does not work afterwards, either.

Also tried that. Also to no avail: WiFi is defunct, and the “Turning hotspot on” message does not go away in the tehering menu.

This sucks so badly. I am glad I found a WiFi I can use, but I can’t constantly work there. :frowning:

You could try to delete wpa_supplicant.conf in /data/misc/wifi/ (using a root browser).

Thanks, but it seems I cannot delete the fime, even using OI file explorer with root rights.

Any further hints?

I already got 145 mb of accumulated work in my upload queue. You can imagine how annoying this situation is getting.

Hi @humorkritik
Do you have F-Droid installed? If this is the case it’s quite possible that you have the bug like many other F-Droid Users that can break your wifi or tethering or both.

In this case tou really should try to delete wpa_supplicant.conf and p2p_supplicant.conf (the second is for wifi tethering)

Also, I read you need tethering for your notebook? There is a usb cable tethering option which is really cool, don’t know which operating system you are using but with Ubuntu it worked out of the box.


USB tethering also works with Windows out of the box.

1 Like

@Stefan & @tobika: your suggestion to try USB tethering saved me. Literally. Sadly, support wasn’t helpful.

Now, I’m way beyond the limit of my data plan, but the important part is that I got my stuff uploaded.

I will look and see if F-Droid was the culprit in a couple of days, I guess - as soon as I have done more pressing stuff, like getting a landline. Connectivity is really bad here, I am seriously living on the EDGE.

BTW, additionally to my connectivity issues, now my battery seems to be dying, and I may even have a broken USB connector. Bad luck, indeed. :frowning:

Thank you so much for your help, and sorry for the late reaction. I was really busy.
I will report back on the F-Droid issue.


I’ have a FP 1, with Kola Nut 1.8.7 and a Windows laptop (Acer).

I’ve tried tethering with two different mobile operators, Tim and Vodafone (I’m in Italy).

The laptop connects to the phone, but no access to Internet.

I’ve tried to delete the two supplcant files, but with no luck.

Then I follow the suggestion by @enos and finally it works: http://forum.fairphone.com/t/ip-masquerading-is-not-on-by-default-which-disables-stethering/6430

My question is: how can I automate this passage? Now I have to open Terminal emulator, copy and past the two lines every day.



I had the same issue in 2014 and I’m quite sure that after trying the workaround of @enos I had solved by installing a new version of package .apk about tethering cooked by a user… perhaps this .apk of the comment #109 (https://code.google.com/archive/p/android-wifi-tether/issues/1661#c109 ), but I’m not really sure.
Some weeks ago I had to make an hard reset the device and I reinstalled Kola Nut 1.8.7 so I lost all my personalization :frowning:

Wrong link, correct is at comment #192: https://code.google.com/p/android/issues/detail?id=38563#c192

Thanks @tobika. That solved my problem with tethering not starting.

F-droid corrupted my FP1’s tethering.
That link solved also my problem.