English

Testers wanted - newer kernel for FP2 - Lineage 16.0 and 17.1

If you know how to flash a boot image, can you please test the kernel updated to 3.4.113 and android-common report back? [1]
You need to “fastboot flash boot boot.img” this on an existing lineage 16.0 / 17.1 installation. [2]

Version for 16.0 (as of 16th March):
https://www.androidfilehost.com/?fid=4349826312261746343

Version for 17.1 (as of 5th April):
https://androidfilehost.com/?fid=4349826312261762567
Source: https://github.com/chrmhoffmann/android_kernel_fairphone_msm8974
Branch: staging/lineage-17.1/last-attempt-to-merge-android-common

Chris

[1] This time it’s rebased not merged, so we have better chances to bisect it, if something breaks.
[2] If you dont know what this means, you shouldn’t test it.

11 Likes

2 SIMs, 256G SD Card with 2 partitions, rooted LOS 16 nightly 05.03.2020 with opengapps 9.0 nano 06.03.2020, no user interaction: reboots after 90sec.

Reboot also happens without second SIM and without SD Card.

Back to LOS kernel and everything’s fine again.

2 Likes

Basically the same here: reboot after a short time, with or without user interaction.
LOS 16.0-20200309, opengapps 9.0-pico-20190411, no SIM, no SD-card, only connected to WiFi.
No problem after going back to the original boot.img

If you want, I can upload a logcat (if that’s helpful).

Can you point us to a changelog or repo to look at? Which version were we on before this one? Thanks for your valuable work!

You can check yourself on your phone… I think all versions are on 3.4.0.

In case it might interest you, @chrmhoffmann : same problem as others here had (reboot after about 60s without user interaction) after starting boot partition modified /e/ OS based on LOS 16. Restore of original boot partition restored working system.
Anyway, thanks for your valuable work!

Hmmmm. Crap. I tried more combinations - Official Lineage + opengapps + downloaded boot.img. All works fine.

Can someone please upload:

  • logcat
  • cat /proc/last_kmsg (e.g. from recovery - right after boot crash)?

Chris

Here are the files for my setup (replace pdf -> txt):

last_kmsg.pdf (118.9 KB)
logcat.pdf (568.5 KB)

Just out of curiosity, what’s the use of two partitions here?

First partition is FAT32 to keep Android happy, second partition is ext4 for files >4GB, symbolic links a.s.o.

and BTW: I can also use that same SD card to boot an ordinary x86PC into Linux :wink:

1 Like

https://androidfilehost.com/?w=files&flid=306245

Uploaded 3.4.10, .20, .30

Can you please try one by one :)?

Chris

2 Likes

I’m sorry. I’ve tried out all three of them - and at least in my case all leaded to the reboot described above too.
Hope there will be more success with the other testers.

I only tested the 3.4.10 kernel because it already showed the reboot issue (uploaded last_kmsg to https://pastebin.com/ie60SFu6).

Some info I forgot last time: I have the new camera and display module.

1 Like

Same here. And unfortunately I don’t have an old one any more to put it in for tests in case that might help…
EDIT: I’ve just thought about it. On my second “test phone” the kernel worked fine. And there’s also the new camera installed.

I guess it would be helpful to provide the kernel log for the phone where the reboots happen.
With USB debugging enabled, when the phone reboots, press Vol-up to immediately boot into recovery and execute

adb shell cat /proc/last_kmsg > last_kmsg-3.4.10-1.txt 
3 Likes

I’d done that in a pm already.

1 Like

It might already give a hint to boot the phone with the new module simply removed.

1 Like

Yes, but as I’ve one phone which works with new kernel and one which doesn’t, and both have new camera module, I’m already sure the module is not too blame…

1 Like

Very nice solution :+1:. I’m having such an all time good & handy mobile Linux on my ebooks SD card. That’s what I am missing when using Android, a FS capable of proper handling >4GB files.

Thanks to @Ingo we were able to bisect the kernel and find the offending commit.
New version to test: https://www.androidfilehost.com/?fid=4349826312261746343
Chris

5 Likes