System UI wurde beendet / crashed

Help help help, oh god.

I got my FP2 a couple weeks ago. It’s rooted, XPosed Framework installed. A couple of days ago the new Update came, but I didn’t install it yet, because it’s rooted and I didn’t have time for the manual installation.
Now I just installed a couple of Xposed Apps, it was PinNotif, maybeeee one that is supposed to keep YouTube playing in the background (don’t know if I just looked at it or installed it) and an update for … something, I honestly can’t remember what it was.
I activated them all and went for the restart, but after booting I got the message that the System UI crashed (or sth like that, it’s in German).
Holding the power on button still worked, so I did that and selected reboot (after accepting the system ui notification a couple of times). But after restarting it just was the same.

I saw this topic already System-UI wurde beendet / Fairphone OS wurde beendet, where it is either recommend to do a factory reset, something I hope I don’t need to do since setting up my phone in the first place took several long hours, or to re-install the fairphone software from recovery.
Now, I don’t know what this would exactly imply. Would that wipe my data too? Would it only make root access be gone? Is this the link I’d need for that, and what exactly would I have to do?
Or are there more options I can choose from?

I hope some of y’all can help me. I’ll try to remember what the update was in the meantime.

Kind regards,

Okay, important update. I unflashed XPosed via TWRP and now it started again. For some reason my background isn’t there anymore, but everything else seems to be. THANK god. I’ll try to maybe disable the apps in XPosed installer now and then install XPosed again, I don’t know if this will work.
(First a backup via Titanium though)

Update again: (sorry btw I hope this isn’t considered spam, but maybe it helps people who might have the same problem in the future)

So it seems to have been caused by one of the modules I installed. The one I updated was Vibration Tuner, but it still works just fine. The other one was PinNotif, and the third one was Heads Up Hide. One of those last two must have caused the problem.

I solved by first rebooting into TWRP, flashing the Xposed uninstall zip and then restarting. Then I deleted via XPosed Installer the two apps that I newly installed (by going to Modules, long pressing on them, and choose delete). Then I activated Xposed again via TWRP and now it’s working.

Hope this helps anybody along the line!

1 Like

If you want to find out which Xposed module caused this (so you can use the other one) you could perform a full backup via TWRP to an SD card and then try one of the two modules. If something goes wrong (evenworse than before) you can do a hard reset via TWRP and then restore the backup. That way you can’t lose any data or settings.

PS: Titanium Backup is great - especially the ability to perform scheduled backups - but compared to a TWRP backup a TB backup is incomplete and harder to restore. Just make sure you don’t already have any software issues when you backup via TWRP or you’ll back them up too.

Thanks! I’ll try this out when I have enough time on my hands. It’s been obvious to me that Titanium Backup doesn’t save the full thing, but I didn’t know TWRP could. Thanks for the suggestion!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.