Switching OS to iodeos

Hello there!
I have been using LineageOS for a couple of months but I am considering switching to IodeOS to be Google-free. To unlock the bootloader, I followed the guide provided by Fairphone. Now, in reading the instructions for installing IodeOS, it is recommended not to unlock critical partitions, but I have already done so. What could be the consequences? Is there a way to restore them to their original state and re-lock them?

Welcome to the community :wave:

You can just relock them. Unlocking the critical partitions doesn’t change them, it only would let you flash them. Un-/locking them does however wipe userdata.

The more important part is to check fastboot flashing get_unlock_ability before you lock your bootloader. If you get a 0 don’t lock it!


Big thanks, that is a relief :face_exhaling:
So I got to check with
fastboot flashing get_unlock_ability
In case the return is 1 i relock with
fastboot flashing lock_critical
Then I’m good to go?

Before flashing iodé you might need to consider android securiy patch dates. I think iodé is March but you may be on April with LOS?

1 Like

Hi margana and thanks for the hint i totally forgot about that! I am very lucky tho, I am not upgrading weekly and I am with the release 20230402 wich has March security patches :partying_face:


Thought i got the hang of it, never so wrong :rofl:
I spent the last couple of hours trying to understand what’s going on with almost 0 results.
I tried following this simple article but i can’t get the recovery flashed. I followed till the 6th point with everything running smoothly but when i try to reboot in iode recovery it is LOS recovery.

Iodé revovery is los. Anyway , you should follow iodé install instructions which are now via fastboot flashing script.


First of all thanks for your patience :grinning:
I tried using the script, it give me an error while starting cause of the SDK version wich i just downloaded from the official site. So digging a bit i found that is a known bug, so i disabled the version checker deleting some row of code in the script. The script then could run successfully but it leaves me with a bootloop. :upside_down_face:
Gotta reverse to LOS to use the phone for this week, i will retry surely but i got to study a bit more i guess. Thanks again for your wise help :heart_eyes: