Locking bootloader after installing Iodé 3.4?

Hi to all you experts out there!

I tried to install the Iodé 3.4 Custom-ROM to my new Fairphone4 following the “official” instructions by Iodé found here
(All files were downloaded from here)

The installation went smoothly until step #12 where I should re-lock the bootloader via

fastboot flashing lock

The previous check for unlock_ability definitly returned 1, so locking should have been possible.

But what I got was a Phone trapped in a boot-loop and, after booting to the bootloader, an error message “your device is corrupt and will not boot”. Now the Phone always(!) rebooted to bootloader, no matter what option (Start, Restart to Bootloader, Recovery Mode, Power off) I choose.

So far, so known … from several other postings here and on other forums.

What was new and surprising to me was, that I could “cycle” through the lock-states “unlocked” and “locked” via the commands

fastboot flashing unlock / lock

with the bootloader showing the correct state afterwards.

Trying to solve the boot-loop problem I repeated the steps #5,#6 (flashing the recovery-image to both(!) slots) and #7 (flashing the “avb_custom_key”).
But that indeed didn’t get me out of the boot-loop.
What has helped here was, after showing all bootloader variables and recognizing that the “current-slot” was set to “b”, to switch the “current-slot” to “a” by running:

fastboot --set-active=a

After that, the Phone surprisingly booted to Iodé, shortly showing the “erase” of something I couldn’t read in time and automatically rebooted again, but now to the regular Iodé-OS 3.4 (which is a really nice move of the Phone, saving me at least 30€ and some days of waiting time :blush: ) !

Note: Re-reading all bootloader variables after the successfull boot to Iodé-OS now shows the following changes:

(bootloader) partition-type:userdata:ext4 was: f2fs
(bootloader) partition-type:metadata:raw was: ext4
(bootloader) current-slot:a was: b
(bootloader) slot-unbootable:a:no was: yes

while all others remain unchanged, for example the following:

(bootloader) slot-successful:a: yes
(bootloader) slot-unbootable:b: yes
(bootloader) slot-successful:b: yes

So…finally(!) it comes to the following questions:

  • After switching to slot “a”, can I now safely(!) re-lock the bootloader to get rid of the annoying “bootloader unlocked message” during boot-time ?
  • Can I safely(!) do the OTA upgrade to iodé 4.0, that is offered to me under “Settings | System | Updater”? Does this even work with a locked bootloader ?
  • When, if at all, should I disable “OEM unlocking” in the OS ?

Because of the trouble I had with the regular procedure any competent advice is warmly welcomed!

Best Regards,

1 Like

Welcome to the community :wave:

You’ll have to check fastboot flashing get_unlock_ability again.

  • 0: Don’t lock it and reinstall the system to get it back to 1
  • 1 and it doesn’t boot after locking: The security patch level on your phone is newer then the ROM you are installing, unlock it and look for a newer release
  • 1 and it boots: Congratulations :tada:


Depends on the apps you want to run and if one of them checks for that.
Here’s some more information on the different states, keep in mind that the FRP protection only works on a stock ROM.


As long as you always check the status of OEM unlock before relocking the bootloader (and there value is “enabled” resp. “1” your safe and your device will not be hard bricked (and no Cordon repair will need necessary).

What I’d do in your case is doing the update to 4.0 (probably security patch date is then *not older than for the currently installed version," so anti-rollback should not trigger when relocking the bootloader), check if OEM unlock is still enabled (!) and relock the bootloader then.
If it again fails to boot (I wouldn’t expect that) you’d still be able to unlock the bootloader again (and reinstall the OS if really necessary).


Thank you @hirnsushi, Thank you @Volker!

I followed your advice and:

  • Checked the “OEM Unlocking enabled”: = true
  • Updated the OS to version 4.0 which worked well! The “current slot” was changed to Slot b during that process correctly !
  • Re-Checked the “OEM Unlocking enabled”: = true
  • Checked get_unlock_ability: = 1
  • Locked the bootloader with “fastboot flashing lock”, which again resulted in an error message “your device is corrupt and will not boot
  • unlocked the bootloader again and checked the “current slot”, which was changed to “a” !!
  • reset the “current slot” to “b” and now the Phone booted in “Recovery mode”, offering me to “try again” or a “Factory data reset
  • I “tried again” but to no avail, ended in “Recovery mode” again and now took the “Factory data reset
  • Now the phone succssfully booted to Iodé 4.0 but the bootloader is still unlocked!

I did this whole procedure 2 times with no success (but, at least, a successful update to Iodé 4.0). The Bootloader ist still unlocked :slightly_frowning_face:

1 Like

So it seems to me that anti-rollback is unfortunately triggered. I’d expect locking the bootloader to work once an additional new iodéOS update (with newer security patch date) is published and installed. But if you wait until then, still a factory reset will be needed once you lock your bootloader…

1 Like

So I’ll wait until the next update, hoping for a newer security patch.

As a newbie to Iodé / Android: Can I backup all changes (Apps, data etc), that happen in the meantime, and restore them later to the then resetted Phone with the “regular” backup mechanisms ?

Have you tried a factory reset after locking the bootloader?

iodéOS supports Seedvault. That’s a good, but not perfect backup system. You can backup to your phone storage (use a SD card or copy the backup on your PC), an external USB drive or WebDAV/Nextcloud storage. You can adjust the scope of the backup in the settings, but there will still be some apps not allowing backups.

Settings -> System -> Backup


No, after the errors on bootloader locking, I always unlocked the bootloader immediately and refused to do anything while the bootloader is locked :flushed:

Thank you for the tipp about seedvault !

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.