Strava GPS issue

Since about a month, I have this GPS issue where they signal is apparently lost on Strava. It doesn’t seem to be the same issue as the ‘getting the signal fix’ topics I see here because that takes only a few seconds. It happens at the start, middle or end of the run and strangely never when Cycling of walking.
Any things I can check, location is always on.

could that be the reason?

1 Like

Hm keeping it ‘open’ is one thing I can test but that wouldn’t explain why this started a few weeks ago after half a year of the same kind of use. Never had GPS issues before.

you never know what changes are done to apps as well and this could be a reason in my eyes…

so instead of keeping it open, did you check the permission options for Strava in terms of lacation?

Maybe also check other navigation apps to see if its a general issue or more an app issue


this issue disappeared for a few weeks and is now back in full force since the last software update. I hope whatever they did to fix it (I didn’t make any changes then) will be done again as it’s quite annoying

Do you mean Strava update or OS update? :thinking:

I know you said this isn’t related to similar topics, but you could try one of the debugging steps that sometimes helps in those cases:

Especially try the last part, that usually improves the speed of positioning a lot (if your phone had insufficient data before) and could hopefully improve stability :crossed_fingers:

Have you tried
a) a restart of the phone
b) clear the app cache and storage

thanks, I meant OS update, I noticed the phone rebooted a few nights ago, the light woke me up :slight_smile: and then when I checked it said “your phone is now fully up to date” or something like that. This is exactly when the issue with the GPS accuracy re-appeared (it adds kms to my running at insane (to me :D) speeds, strangely never when cycling.
So that’s why I thought the update was to blame.

I tried the GPS test and will check in the coming days whether that improves stability

1 Like

:frowning: the issue has been back for a few weeks again, no sign of the spontaneous improvement this time :frowning:
I"m starting to think the FP4 is fundamentally incompatible with Strava

in case anyone is having this issue, what seems to have solved it for me was the following :
I have the sigma ride app to find my way on bike rides and having that open seems to tow along the strava GPS to get the location correct. Takes a bit more battery power and it’s kind of stupid strava doesn’t just work “on its own” but saves a LOT of frustration.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.