GPS fix takes very long after update (with e.g. and GPSTest)

Does not seem to be a general problem, so I would probably #contactsupport to exclude a Hardware issue with your phone.

Else have you tried in safe mode (GMaps should still be available) to test? #dic:safemode

Or any of the other forementioned tipps?

1 Like

I also have GPS issues since last update.
Check this thread: GPS no refreshing fast enough - #5 by lordtaki

Yes, I can do that. I will also try to screenshot some GPSTest screens next time.
I however think the chances it’s a hardware issue are low, because the problem appeared directly after the system update, that must be related.

1 Like

even if related with the update there must be other settings/circumstances which facilitate this behaviour, as I dont have this problem. This makes it difficult to detect during QC before roll out of an update.

Def inform support they need as much information to troubleshoot

Some update made it slightly worse for me. It is not in the range of 4-6 minutes as before but still 1-2 minutes and ugly if you start navigating and had the GPS disabled. (this happens for different apps)

What’s the number of satellites you are getting in GPSTest? Does your system clock differ from the time shown there? What’s the value of TTFF (if any)?

Have you tried injecting PSDS / time data in GPSTest (in the left drawer menu) and rebooting the phone?

1 Like

With latest update, stock FPOS: TTFF 10 seconds inside my office. So maybe it’s a hardware problem with some phones? Or it’s because GPS is usually disabled. Mine is on all the time at least…

1 Like

Of course if the GPS is on there is no problem. This problem is regarding the initial GPS fix.

What’s the number of satellites you are getting in GPSTest ?

I can see many (>20). Even before I get the initial GPS.

Does your system clock differ from the time shown there? What’s the value of TTFF (if any)?

the time is identical and the TTFF is empty.

PS: sometimes I get a fast GPS fix (~20sec). But no idea under which circumstances (could it be due to disabled 5G?). Will have to try this a couple of times with reboots.

I don’t see different behavior on my phone if the GPS was on beforehand, it’s not like it’s constantly updating your position in the background if no app is using GPS.

For which of the three values (used/useable/known)?

Did you try injecting PSDS / time data, any difference?


Hi there,
My first post here to try to fix my GPS issue.
I bought my FP4 last week and discover my GPS is very long to fix my position (with Waze/ GMaps)
To try to solve by myself :
I checked the apps parameter : Position always allowed
I reboot my FP4 several times
I installed GPS Test to see the behavior : Outside, without Wifi, with 4G, GPSTest first show me 19 to 23 in view/ 0 in use during 30 to 60 seconds before fixing the GPS
Do you think It could be an hardware issue ?
Do you have some other tips ?
My Fairphone version : FP4.FP4G.A.170.20220920

Some good news here. The GPS problem disappeared after turning off the phone, and removing the battery for about 15 minutes. Now I have instant fix within a few seconds, and no more inaccurate tracks or navigation anymore.

The reason I did that, was unrelated. My phone suddenly went completely dead during the night. I was afraid it was bricked, but the above method (removing the battery) solved the issue.
This was about 2 weeks ago, issues didn’t occur anymore since then.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Re-opening this topic as after the previous and the current update ( FP4.SP2J.B.086.20230807) I noticed that it took long to find a fix, GPS test had very few sattelites only and the time is incorrect and only after refreshing time data and PSDS and rebooting its fixed


Yep, can confirm. I thought I was going crazy.

1 Like

I got around this bug by using GPSTest and clearing assist data, injecting time and psds data. I then turned the phone off, removed battery and SIM.
On reboot, without SIM, GPS time was accurate again.
Turned it off and replaced the SIM and it’s still accurate.

It doesn’t help find the bug itself but it might resolve the bug for others. With luck the gps time will remain accurate.

1 Like

Yeah, that usually fixes it. And it’s great that there’s actually a simple workaround like that. But the thing is, it shouldn’t happen in the first place. :man_shrugging: I have never had this problem with any other phone.

1 Like

I just had to reboot, no need to take out the SiM or are you saying this is a permanent fix, i.e. it survives updates?


No idea of permanence. I just chucked all the advice,saw someone say that support claimed the SIM was to blame.

One would hope it survives the updates!

Another update and here we go again… Weird, at first time was correct, it just took quite long to get a fix then I let the FP lying on the table for a few minutes while GPSTest was till open and the time changed to incorrect