Strange FP2 vibration problem

Hi, I have a somewhat strange problem with vibration on my trusty FP2 since yesterday (running on Fairphone Open OS Android level 10, with latest update (which I installed several weeks ago).

During a timer alarm, it stopped vibrating (which means the phone was locked). Since then it did not vibrate again. Almost.

No vibration as tactile feedback (although turned on). When I switch MS swiftkey from standard Android vibration to a custom set duration, nothing changes.

It also does not vibrate when I hook it up to the charger or PC.

Although the phone was locked when this happened, I checked all settings I could think of, they are still active.

So at first I thought the actuator could be defect. I turned the phone off - and during shutdown, it did vibrate. I took off the back cover, checked the unbalanced weight, which easily moves. Turned the phone back on (also did reboot twice) and off. Again it vibrated. It always (!) vibrates on shutdown, so the actuator does work. But it only vibrates on shutdown…

Any ideas?


I tried to go into the test festure described in FP4 - Vibration not working - Help / Fairphone 4 - Fairphone Community Forum, but when I type the string mentioned, I only get a white screen. Does the FP 2 have a different number for the test feature?

The FP2 has the check up in the settings nor test number

1 Like

Thanks! But strangely (even stranger) since I tried the non-working FP number and got the white screen, vibration is back to normal. Let’s hope it stays that way. But this confirms me in my belief the actuator isn’t broken. Next I would have tried to disassemble the bottom module, inspect/clean/tighten the spring connectors to the actuator motor… I saw that Fairphone no longer has those in stock, but may offer some refurbished ones. If it holds, maybe I won’t need a replacement.

I disassembled the bottom module, cleaned and tightened the contacts/springs. This reduced problems a lot, but not totally. So I will go for a refurbished bottom module. The disappearing of the alarm clock process that went away for some weeks has re-appeared. Sometimes in the middle of a sounding alarm the process goes away…

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.