Stock fp3(+) (factory reset) boot loop (workarounds in first post)

Same problem Friday 10 nov

1 Like

tysm for taking the time. this is super helpful! have a great day

This just got me my phone back! Thank you so much!

1 Like

Thanks so much - I have been experiencing the same issue since last night (early hours 12/11) on a FP3 and this worked. Involved connected through ADB, clicking notification to always trust the connected computer, and then on the next reboot ran the commands before unlocking the phone. Have now disabled Google Play updates and seems to be running fine for the time being.

1 Like

@Pilo11 how have you been able to copy files before unlocking? I fiddled around with ADB / shell commands for hours and I only received messages that either the path was not found, or I did not have the rights to access those disks / data…

Thank you so much for posting this. After many difficulties, I have managed to get to step two, but I get “cmd: Failure calling service package: Broken pipe (32)” as a response. Would you or someone else know what that means and what to do?

Fingers crossed :wink:

Hmm seems like your adb server is crashed (in an unexpected state): try to execute the following commands to restart it or restart your computer.

adb kill-server
adb start-server

It is not really necessary to execute “pm clear…”, the “adb install -d” command also clears cache and data because I did not used -r (ADB Syntax examples). But I thought it’s a nice addition to understand the steps.


Hi !!

I also experience this issue, until 12 november around 12:30 in France…
THANKS A LOT for all the tips here !! <3
Special thanks to Pilo11 :+1:t3:, Fairy3000, amoun & Elli_Thomas

First two lines of commands : success :grinning:
But at the third line of command, failure response : [INSTALL_FAILED_VERSION_DOWNGRADE] :weary:

Do someone know what I did wrong and how to get it OK ?!
Thanks !!

1 Like

Are you sure that you did not miss the “-d” in the “adb install” command?
What does the following command output (need to be called on a linux or macos system or a terminal environment on Windows which supports grep)?

adb shell dumpsys package | grep versionName

on Windows powershell perhaps this:

adb shell dumpsys package | findstr -i versionName

My output:

versionName=22.02.21 (150408-428111784)
versionName=22.02.21 (150408-428111784)

It is important to install exactly that APK version (apk link).


I got it.
Thank you so much for the help!

Ooooops that’s it, I missed the -d :grimacing: :woman_facepalming:t3:

Everything’s OK now, THANK YOU Pilo11 !!! :superhero:t3:

I have another Fairphone3+ with Ubuntu which is also not affected … lol :wink:
many many thanks…

1 Like

Thank you for taking the trouble to provide these detailed steps. I had no chance without your guidance.

As a first time user of the sdk manager utility, I discovered:
The apk version needed to be downloaded to the Android\Sdk\platform-tools folder so the tool could find it.
In that folder, shift and right-click allowed me to start a ‘Power shell’ window to run the commands.
Adding '.' before the adb commands cleared one reported error.
Putting the apk name in single quotes cleared the other one.

When giving permission to use USB debug, I had to remember to tick “always” before pressing “allow”. It was still quite a game getting to those options in the permitted time before each reboot.
Kudos to you and the rest of the community for getting to this answer.


You can just drag & drop the apk behind the First Part of the command.

But workaround worked like a charm!

1 Like

Thank you all! With a combination of those two hints, I was able to uninstall the Google Play Services updates pretty easily without activating USB debugging, installing SDK, and all that.

Seems to be working for the time being. Automatic updates are disabled. I hope that prevents it from happening again.


I had EXACTLY same issue this evening FP3, UK, EE. Nothing special happened to my phone before this occurred. It came out of the blue

Solved it with Amoun’s tips- disabled Google play (phone was NOT happy about that… cue 1000 notifications about the world ending…), stripped Google Play of its updates, then switched off auto update for all. All is good again. For now!

1 Like

and tbh, if I can do it so can anyone

1 Like

As I read, your advice has been very helpful to everyone. My FP3+ reboots within 10 seconds. I managed to activate the developer mode in that time, but I can’t manage to reach the USB debugging button as well. Is there any trick? Thanks a lot…

Did you try this way to the workaround already?


Good morning,

i did the downgrade Yesterday on my wifes fp3plus. It worked for a few hours. This morning the boot loop is back… :frowning:

I also disabled automatic Updates in the Play Store App. Why is the Loop Back?

1 Like