Starting to lose it over the "zero brightness" bug

edit: sorry for this little outburst, was really mad yesterday, trying to figure out a solution now!

Ok, so I am at a point where I am getting really frustrated. I just recieved my new FP2 last week, a replacement because my old one was so bugged. Now I spent half a day to set the new phone up, just to end up with a completly black screen yesterday and no idea what it could be. In the end I reset the whole phone via TWRP and went thru the whole setting up process again. Today I found out that it’s actually a bug and was able to fix it by blinding swiping the top of my phone for like 10 minutes (I realized its a bug, because I had this before with my old phone). Note that I just updated to 1.6.2 today, yesterday I had the bug with 1.5.1…
I went to bed 30 minutes ago and spent those 10 minutes panicking while trying to set my alarm clock for tomorrow morning. So instead of going back to bed I got up to search the forum for a solution, which I am tired of. I love the concept of this phone and I do understand that there are some issues that come with this kind of phone, but I read about this bug here before and still its not listed in the “known bugs list”, neither do I find a good solution or work around for it without spending a long time browsing this forum, which is super frustrating!! I dont want to sit here searching this forum in fear I have to reset my phone again tomorrow when I get the bug again. Help would be very much appreciated!

It is tagged as #blackscreen in the forum.

Software workaround:

Hardware workaround:


hi, thanks for your response! I think I couldn’t find the problem I’m having under #blackscreen, because it’s also used for the sensor problem, which doens’t turn the screen back on after calls. I had that one before and that seems to be a hardware issue, while the problem I’m currently having seems to be a software issue, as it does not persist over factory resets. (edit: ok, I just realized that this makes no sense, as I obviously just described how it did persist over a hardreset, the only thing it did was setting the brightness back to a medium level)

In this case I turned the brightness to 0 (or 1, whatever the lowest level is called) myself and instead of going very dim it just went black, which is a huge problem since this persists over reboots. Like I said, my solution was to blindly swipe the screen for ~10min until I got lucky and set the brightness up again.

As I understand it the adp solution only sets the brightness back up but doens’t do any permanent changes, right?

Is there a way to change the brightness levels, like say 0=20/255? I could imagine that for some reason my phone thinks that 10/255=0/255, thus turning the screen completely black

Oh, I see. For me that bug was solved by the first software update and I never have it again. It was a problem with the autobrightness feature with some screen misconfiguration on the system.

I honestly don’t know how to upper the lowest brightness level (e.g. make 0/255 become 10/255), but I’ll search for it today later, ok?

Are you on the latest FP OS release (1.6.x)?

I installed xposed today and used gravitybox to set the brightness-level 1 (the lowest one) to 21 instead of 20 (for some reason it goes from 20-80 in gb). It seemed to work and I was able to set the brightness to the lowest level, but after I changed it back to ‘20’ (to check I found the solution) it didn’t black out as well, so I am not so sure if this had any influence… But at least it’s working for now for some reason…

I’m running FP OS 1.6.2, the bug occurred once before and once after the update… Thanks again for your help!

No problem! Glad you solved it somehow, :slight_smile:

I had the same problem until I figured out I was using an old boot.img for rooting. Problem disappeared after update and appeared again later (I did not realize it was always happening after flashing the boot.img).

I was always following this guide: [HOWTO] Root with Superuser (for FP OS with GMS) but using a repository url mentioned in an earlier version of this topic so it kept downloading the image for version 1.3.6. After removing all files and starting over it works again. I’m not sure if I should be happy that the phone was even booting with the wrong image or not because this issue caused a lot of frustration :wink:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.