Critical: #Blackscreen after minimal brightness

Yes, I also have a problem with my screen staying black during calls.
I tried to readjust the proximity sensor but I get error messages.
It could be that my phone is not well centered (case/screen), but it came like this when I first got it (I am still in my first week of use). Still trying to figure that one out…
Perhaps the light sensor is also affected in some way?

It happened again last night and I had no phone for the rest of the night when I was supposed to meet with people.
I will contact the support again because this is the third problematic issue (proximity sensor, cover that’s falling apart and now the black screen).

One last thing that I would like to state here: As a former test manager on a part of the Galileo project (european gps), IMHO Fairphone has a Test problem. Some issues like this one occur after a new software release and it should not go undetected. Something is going wrong in the way you release the software and this is very problematic for us, I hope you can resolve it.

The Forum is a by the community for the community effort, so there’s very little Fairphone staff involvement here (none of the moderators are staff either). Be sure to include any messages to Fairphone in the support ticket if you want to be sure that they’re read by Fairphone staff.
By the way: some of the testing is also done by enthusiasts here in the community (see here). If you feel there are achievable improvements to the testing process, it may be interesting to have a discussion with the people running the testing programme (though I can’t speak for them - so I can’t promise they’re open to anything right now -, nor do I want to pressure you into anything).

2 Likes

Hello @Johannes

And first, thank you for your message.

Yesterday morning, I sent to an email to Fairphone support, in reply to an email they sent me after opening a ticket (ticket number #118302) with this issue 2 weeks ago. I have not received any feedback yet.
I am now back to using my good old FP1.

Since, after updating my FP2 to 1.5.1, I rooted it -as always- with phh images, in order to exclude any rooting related problem, I could reinstall 1.5.1 then reproduce the problem when unrooted.

But I have been going through 3 problems now. Last week-end, while having dinner, a friend asked me what was happening to my phone since the cover was falling apart after just 6 months of normal use. He was considering buying a fairphone, and even though I tried finding excuses, a long-lasting phone whose cover falls apart after just 6 months of normal use is disapointing. Of course, the cover is replaceable but it’s from fairphone, and it has only been after 6 months!

I would love having at least an hour per week to dedicate to help testing but I don’t have that time right now. Actually, most of the time, I prefer waiting a bit before updating to make sure there are no big problems with the update because I have little time and need a working phone that don’t go suddenly black when I am out.
When I say that there is a test problem, that’s not an accusation, but a suggestion for improvements. Problems happen but it’s important to be aware of them. I am saying that because of the proximity sensor problem then of the black screen display problem, both were undetected before release and it’s important to understand why and what went wrong in the testing procedures.

Regards,
Antoine.

Right, so actually after reinstalling 1.5.1, the bug does not occur anymore. So it is not test-related or fairphone-related, and I got angry a bit too early I guess.
Apparently, it only happens after rooting with phh image (available here https://superuser.phh.me/fairphone/fp2/ …)
Is there any way to contact phh directly to find-out what’s wrong?
I also tried with another image from http://siteactif.org/fp2/FP2-gms59-1.5.1-ota/ and the exact same occurs.

Regards,
Antoine.

@NicoM might know more about this…

1 Like

You could probe this by flashung the original boot-image.

1 Like

Hi!

I honestly have no idea why the root.img does do this… I even have trouble to understand how it is possible.

Currently I am on OpenOS, so I can’t test. Can someone confirm this behavior:

  • Fresh 1.5.1 = no problem with minimal light
  • Flash rooted boot.img = minimal light leeds to black screen

Edit: actually this bug was already here: Brightness can be turned to zero with FPOS 1.3.6 and supposed to be fixed :-/

Could it be that you downloaded an old version of phh’s boot image, which still contained the issue?

I realized that it takes phh usually a couple of weeks after a new FP OS is rlreased, until the boot.img is updated. For example, the current boot.img has the time stamp from Aug. 2nd.
Unfortunately he does not provide a version no. from which package the boot.img is extracted, so one needs to be careful that phh’s boot.img correlates to your actual FPOS version.
I also read earlier that the boot image may change with the OS versions and that some users ran into issues because of the boot image being from a different version than the FPOS version they run.

I usually always made the boot images myself (just takes a couple of minutes for the first set up, then it goes even quicker to create your own boot.img).

1 Like

Actually, I made the boot.img for beta version and as soon as the “real” version is out, I redo it. So I am confident that my boot.img is up-to-date (with latest git update too) and apparently, the bug is also here.

1 Like

Thank you all for your messages.

@Spielmops I reinstalled the official 1.5.1 from http://storage.googleapis.com/fairphone-updates/FP2-gms59-1.5.1-ota.zip
I can confirm that before rooting the display problem does not appear.

@NicoM Yes, I was surprised too that the mere fact of rooting creates the problem

@freibadschwimmer I don’t think so because:

  1. on the 25/07/2016, the following was done:
    => upgrade to 1.5.1
    => Download phh image (named boot-fairphone-fp2-su-eng-r221.img), and the image was compiled a couple of days before that

Then a couple of days later, the problem occurred (at the worst time, I was waiting for an important call and out from home).
Then, to resolve it, as stated in this thread, I reinstalled 1.5.1 then flashed again the same phh image.

Then on the 03/08/2016, it happened again (at the worst time of course again).
I reinstalled 1.5.1 again, but flashed another image from phh (since he updated it) boot-fairphone-fp2-su-eng-r224.img and again, I could reproduce the problem.

Reproducing the problem means:
=> Go to the display brightness setting
=> Bring the brightness to minimal (while keeping the finger on the screen to bring it up otherwise you’re into the black screen again)
=> If, when brightness is set to minimal, the screen is completely 100% black, the problem is reproduced

Then I decided to test @NicoM image and I could reproduce the problem again.

The proximity sensor is also failing as shown on the attached picture with the sensor app running on my FP2.

I had that same issue. This is most likely the result oft a dusty proximity sensor. Disassemble the screen and see if a few strong blows of air (to remove the dust) help.

Hello @Trust

I followed the guide (https://fairphone.zendesk.com/hc/en-us/articles/208661706?input_string=screen+stays+black+during+calls), disassembled the screen (https://www.youtube.com/watch?v=hsop-mM1MZk) then cleaned the proximity sensor (actually it was not dirty but I cleaned it anyway just to make sure).
Here is a picture of the cleaned proximity sensor

And here is a picture of the sensors app showing that the proximity sensor does not work.

Workaround (ADB pre-enabled, no root required)

From your computer, launch on a terminal with your FP2 connected by USB:

adb shell settings put system screen_brightness_mode 0
adb shell settings put system screen_brightness 50

First command disables auto brightness. Second command may not be needed, but ensures brightness level is not low (range goes from 0 to 255).

For future reference, settings's keys can be found in Java constants on the Settings app source code (values in quotes after lines starting with public static final String)

PD: I know, probably few people had ADB enabled before the #blackscreen… but there’s hope for that few people, :slight_smile:

Just to make sure we didn’t misunderstand each other:
The proximity sensor is actually in the “main board”, NOT in the screen. The screen has just two transparent areas at the top for the camera and the proximity sensor. Cleaning these parts of the screen does NOT mean cleaning the sensor itself.

Ok so I suppose that to be able to modify these from ADB through USB, that means:
=> Developer settings enabled & USB debugging enabled as well
=> in Superuser app: Superuser access set to ADB only
Am I correct?
Are these settings creating a security risk? But only when connect to USB, right?

@Trust Ok, so I removed the screen again then really cleaned the proximity sensor this time

And the result from the sensors app is still the same: The proximity sensor is not working.

OK, so it’s probably not a dirty sensor. In that case, it would be interesting to know if the same thing happens with FPOS installed, because as far as I remember, you had the free open-source OS installed, right?

Btw, I’m using Sensor Readout to determine whether my proximity sensor works. Last time I checked before factory resetting my phone, it worked. After the reset, the sensor does not seem to work properly…

@Trust I am usually using the last official release rooted with phh or @NicoM images.
But right now, to run these tests and make sure there is nothing else related, I am using the latest official release (1.5.1) unrooted (installed through adb sideload ~/Downloads/FP2-gms59-1.5.1-ota.zip ), and with no other change than that.

I just ran a test using the sensor readout app you mentioned with the proximity sensor (“lt1pa01 ALSPRX”): It does not work either.


And during calls (or worse, whatsapp messages), the phone cannot be accessed and is always black.

Sorry for the delay answering, @Antoinet. Superuser access is not needed, only ADB. The ADB shell runs as a privileged app (because it’s part of the system) which can run settings and modify system settings, but doesn’t need root.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.