English

Sometimes wifi never connects or finds any wifi at all. Happened twice already since upgrade to FPOS 2018.09.2

wifi
Tags: #<Tag:0x00007fefbd91f398>

#1

Upgraded FP2 from 2018.04.x (last one with Android6) to 2018.09.2 (Android 7.1.2).

After a day or so, I first noticed this situation. Waking up the FP2, having a lock screen with PIN. Already seeing in the locked state, that the wifi is disconnected. Extending (swiping down) the notification area, also fully extending it downwards with more symbols, the wifi symbol sits there greye with a question mark.

The phone comes back from sleeping, with plenty of battery left (FPOS 2018.09.2 is actually quite a lot better with this Android7 than Android6 state was before, so thank you already for this improvement). The sleeping time was maybe a few minutes or also a longer time. Doesnt seem to matter to this situation. But I have little statistical relevance as this happened to me the sencond time already with this FP2 as I am writing this thread now.

When unlocking the FP2, going into wifi details, it shows, no wifi networks available. Being close to wifi networks though that I have configured and pre-defined. No matter if WPA2 protected wifis or unprotected wifis. It finds, displays and uses none, even though they are available and present, e.g. with other devices, a laptop or other Android based tablets etc.

I think I pretty close to never or very very rarely had this situation on the Android6 levels of FP2.

When I completely disable the Wifi, and re-enable it back, it then finds quickly the wpa2 protected wifis in the vicinity, and then a little bit later shows the unproteced wifis too. Eventually it connects to defined wifis and it uses them, acquires internet connection and everysthing is back to normal and fine.

My usage of FP2 is the following: I dont use this one as a phone, but rather as a tablet, always on airplane mode, but wifi mostly being left turned on. No sims, no nothing fancy. Simple apps from Android/Google play store.

Any clues? Bug? Needing to report? Anyone else reproing or experiencing these problems? Thanks.


#2

Sounds similar to issue 36 in the bug tracker.


#3

Okay cool thanks for hinting out that bug, will observe there. Thanks.


#4

Same/similat here. WiFi doesn’t reconnect after going idle or leaving the area and reentering it.
It doesn’t help to switch the WiFi off and on.
If I do a new start it connects again.

Thanks for the link to the Issue 36.
I’ll try the flight mode and tethering tip.


#5

I have also experienced this issue since upgrading to 18.09.2 - I can’t resolve by disabling and enabling wifi, and the WPS push button doesn’t work either. I can see my router in my saved networks, but neither this, nor any other nearby routers or open wifi networks are available. Refreshing doesn’t work either. I can only resolve the problem by restarting the device.


#6

Hello,
I have the similar issue since last update.

I have to manualy reconnect to know wifi when i use to have automatic reconnect.
The on/off wifi button is not working properly

Reboot and Airplane mode doesn’t solve issue.

Regards,

Kevin


#7

As with yesterdays Fairphone OS release 2019.02.1, so far, but after only barely half a day of uptime of the rebooted fairphone2, my gut feeling is, that wifi stability, wifi reconnection and wifi connection to public wifi places seems to be much better than with still the initial Android7 release from October 2018.

this is my experience so far. Fairphone2 wakes up quickly, seems to be better performing overall as well, but maybe it is only due to the fresh reboot. Usually I have very long uptimes and never shut down or boot the phone.

We will see. Keeping my fingers crossed.


#8

Here also the same problem. When I change location, say from home to work, then all the new wifi locations are not recognised. The Wifi is not refreshed, and as such also no new connection is made. I can resolve my issue by rebooting the phone, but this should not be the case.


#9

Exactly the same here.
WiFi list will not refresh - only way is a reboot, every time. Started about 2 weeks ago. I ran the updater last night and I now have 19.02.1, but the problem persists.
Very tedious. Help!! anyone?


#10

According to bugtracker the problem is “confirmed” but not solved yet.
BTW.: have you tried both other workarounds (than reboot) mentioned in the issue workaround section?


#11

I hadn’t tried airplane mode on/off, but I will.
I don’t know what wifi tethering is …?


#12

That’s using the wifi hotspot mode.


#13

This morning I toggled both settings, then went out. My phone went berserk with new WiFi options.
Tonight I came home and it did not refresh. I toggled WiFi off/on, still nothing. I toggled airplane mode on/off, success, a refresh. It’s marginally better than reboot but still a very manual process.
Tomorrow I’ll try toggling hotspot mode instead.


#14

I’m having the same problem since the upgrade to Android 7. I’m on the latest version, 19.02.1, I have always had Keep Wifi on during sleep set to Always.
Switching wifi on and off usually works, but I can’t always remember to do that and it means I sometimes go over my mobile data limit :frowning:
Looking forward to a fix :slight_smile: