[solved] Stuck in "very slow" charging mode

Hi Fairphoners,

I had a big issue with my Fairphone 3: impossible to charge correctly since 2 weeks.

The exact behavior is:

  • charging takes 24h for 30%
  • the charging icon is never again in speed mode, no more little lightning in the battery icon
  • the LED indicating the charge was sometimes visible, sometimes not…

My setup is:

  • an official FP3 with pre-installed Android 10, fully updated, bought few months ago on the official store
  • 2 officials chargers and cables for tests
  • a new battery for tests
  • clean charging pins and no bad use of the phone since the beginning

I tried everything in my power, described here:

  • My FP3/FP3+ is not working. What can I do? – Support
  • all posts on forum with a related subject
  • factory reset, fully unmount, clean, let it down 1 day, reset while waiting a minute on the button, even voodoo stuff
  • pin/unpin from several points of the wire
  • the phone support in not responding at all since 2 weeks, “because of fairphone 3+ launching”

Today, I tried something new, just because I was boring: put the phone in plane mode, then normal, then plane mode… 3 times in a row. Then pin again in plane mode, and: miracle, I just recover the normal charging mode !

I don’t know at all what hardware/software/voodoo worked here, but I wanted to share this strange experience with you.



Just out of curiosity. Did you check if you USB C port on the phone has dust and dirt in it? This prevents often from charging right and maybe because you tried so much it came out without notice. Just a thought. I do use Fairphone since Version2 and almost all in our family do. So far none of them had charging issues but that does not mean it does not exist.

I had the exact same problem only a couple of weeks ago.
Your airplane mode trick sounds so peculiar that I hope it’s not only a temporary “solution”.

I ended up having to send in my phone to the repair center, as they couldn’t determine whether the problem would lay in the bottom module, the core module or the battery.
They ended up replacing both the battery and the bottom module.


  • The UPS shipment and the repair service are pretty fast. I got my phone back in just over a week
  • Problem solved. The phone is fast charging again as it should.


  • Charging should not break this easily. I’ve only had the phone for 6 months.
  • The module system works great, so I could have repaired the phone myself if they’d shipped the replacement parts to me.
  • The phone was completely wiped and reset to factory mode. They warned this was possible, but it’s not needed at all for only replacing some parts. With backups, this is not the biggest deal, but setting up all apps again, restoring backups, resetting authenticators, … it becomes a big hassle.

So, I hope your solution holds up!


On the USB port dust etc.

I bought a full case so I could insert a thin piece of plastic material covering the USB port stuck inside the cover, this means I remove the cover when I charge the phone.

Good for you. Just trying to help.

I assume they did it during the analysis of the problem.

1 Like

My understanding is that to repair any phone at source, except for a clearly damage component, like a screen etc. there will be a factory reset to remove the possibility there is any OS problem, so I’m surprised FP said maybe. If they had come to the conclusion that just a module replacement would work they would most likely offer to send you a new module.

I would never ship a phone with personal data on it. So as long as it is working, I would wipe it before shipping for repair anyway.


The shipping instructions simply say “make sure you have a backup”. And sure, my pictures and contacts are at Google, my files are on Dropbox, … but if they would have stated “We WILL wipe your phone”, I’d have taken more care to export the (quite extensive) settings of my email client, disabled 2-factor auth for a few accounts, etc…

But the point @Incanus makes below, that I was too trusting to not wipe my phone before shipping anyway, is also a valid one.

Anyway, all this, just to support @chiffon in the fact that he’s not the only one with charging failing this way, shortly after buying the FP3.

1 Like


I am experiencing a similar problem as listed above.

As of yesterday, my phone will barely charge. 1-2% per hour, and is down at 20% battery.

When I connect it to a USB power charger, it only draws 0.06A, and charges very slowly. Using the exact same cable and charger, another FP3 can draw 1.45A, so it is not the cable and charger. I have also swapped the battery with another device, and this make no change to either device, so I do not believe it is the battery.

Based on the suggestion above, I restarted and cycled the airplane mode a few times, and this seems to have fixed the problem (the phone is able to draw 1.4A, and is charging at regular speed.) However, sometimes the airplane mode cycle works, and sometimes it doesn’t.
This seems to not be a one-off problem

I tried updating software to the latest version, and the airplane mode trick seems to have stopped working, so it is now constantly stuck in Slow Charge mode.

To me, it seems that the phone is getting stuck in slow charging mode, when it switches off the Qualcom Quick Charge: FP3 Slow Charging - #6 by teezeh


  • With the restart and cycle of airplane mode, is this likely to be a software issue, or a hardware issue?
  • Is the charging circuit in the “bottom module” of the FP3 - Would there be any value in purchasing and swapping out this module?

Any help or suggestions welcome

Your FP3 is still under warranty so you shouldn’t have to purchase.

Referring to my issue that you linked to, after almost 3 months I’ve just about given up having any meaning full discussion on the issue, but it won’t hurt for you to put in a similar support request, which you need to get the repair, if it is bottom module etc.

And I do think also that the Qualcom switching isn’t happening and I get mostly 5hours to charge, a couple of times1.5hours all from the same 5V 2.4A supply??

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.