[Solved] SMS send takes unusually long

Hi Fairphones,
when I send a SMS from the FP3, it takes ~ 1 Minute until it is sent. Same SIM-card in old Smartphone: basically immediate sending. Tried with stock Messages App and with Signal - same effect. Not critical - SMS goes out in the end, but - unusual.
Any ideas what may cause this?


Have the same issue, though I never thought this was unusual, as I rarely send mails, but it is indeed quite slow.

1 Like

What about this here … could that help? …


Hi @AnotherElk,
thanks for the hint, but I cannot find this setting under “Details”. Would you mind to send a screenshot?
Thanks a lot!

@fp3user9: Could you upload a screenshot?

I don’t use the stock Messages and Contacts Apps and uninstalled them.


Very good Information, thank you!

I suppose that exist only in the german Version.
If you already sent a message (i suppose it was a new Chat) you should select the Person/contact from the list of Messages and after that you will see the list of all Messages of this Person, then on the right top menu you will find at the first Position “Details (German Version)”.

Hi @fp3user9,
I have the German version, I do see “details” and can navigate there, but the “Nur SMS und MMS senden” item is not there… Thats why I’d be interested in a screenshot, just to make sure I am not too stupid :slight_smile:

1 Like

That is very strange, probably we have different Android 9 pie Versions of FP installed,
i suppose i have the 0110 of January 2020, preinstalled in my FP3 or
the Data of the Messages and i suppose that do not depend on the Mobile Network Provider.

Now i do not have the FP3 with me and as soon as i have it again, i will try the screenshot.
By the way, how can i create a screenshot in FP3 with Android 9 pie, i got the FP3 just last week?

Press Power and Volume - simultaneously, then release them.
There will then be a notification about the screenshot.

1 Like

Thank you, i will try it!

Here is the screenshot.
I have notice that the option will not be displayed for all Contacts,
because in the list of chats i have 3 persons/contacts and only for 2 of them, the option “nur SMS…” is displayed, probably because for this 2 persons i sent to them the “chat” messages (default) first and for the last person i have received a SMS before i sent a message responding, but i just suppose that, i am not sure if that is the reason.
Hopefully it helps you too.

Thank you very much! For me indeed the setting is missing:

All my conversations were started as SMS, so I suppose you are right. So no luck here, but does not really matter much - the SMS goes out after all, if only with a tiny bit of delay - nothing of much concern.

Edit: Btw - Screenshot is even more easy with Pie: Just long-press the On/Off key - three options: Restart, Switch off and Screenshot.

1 Like

Yes, I agree, very good, thank you!

Which carrier do you use? Have you tried getting a configuration SMS sent to your FP3 from your network operator?

On my FP3 sending SMS works in near real-time. T-Mobile DE, default messaging app, no matter if RCS is enabled or not.

1 Like

I have already received a SMS/MMS sent to my new FP3 from my network Operator T-Mobile DE, right after inserting the SIM-Card, which i used to have it on the old Smartphone Windows 10 Mobile and this old one was allways sending SMSs in near real-time, that’s why i was asking me, what was happened with FP3.

I have also recognised the same ~2min SMS sending delay with a FP3 from the first batch as well as one of another later batch. Using QKSMS and Telefonica network.

Hey There,

I have a problem with the sending of my sms. They take a loooong time to get send. Sometimes it takes like 3 of 5 minutes before they go. It’s impossible to use sms for urgent information or to discuss.
My sim card is ok and apparently it is not my mobile operator (Orange). I test sms with an old phone and the sms are send instantaneous like they should be.

If you have this problem too or if you can help me, tank to react :slight_smile:

1 Like

Welcome to the community forum.

I moved your post here to avoid duplicate topics. Please have a look around.

1 Like

Good idea, probably it is the same behaviour like the others here.