English

[SOLVED] Problem with rooting FP3

Hello there !

I’ve got some troubles with twpr and magisk. So I come here hoping that you will be able to solve my problems.

Summary:
I’ve tried to follow this method (How to root the Fairphone 3?), and I’ve fallen in problems. Finally, I’ve used the last comment of this reddit discuss to recover my phone : https://www.reddit.com/r/fairphone/comments/exrxt5/how_to_flash_lineageos_or_any_other_custom_rom_on/

Now I try again this method. And the first time I launch twpr with fastboot, I get a message with mkfs2e and sd-ext :

 Formatting SD-EXT using mke2fs...
 mke2fs -t -ext4 -b 4096 /dev/block/mmcblk1 3789824
 process ended with ERROR:1
 Unable to wipe SD-EXT
 Unable to wipe /sd-ext
 Updating partition details...
 ...done

(I hope there arn’t typos, I’ve copied manually) I get the same message if I try to wipe in the advanced menu of twpr.

Then, I’ve tried to follow the method with twpr and magisk and I fall in a boot loop with an orange corrupted system message and then I have to make a choice between “Try again” and “Factory data reset”. (and if I push the on/off button, the phone reboots immediately).

Would someone have an idea to help me ? :slight_smile:

More precisions :

  • On the fastboot screen, its written : “INTERNAL STORAGE SIZE - UNKNOWN”
  • OEM is unlock. (of course)

edit1 : To get a woring phone again, i’ll flash again with stock rom A105, and get these following errors :

Invalid sparse file format at header magic
Sending sparse 'vendor_a' 1/2 (519509 KB)   
[...]
Invalid sparse file format at header magic
Sending sparse 'system_a' 1/5 (522235 KB)    

And the same when I flash the other slot. But that works and I get a working phone again. but i’d like to get a rooted one :’(

The reddit post isn’t updated and is based on this thread, you should refere to it.

Please try the Flash back stock ROM section. Also, there is everything you need to root your FP3 on this thread. If you have any issue, take a look on the Troubleshooting tips.
Finally, you should read the entire first post before doing anything.

1 Like

I’ve just flashed back. I’vnt seen this thread before. I’ll go and follow these instructions and come back if I go through some problems again.

I don’t know how I might not have seen this thread before doing afternoonwide researches. But thanks ! With this HOW-TO, I’ve installed Magick successfully. For now, I’ve other problems with uninstalling gapps, but I’m going to open another thread to stay clear.

I think the problem was I didn’t check whether the two slots were success or not.

THANKS A LOT ! <3

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.