English

Rooted phone, how to uninstall gapps and get a terminal?

Hello there !

After some troubles (described here ), I’ve got Magisck installed on my FP3. It’s the first phone I root, but I’m not a newbie on Linux-base system (I have been an Arch for a few years, and Linux for a longer time).

Now, I’d like to be able to do 2 things :

  1. Uninstall gapps that are not necessary for the system.
  2. Get a terminal in order to be able to (by example) execute some for arm64 elf files cross-compiled from my arch.

Of course, I’ve searched trough Internet to get methods to do this. I’vnt tried to perform the second goal, but my problems with the first made me come here to get help.

I’ve tried to uninstall with many applications the gapps, but they never got uninstalled. I’ve tried with NoBloat Free by example, and I click on “uninstall”. Aaaaaand, the app is still here, and when I go again in the installed app list in NoBloat, the app is again here.

And that the same for the other applications I could use. I’ve so tried to use adb shell pm uninstall and … broke my system. (bootloop) So, I’ve flashed back to the stock rom and reinstalled magick, and got a functionnal system.

So, would anyone have tips for uninstalling gapps on FP3 ? And get a terminal in a rooted one ?

(Because I’ve broken my system, and I’ve already flashed back my system 5 or 6 times, I want to be sure of doing safely the things I want)

Thanks to all you could bring me piece of solution ! :slight_smile: