[Solved] Orange FF3: Firefox and others apps take a tremendous time to load

I just bought a fairphone3 form orange France (a mistake?)
I would be very happy with the device if it was not for this software problem (I hope it is not hardware).

In short some apps are taking a tremendous time to boot (many minutes) and then they work super fine.

Apps that do not work

  • Wire (stays stuck on the boot logo screen forever)
  • firefox (needs 10 minutes to load and then fine, does it again after being killed), same for firefox preview
  • Microsoft edge (stays stuck)
  • Facebook messenger (took 10 mn to load the first time, never did it again after being killed)
  • Nova launcher (takes 1 mn to load when starting phone arg…)

Apps that work

  • facebook
  • acalendar
  • Chrome
  • All apps installed by default

The notable things I did:

  • I first used and updated the phone with a sim card from another operator (free France)
  • I noticed that some app updates/installs would only work though cellular network and would get stuck using my wifi (waiting for download, or download stuck at 99%, I am not using a vpn)
  • I have Android 9 update from 5th of april 2020 (that updated through wifi)
  • I was using Nova launcher but scraped it because it takes a long time to boot
  • I have a feeling that the android update did not quite go as planned and the OS is corrupted somehow. But when I try a factory reset the android version is still the same (not an actual factory reset surprise…)
  • I did not contact fairphone support yet but probably will. And Orange support is out because of COVID.

Things I tried

  • Fake factory reset
  • Reinstall firefox
  • clear data and cache of firefox
  • Removing novalauncher (it was the first app I installed)

Does anyone encountered the same problem around here? Does anyone have any idea how to solve this ? Does anyone know how to do an actual factory reset ?

Thanks to the community for taking the time to read this ^^

I use some of the apps that you’ve mentioned on my FP3 (German, Telekom SIM) without issues, so the FP3 is not the culprit here.

I think I would try the factory reset as described in

Good luck!

Thanks @teezeh !
Unfortunately I already tried that if you mean :

Go to: SettingsSystem → open AdvancedReset optionsErase all data (factory reset) → push the button Reset phone .

Also that is not a factory reset but a cleanup of personal data. All previously applied security updates on the android system for exemple will remain.

1 Like

I found something.
Apparently when I remove my sim card from the old operator and use the phone only through wifi everything is normal again.
I need to find another working sim card to tell you if it is sim card related or operator related.

I’ll you you updated


I will have to wait until I have access to a friend’s sim card to see if orange locked the phone in any way and caused the bug.
I will update that thread as information comes.

FF3 rocks, I absolutely love it <3 (screen is nicer on my eyes than my previous phone, looks raaad, calls are crystal clear)

Ok I have definitely narrowed down the problem.

It was because I had a busted SD card inside my phone. Or perhaps it was formatted to be part of the memory of my previous phone, and the new android (or the fairphone it self) did not like that at all.

Everything is back to normal ^^


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.