[SOLVED] APN disappears when changing MNC


I created a new APN, entered the settings as mentioned my the provider, saved it, and it’s gone.
When I don’t change the MNC (07 by default), the APN does not disappear. But I need it to be 02.

Long version:
I’ve purchased a new LTE contract from WinSIM which uses the O2 net. I wondered why the best I always just get G or E when my prepaid SIM (Fonic, also using O2) can receive H and H+.

So I contacted my provider and asked for the APN settings. This is what I should configure:

APN for Internet:

Name: O2 Internet
APN: internet
APN type: default
Proxy: Not set
Port: 8080
Username: Not set
Password: Not set
Server: Not set
MMS proxy: Not set
MMS port: Not set
MCC: 262
MNC: 02
Authentication type: do not define (same as “Not set”?)
APN protocol: IPv4
APN roaming protocol: IPv4
APN enable/disable: APN enabled (tick)
Bearer: Unspecified

Most of this is already set by default. The MNC however is 07 by default. If I change it to anything but 07, the APN will vanish without any warning or message as soon as I leave/save it.

Interesting in that context is that I do not get internet with the WinSIM card if it is in slot 2. The Fonic card has internet in either slot, though.

Also interesting (maybe in this context) is the fact that the SIM card in question does not show it’s number in the SIM cards settings, though it has one and I already called and received calls with it, so it obviously works. And in the APN settings, I cannot set the preferred network type for the WinSIM card while I can set it for the Fonic card. (Screenshots below)

So far, I’ve tried everything I could imagine. Resetting to default APN settings, swapping SIM cards, rebooting after every change, leaving settings untouched. Nothing helped.

I cannot tell whether this is a phone/hardware/software or card problem. I would be really happy if somebody could help me here.

Forced 2G network type on WinSIM:

4G network type (changable) on Fonic:

If I look at my Cellular network settings, then I also see only the line Access Point Names
and under Network operators I see the line Choose a network operator.
When I tap on Access Point Names then I see the name of my APN and tapping on the name brings my to the specific settings.

Is this the same at your phone?

So you’re in Germany. Which means:

Is the Vodafone D2 network.

Which is the O2 network

So it should be on MNC 07, as far as I can tell.

Your connection to the network seems to be working, as you do get calls and data (GPRS/EDGE) over 2G on the O2-WINSIM network, so it’s unlikely that the MNC needs to be different. Now here’s the thing - the phone can only handle one 3G/4G connection at a time. If I recall correctly, the FP2 settings are slightly odd, in the sense that you’ll have to set O2-FONIC to 2G only, before you get the option to set O2-WINSIM to 3G/4G. Hope this helps!

EDIT: Forgot to mention - the reason the APN disappears is because it only shows APN settings that are relevant to the current network the sim is connected to. As it seems to be connected to MNC 07, changing the setting to MNC 02 makes the system ignore APN as irrelevant to the current connection. You’d need to force a connection to the other network using manual network selection (different options menu altogether) - but as stated above, in this case I believe you’re on the right network and the 2G/3G/4G toggles are your actual problem.


You’re right. This kind of setting is rather odd. :grin: But thanks for pointing that out! It indeed works that way!

Good thing to know. Thanks!

So now the only thing that remains is this not-displayed phone number. But I assume that’s a SIM card problem and since the other problems are solved now, I consider this issue solved.

Best regards,

1 Like

Yes, that depends on the SIM card. I have two of them and both don’t show their number in the settings. But since the numbers are correctly transmitted to the recipients of calls and messages, it’s not a real problem.

1 Like

For me it is as you see it in the screenshots. Regarding the Access Point Names, yes, it’s the same.

How would I do that?

I also have a FONIC/winSIM combination in my FP2 which both don’t show their own phone number, too.

In the dialogue which you screenshot, the last entry (“Network operators”).

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.