English

[solved] Adb reboot bootloader linux problem

Your help is much appreciated, as I am stuck in the FP2: Fairphone Open 19.11.2 release.
I always install OpenGapps after a release on Fairphone Open.
The problem arises now the 19.11.2 release replaces TWRP with AOSP recovery.

On my computer with Fedora I have done the following:
as root
$dnf install android-tools
$dnf install usbutils
$lsusb
Bus 003 Device 009: ID 2ae5:9039 Fairphone FP2
ls -l /dev/bus/usb/MMM/NNN
(in my case:
ls -l /dev/bus/usb/003/009 )
$groupadd androiddev
$usermod -aG androiddev lidwien
create the file /etc/udev/rules.d/99-android-debug.rules with the following content:
SUBSYSTEM==“usb”, ATTR{idVendor}==“AAAA”, ATTR{idProduct}==“BBBB”, GROUP=“androiddev”, MODE=“0664”
(in my case, see the output of `lsusb’:
SUBSYSTEM==“usb”, ATTR{idVendor}==“2ae5”, ATTR{idProduct}==“9039”, GROUP=“androiddev”, MODE=“0664”)
$exec su -l $USER
as root
$udevadm control --reload
$systemctl restart systemd-udevd.service
$exit [to become a ‘normal’ user]
$adb devices
List of devices attached

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    265f65b device
    $adb reboot bootloader
    now I see a blue flashing led on the phone and the screen is stuck displaying
    FAIRPHONE
    POWERED BY
    ANDROID

What do I have to do to be able to give the command
fastboot flash recovery twrp-3.3.1-0-FP2.img

Other question; in which file do I need to put the twrp-3.3.1-0-FP2.img

Hmmm … I’m not a Linux user, but adb and fastboot seem to be installed, phone is connected, adb seems to work, phone is in fastboot mode (that’s the logo screen with the blue light flashing) … So, why wouldn’t this work?
Did you try to run the command?

If you run fastboot flash recovery twrp-3.3.1-0-FP2.img just like that, twrp-3.3.1-0-FP2.img would have to be in the path in which you run the command.
Else you would have to give a path to the file, e.g. fastboot flash recovery /home/user/Downloads/twrp-3.3.1-0-FP2.img

If fastboot doesn’t work at first, be prepared to try as root or with sudo.

4 Likes

Yes, I tried to run the command:
fastboot flash recovery /home/lidwien/fairphone\ 2/twrp-3.3.1-0-FP2.img
But I got “waiting for device”

But your my hero! :heart_eyes:
I needed to run the command as root.
Now twrp is working.

You made my day.

3 Likes
3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.