Software update Kola Nut 1.8.7 is ready - Stagefright fix

Hi Urs,
super, vielen Dank!
Ok, sobald ich mich traue :wink: und genug Zeit habe, versuch ich den offiziellen Weg. Hatte noch keine Probleme mit dem Cache, bin also erstmal ganz zuversichtglich. :wink:

Backup vor dem Storage Upgrade nicht vergessen. Und Google Apps müssen am Ende neu installiert werden, falls Du die nutzt. :slight_smile:

Die nutz ich … und das mit dem Backup, genau, das ist noch die Sache, vor der ich mich ein bisschen scheue. Ich hab immerhin schon mal Titanium Backup installiert… :slight_smile: Danke!!

I would like to translate your answer to English so the rest of our community also knows the anser to the question:[quote=“urs_lesse, post:79, topic:9638, full:true”]
The officially recommended way is to first apply the update to 1.8.7 and THEN the Storage Upgrade. However if you have had problems with your cache regularly, a different solution might work for you. But first, try to do it the official way.


I successfully updated my Fairphone back in August to Kola Nut 1.8.7.
After reading the Fairphone Blog about “Long-term software support for Fairphone 1” I checked my phone with the Zimperium app.

And this is the result:

What now?


Those two CVE’s labelled in red were added to the app last week. They probably refer to what is being called Stagefright 2.0. See also here. This is quite recent, and it isn’t clear what the impacts are, or what patches will be available for which versions of Android. So for now, we wait.

1 Like

Thank you for the clarification.

Doewnloaded this like 6 times now and it still prompts me to download. What do I do?

Have you checked in “Fairphone Updater” whether you still aren’t on 1.8.7 ?

I’m still on 1.8.5. How do I make it complete the installation?

Have you encountered any error message in the process, like “not enough cache”? Does your Fairphone have a “phone storage” plus an “internal storage”?

Doesn’t say any errors. I contine the restart and then it prompts it again.
Not sre if I have extra storage? how do I check this?

Try setting the screen to stay awake (Settings > Developer options >stay awake) and plug in your phone. For some people this has solved the problem (e.g. here).

Edit: Or see a number of different posts in this thread, whoops.

1 Like

I hope this complete collection is useful for you: :slight_smile:

1 Like

Hey, I don’t want to open a new thread for my questions:
After finally updated my sisters FP1 form OS 1.6 (1+12GB) to 1.8.7 (13GB) I encountered this problem:

  • In the default camera-app of android, there is no button to switch to the back camara (at the screen side), only the main camera works.

Any solution for this?

Only for my interest are the following questions:

  • What’s about the second SIM-network symbol in the status bar? I thought it will be not displayed anymore if only one SIM is used? But it is not the case for me - or is some setting neccassary. (of course GravityBox is doing the trick).
  • I still don’t have any informatoin, if the well known “14% battery problem” was adressed in any of the FP-OS updates until now…somebody knows more?

Cheers, Robert

The button is located at the red arrow. You don’t have that?

Yep, I know from my own FP1 :wink:
But unfortunately it is NOT available at my sisters FP1 after update…any guesses?

  • Camera: Happened to me once, kill the camera app and try again! :wink: This worked for me.

  • The second SIM network symbol will always display, if you do not hide it with Gravity Box.

  • I think it was already addressed with 1.6, so if you’re still encountering troubles, the battery might be bloated.

PS: If you are not sure, the update works as it should, you could run it again.

If that doesn’t work, see here on testing cameras. I know it’s about front facing cameras, but the procedure is the same for the back-facing camera.

1 Like

I know I´m late with updating my phone on Kola Nut 1.8.7.
My phone currently runs on Kola Nut 1.8.5.
Downloading and installing works perfectly fine, unfortunately when the phone reboots it states that there is “no command”.

I`ve already tried to install it manually (, I followed it till step 5. Then it said installation aborted.

Any clues how to solve this problem?

Thanks in advance.