Software update Kola Nut 1.8.7 is ready - Stagefright fix

So far my attempts at installing the update have been going like this:

  1. Get message update 1.8.7 is available: fine
  2. download update: fine
  3. restart phone: fine
  4. android robot flat on it’s back with exclamation mark “no command” : uh-oh…
  5. wait a bit…nothing happens…: uh-oh…
  6. press on/off button to enter recovery mode, reboot phone: fine
  7. phone starts up as if nothing happened and back to step 1

I wouldn’t mind installing the update manually (again…), but I don’t understand why apparently these updates go smooth on some phones while on others they don’t work at all?

Either way, any suggestions are most welcome, thanks

1 Like

Plug in your phone to charge it, go to settings > developer options and tick stay awake. The screen needs to be active during the update at all times.

Already tried that and just tried it again, but to no avail. I keep getting the dead robot (no command).

This guide should help you in that case.

Very good tipp. If you forgot, like i do regularly, you can make Google call you or send you a message with a working code.

1 Like

Hi Paul, thanks for the hint. I followed the guide, but my phone didn’t show the folder “updater” and a few other folders were missing too. Why is this?? Anyway, I rebooted the phone again, used file management to cut and paste the downloaded zip file to a folder that did show up in recovery mode (\storage\sdcard0\updater) and followed the guide again, which seemed to work this time.

Thanks for the help,

edit: so I’m having the same problem now when reinstalling the app store. The updater downloads the file ( to te folder (\phone\updater) but on restart i get the dead robot again. I will try moving the file to a different folder and isntall the store manually I guess
edit 2: yup, that did the trick as well.


All fine here, too (with screen activated while downloading and updating!).

1 Like

A post was split to a new topic: Contacts missing 2 days after update

Dear Fairphone Team,

Everything went perfectly. Thank you very much! :kissing_heart:



I think in my case the update worked even with a black screen inbetween.
I did not activate the “stay awake” option and the phone was not connected to the charger all the time …
But update worked completely fine!

Yes that stay awake trick is not necessary for everybody and of course the screen will be black a few seconds during reboot.
But sometimes the screen will go to sleep before or after the reeboot and the thing will go wrong.

I am a real clever phone novice. When I look at right page to install Google apps I do not even get this:
Scroll right ad find Menu Button… I scroll right and do not have a menu button. what does it look like?
What is a menu app and where can I find all these updaters?

Are you talking about step 3 in the interactive tutorial?
If you don’t have that widget with the menu button you can also get there by performing an edge swipe.

I have tried to install 1.8.7 about 8 times now. It doesnt work… I kept my screen active, i deleted all the cache yet nothing. It downloads everything but when i click the ‘restart’ button it shuts down, and then i get the android figure saying: ‘no command’.
So am lost…
Hope u can help me :slight_smile:

oh., so i restarted the phone and it works normally but with 1.8.5…

Try again and when you get to the no command screen follow this guide:

Yep… this did the trick. Thnx! Now reinstalling Google apps

1 Like

This update has been running smoothly on my FP1.
Thanks guys

Also for me, updated to 1.8.7 without any problems!

1 Like

How many downloads were made for how many fairphone? Reason: I wonder if this update is causing less problems in the forum because it is better or if some people - like me - didn’t update yet?
Was any analysis about that already made?

(Honestly, I take the risk of become a stagefright as long as the update may spoil my phone again like the last time.
MMS download, etc. is already deactivated and a firewall and a virus scanner are installed since a long time.)

A big thanks for this very valuable advice of “cache clearance”. I have been having problems for weeks now, and had not found anything and had no success even after reducing my numbers of extra Apps down to 5 and clearing their caches.

I had hoped downloading the 1.8.7 Kola Nut update would help but it didn’t. Infact I was seriously considering going back to my Apple iPhone, which I NEVER HAD PROBLEMS WITH (except how it is manufactured, supply chain sustainability etc.)

After following these instructions, for the first time in about 3 months I have a fully functioning Fairphone again.