Software update: FP4.TP2D.C.0112.20240313

Release date: 4th April 2024
Android version: 13
Software Version: FP4.TP2D.C.0112
Security Patch Level: 5th March 2024


  • An issue that was causing the screen brightness to drop when entering the Camera settings has been solved.
  • An issue that was causing the “Display network name” feature not to work as intended has been solved.
  • An issue that was causing the battery capacity not to show correctly on third-party apps has been solved.
  • An issue that was causing the Settings to be unresponsive when exiting Guest mode has been solved.

The update was flawless and successful.


OK here too, so far.

Nice, this finally works as expected.

Cool, I was quite confused by this (it used to report 3300 mAh instead of 3905).

1 Like

For me installation fails after removing Magisk and reboot the phone. The error is too generic to guess what the root cause is.
After another reboot I still cannot install the update with the same error.

Also on my side no issues (stock Android without any rooting).

Vanilla went through fine for me as well.

The error is cause by a checksum mismatch and I am still searching for a way to work around that. Any idea is appreciated

04-07 09:55:17.932 1663 1663 E update_engine: [] The hash of the source data on disk for this operation doesn't match the expected value. This could mean that the delta update payload was targeted for another version, or that the source partition was modified after it was installed, for example, by mounting a filesystem. 04-07 09:55:17.933 1663 1663 E update_engine: [] Expected: sha256|hex = 26D983B114AFD6E18F1692BC60C3073A850711F90CDEA6B0FCCAE84526BB2883 04-07 09:55:17.934 1663 1663 E update_engine: [] Calculated: sha256|hex = DE99A29DA1F76EFF1C2E81030C84B235279397A1E8AAB3F89A43BCF2533F1590 04-07 09:55:17.935 1663 1663 E update_engine: [] Operation source (offset:size) in blocks: 0:824 04-07 09:55:17.936 1663 1663 E update_engine: [] source_fd != nullptr failed. 04-07 09:55:17.937 1663 1663 E update_engine: [] partition_writer_->PerformDiffOperation( operation, error,, buffer_.size()) failed. 04-07 09:55:17.938 1663 1663 E update_engine: [] Failed to perform BROTLI_BSDIFF operation 0, which is the operation 0 in partition "xbl" 04-07 09:55:17.939 1663 1663 E update_engine: [] Error ErrorCode::kDownloadStateInitializationError (20) in DeltaPerformer's Write method when processing the received payload -- Terminating processing

BTW, this happens also when I try to run the ota manually via sideload

Havent read the error codes, is it the same?

FP5 however similar?

I guess I found the root cause: The system images in the two slots seemed to be different. After syncing those the update did not run into the error again.

EDIT: Not that backup process ended successfully. It’s always surprising again and again, how things work perfectly fine if you do it right :stuck_out_tongue_winking_eye:


Usual link to the and a Magisk patched-boot.img in case someone needs it (forgot to pull a stock boot.img this time, sorry).

Have fun :slightly_smiling_face:


Anyone on EE UK got this update yet? I’ve no sign of it and I usually get these on the day of the FP notification. Updater says I’m up to date but it’s the last update Build code.

I am also still waiting for the latest update. My security update says I am still on January but I think I have had an update since then.

I am running FP4.TP29.C.0101.20240121 so maybe not judging by the last few digits.

Same here: I’m also in the UK on EE (via 1p Mobile). Has anyone in the UK received the update? What should we do to get it? Thanks!

Thanks - I suppose we wait for EE to get round to releasing it! Mine is on a two year agreement about to run out but I’ve stayed with EE SIM only. I’ll see if the update comes along next week when it changes over. If not I’ll try contacting them to see what’s happening. They’re usually very quick to release an update so it’s strange they haven’t this time.

I just wondered if anybody in the UK has had the update yet, not just on EE as I am still waiting?

On O2 UK, got the update the day it was pushed.

1 Like

Thanks for confirming that is is on O2, so it suggests it is an EE thing. I am getting horrible flashbacks of previous phones of having to have multiple sims to try to get updates.

I assume my only other option would be to try manually updating as the networks are never any help for updates but I have never done this so am a bit nervous.

If you want to force an update, just

  • turn off the phone and remove the battery
  • remove the SIM
  • put the battery back in and turn on the phone, using (need I say) a Wi-Fi connection.

Go to Settings > System > System update
If necessary, tap the “Check for update” button bottom right.

Please be aware, that delays with an update with a specific carrier may mean that there’s a problem that they need to sort out before pushing it on to you, so it’s usually advisable to wait. Or you can contact FP official support.

1 Like

Sorry, but I can’t confirm this to work - at least on the FP3: Removing the only SIM does not give you access to previously blocked updates. You actually have to put in another SIM or already have a second one in. Can you confirm that this is different on the FP4?

1 Like