Software update: FP4.SP21.B.048.20230215

Yes, I am aware of that. I was just wondering, if 6% of health degredation in just 3 weeks will continue. But it’s more likely that the battery is seen as “94%” health out of the box by “AccuBattery” and the degradation is much slower. I expect it to last at least for 4-5 years, this is what my old Smartphones reached easily and still had about 60-80% of the original battery runtime.

1 Like

Keeping a battery between two values does in laboratory tests appear to extend the amount of cycles a battery can achieve, but this is not specifically related to current battery wear values.

For example, with my laptop. Using a Windows powercfg.exe I noted that the wear started at 3.4% or 96.6% of nominal Ah.

After a few months the wear increased from 3.4 to 7.7

I then thought the monitoring may require calibration, so I ran the battery down to ‘zero’ and then charged to 100%. I have done this once a month since.

After a year the wear has decreased back to 3.4% i.e. no appreciable wear after a year.
The value of wear during a single day can fluctuate by 2 or more percent, so all such readings are vague and volatile.

My daily record will show you the fickle readings so it’s possible that part of the 6% is just a build factor, part due to the measuring method and part due to time of day.

I measure multiple times a day and invariably the reading of wear is less after the laptop has been switched of over night.

If you are interested in my findings you can find graphs of each day’s lowest value at

and tables of daily measurements, with time of day via

If by “tray” you mean the shortcut drawer on top

Well, not exactly slight_smile:
In my terms:

  • “reduced tray” is the top bar with the icons when the drawer is not extended.
  • “extended tray” is indeed the drawer.

There is an “Alarm” button, which allows you to fire up the clock.

I feel stupid somehow, I did look for it there but could not find it before …
Still, better than nothing, but the previous “ability” to open the clock when clicking on the clock was even more efficient :wink:

As for vibrate mode, I’ve initially missed it too, but you access it by using any of the physical volume buttons on the side of the phone, to show the small volume popup menu

Sure, that’s how I change/switch between modes.
But this requires “interaction”.
The A11 way was showing up a vibrate icon in the reduced tray/top icons bar. Just looking at the display was allowing me to know in which state the phone is.

Another thing that changes, not necessarly for the worse (even if) is how one can take screenshots.
A11 was giving you the option to do that when switching apps. That was actually convinient
Now we need to use “power + volume down” (like on any other phone i guess ?)

For screenshot please see and and follow-up in the dedicated topic.

The clock thing is most likely an A12 feature and not a FPOS bug.

The missing icons are still there in the statusbar when you just pull down once from the top (what I think you call tray). Not sure if bug or not…


Well, mine shows right now “11 hours of usage since last charge”, which I doubt, because it’s 14:00 and that would mean I charged it at 03:00 in the morning, and at that time I was sleeping…
It does seem to be a little out of kilter.

A post was merged into an existing topic: Bluetooth audio bug on Android 12

Hi! Thank you for your work.

Since the last update, sometimes the keyboard stops popping up until I restart the phone.

Does it happen to anyone else ?


No, it doesn’t happen to me.

Hi and welcome, in all apps? Do you use the stock keyboard or any third party?

It’s the standard android keyboard.

I noticed while using signal. Then the keyboard does not pop up in any other app when I touch text boxes.

Maybe clearing the cache of the Gboard App helps, under settings, apps, gboard, cache and storage…


I have the same problem with my music apps, they freeze on my Fairphone 4. I can’t use my IFI GoBlu with aptX Adaptive. It works if I turn it off but that cancels my interest in using the GoBlu. Thankfully the phone connection in my car still works over Bluetooth. I don’t know if aptX HD is available on my phone as I can turn aptX Adaptive on and off but that is the only version of the codec I can see.

Thank you, I’ll try it if it happens again.

Wide angle lens distortion can be corrected with:

ffmpeg -i in.mp4 -vf lenscorrection=k1=-0.21:k2=0.055 out.mkv

I’ve found these parameters by recording a grid pattern.
They’re not the best but it corrects most of the distortion and makes a video with regular parallel projection perspective. Please note that some data (edges) is lost with this filter.

Edit: another filter

-vf "v360=input=sg:ih_fov=91:iv_fov=51.5:output=flat:d_fov=100:pitch=0:w=1920:h=1080"

Huh yeah my Minirig changed from aptX toggled off to on with this patch but as it’s not aptX HD it then didn’t work - bit of a silly one for it to turn on all hd audio codecs when not all fixed.

Appreciate lower brightness though happily with 12 it’s great to have an extra dim setting option built-in too

No issues with my keyboard nor 5G

Just for the record, today I moved out of my lair (hollow volcano island) and indeed, it does 5G just fine.


I am similarly appalled to report that I’ve finally accepted the Android 12 update with this, and after a few strange teething troubles (a few minutes after upgrade, the screen just went black: only the emergency-poweroff menu worked, so I rebooted that way)… I have experienced no problems at all, and everything I needed to work has just worked. (The new UI of the app switcher and the notification pulldown are really pig ugly, but I guess that’s Android 12 for you.)

This is just not good enough! I expect some really seriously annoying problems so I can rant about them like everyone else who upgraded last month got to do. What is the Internet coming to, grumble grumble


Ok so I’ve been using wide lens for 4 days and it might be as good as a GoPro (except stabilisation).
Fairphone 4 doesn’t overheat, records 4K H.265 for like 12 hours on a single charge - all with a great software support.

# Removes distortion. Adds nice blurred background
ffmpeg -i in.mkv -filter_complex "[0]v360=input=sg:ih_fov=91:iv_fov=51.5:output=flat:d_fov=100:pitch=0:w=1920:h=1080:alpha_mask=1[a],[0]scale=1920:1080,boxblur=50[b];[b][a]overlay" lens.mkv


A post was merged into an existing topic: Display brightness too low at dark environment

My Fairphone4 just installed some new version. 1GB, and apparenty no way to avoid it.
Now the scren keyboard has narrowed, with a band on the left (or right), uncomfortable.
Where has the screen shot option gone? It used to be just under the windows of active apps.
When I swipe the small screen of an active app upwards to disactivate it, but don’t swipe high enough, it hangs (for that app only) somewhere halfway up, and no way to get it down again.
And in the system settings now everything is uniformly black, all the colours have gone: more difficult to find things!
What is happening?
Andriod 12.