Software update Cherry 1.6

You should read this entire post :smiley: Quickly tapping ‘Download’ multiple times should help.


I successfully updated my FairPhone to 1.6, but it went wrong reinstalling the Google Apps. After placing the widget on the homescreen and tapping it, it starts to download Google Apps, but when this is complete I got the error message “an error occured during download”. I retried it a second time, but without success.

Does anyone have an idea?



I recommend you to try a different wifi network, this might help:)

thx for sharing. It has been very helpful for me.

1 Like

Hello. I’m having some trouble installing Gapps, I get the error 1004 message. Tried 5 different WiFi networks, and tried to erase memory of fair phone updater app (is that what reflash app means?)
I googled and read on this forum and on other forums as well.
Any help would be appreciated

Hi Rick! After resetting the phone the 1.6 installer finally works, but now I got a message that the downloaded file is invalid (“invalid file download”). I looked at the instruction for manual installation, but it seems to be too difficult for me. Invalid file download - why, what does this mean? JusSi

@Jussi_Silvonen have you been able to solve your problem?

I am understanding you are still on 1.5 and want to upgrade to 1.6?
It is possible the file got “corrupted” while being downloaded. Are you able to restart the Download?

After three months with Cherry Pie I just reset my Fairphone to Chestnut. Here’s why:

  • Immediately after the update I had realized that the battery indicator seemed to have gotten worse instead of better. I had hoped this would fix itself after a few loading cycles. At first, it seemed like it did, but recently it got worse again. Not only did the battery still deplete within minutes after the 15%-warning. Last night I realized something else: I had switched my phone off with 56% battery life left. Then, because I had forgotten something, I switched it on again a few minutes later - and the battery suddenly had dropped to 25%. Yes, the old 14%-glitch (with battery life being stuck there for hours) wasn’t perfect, either - but at least it gave me enough time to get my battery reloaded somewhere before it was empty. (It almost felt like a secret reserve.) So, I hope I’m back with that after having downgraded the OS.

  • Soon after the update I had realized, that sometimes when I got my phone out of the pocket, I had to reactivate the SIM card, just like the phone had restarted itself. I first took it as a coincidence, but actually this had never happended in all the months before Cherry Pie. Now it happens about once every few days. It took me some time to connect the dots, but I’m quite sure that this has something to do with all the reports about the touch screen being too sensitive and “ghost tappings”. It wasn’t as bad for me as some people wrote here. I could still use the phone pretty well. But being disconnected for hours without noticing because the phone had seemingly restarted itself in my pocket is, of course, totally unacceptable.

  • The only real improvement with Cherry Pie seems to have been the unified storage. But I didn’t use that, because I had re-partinioned my phone from the get-go. So, I had no trouble getting back to Chestnut, either.

  • One other tiny thing that I had realized earlier, but wasn’t sure about. Didin’t the Wi-Fi icon in the status bar use to be blue? Or did I remember wrong? No, I didn’t. Being back with Chestnut the ugly grey is gone and the icon is blue again as it should be.

So, there you have it. Three months with Cherry Pie - not convinced!

Maybe the next update will make things better again. I sure hope, Fairphone takes care of those battery and touch screen issues. But - being an early adopter, so far - this might be a lesson for me. I might wait a few weeks and read all those postings here first, once the next update arrives.

I moved 3 posts to an existing topic: Software version Hazelnut 1.7

I had the ‘no connection’ error with GPlay after the update to 1.6 (Cherry) for a couple of months, tried to solve it by all intructions found on forums, but nope. Didn’t bother too much, because all Apps kept working, but after a while more and more wanted to be updated. Then someone’s response elsewhere suggested to use the 1mobile-appstore. I did, and this solved all, it even updated GPlay and GServices, which now do again what they’re meant to. I’m still cautious, but it 1mobile seems safe until now. I’d like to read experiences of others with this App+store.

Hi, what resolution did you get in the end? I’m having similar issues at the moment.

Hi DoraXP, I had to send back my Fairphone! But within a few days, I got a new one, installed the update and since then everything works perfectly fine. To send back your phone, contact the support-team, they’ll tell you what you have to do. Good luck!

1 Like

the update to the 1.6 unifyed also messed with my SD card and deleted
files and put new ones there. not something I was expecting. you could
have written that somewhere, luckily I had a backup of the SD card.

This is strange. I’ve done several updates and do not remember this happening. Although, before the update, the labeling of storage was quite confusing if i remember correctly: The “internal file storage” was labeled as first sd card. This would make the real scared something like sdcard2. Is it possible that this is what happened in your case?

Hey Sarah did you ever get a response on this? I’m still on 1.1 and having massive problems after trying to instal…

Hi, I just updated my fairphone with this software update. Now my keyboard does not work. I understand that I need to install Google apps to get the key board to work. However, it will not download as I need to be in a wifi connection. To log into he wifi I need to input a password. This I cannot do without the key board… No keyboard, no password, no google apps, no keyboard… Please advise on how I can get out of this vicious cycle. Thanks.

Are you sure, you updated to Fairphone OS 1.6 and not 1.8? (Please check in the Fairphone Updater app.)

Here is something I found in another topic:

You should be able enter your wifi password then.

You’re a star! That worked a treat. Thanks loads

1 Like