Software update: 3.A.0101.20210420

Yes if you are also using 2.4Ghz for bluetooth (no option there) and 4G network. I have the same issue on a Raspberry pi 4 and Windows 8" tablet.

No issues on a FP2 (running Lineage OS) with WiFi (2.4 GHz), LTE, and Bluetooth enabled…

In which area in the world is 4G using 2.4GHz? The FP3 doesn’t even support a frequency in this range. Channel 7 is the nearest, but that starts at 2.5GHz.


My apologies, you are correct. The nearest network signal for my EE in the UK is 2.6Ghz and O2 use 2.3Ghz :blush:

More to do with bluetooth and wifi that use the 2.45Ghz band

I think part of the problem is that they may use the same antenna and of course different heads and ears and hair, which really messes with the software :slight_smile:

Having multiple antennas results in interference between antennas, which is very complicated. As a consequence, mobile phone antenna design relies more and more on electromagnetic simulation programs that model not only the antenna but the effects of conductors, dielectric material (plastic), and the human body that are very close to the antenna.
The Challenge of Mobile Phone and IoT Antennas |

1 Like

After the update I still have issues when I call with third-party apps. The recipients I call still hear an echo of their voice when they speak. It gets unusable to call with me when they have higher volume.

Before this update I found that turning my volume up stopped the echo ???

have you already checked that the update worked properly and that you’re using the most resent version?
I had one case where something within the update process failed and the phone switched back to the A/B slot where the old OS version was installed…


Italy, update made some days ago, the problem of the reminders in the settings section that never disappeared was solved.

My carriers are COOPVoce and Wind.

No new problems experienced so far.



Installed the update five days ago and I noticed these changes:

High battery drain
After a regular day, the battery is around 20% lower than it used to be.
And at night, when the phone is doing nothing, it used before 3% - 4% per night. Since the update it uses 11% - 13% per night.
I did not install new apps and my usage scenario did not change. All apps in the battery manager are showing their usual behavior. So I guess it is caused by the update.

Bluetooth audio stuttering
I have a bluetooth speaker connected to the phone. When there is audio playing and a messenger notification arrives, the speaker is stuttering and sounds like everything is crashing. But some seconds later the playback is continueing again.

Anybody else noticed similar effects since the update?

That is a concern, but despite your efforts to find the cause, try at least to put in aeroplane mode open to see if night to see if it is a network/wifi/bluetooth drain.

You also have the option of reverting to the previous version to see if that resolves it as it could just be coincidental, then try the update a second time.


Hi amoun, How can you revert to the previous version? Do you know Any step-by-step instruction anywhere in the forum or internet?

Here’s a topic with links to versions:

1 Like

As for the manual install there are topics on that, my next post links to the official Faiphone instructions. Once you have the version you want even /e/ or LOS you will need to install the Android Debug Bridge (ADB) to a computer and use that to access the phone etc.

You can search for (adb) and ensure you are happy with that before doing anything else. i.e. download adb and connect to your phone. Once you are confident you can connect to your phone via computer you can download a version and install/flash to the phone.

Here’s a link to the download options:

Here’s a Fairphone page on manual install, which is clearer and as official is more confidence boosting :slight_smile:

Just a bit more on installing the android dev bridge.

Here is a page written by the e foundation for those that want to switch from the default android 10 ~ this is just to show the adb install process.

I have installed adb on my Raspberry Pi computer, the process as you can see is much the same ~} you have to install the adb for the OS of your computer e.g.

Since updating to this firmware version, my WiFi reciever has become unstable . On all of the AP’s tested , the WiFi is flapping ( Connecting/ Disconnecting)

Flapping between what and what? If it is a network issue try aeroplane mode then use wifi only. If it is a wifi at home try ensuring your router is on 5G only.
Of course if you are out and about the phone may switch amongst 3G, 4G, 2.4Ghz and 5Ghz.

It could just be a network issue or a phone setting you had that wasn’t kept by the update.

By the way, if you want an uncluttered topic to address your issue you would be better of with a new topic explaining the problem and what you have done to try and resolve it, something like WiFi unstable after update to 3A0101 You could then post it under the Help > FP3 category

1 Like

As I said the Wifi Receiver is flapping ( disconnected/connected) Irrelevant of the mobile network . Irrelevant of what AP ( I have tested many )
Why should I use 5Ghz ? 2.4 Ghz has better coverage , if both are saved as AP’s or the AP is common , usually it is up to the device to connect to the stronger signal . I prefer not to use 5Ghz in many cases . It should work this way .

It has nothing to do with location , it is the same wherever I go , its a bug , never done this before . Just writing here as a warning and I have already submitted a support ticket to Fairphone .

I can bet that I will be asked to reset to factory … Yawn , then spend another hour restoring all my apps


I liked your post not because you have an issue with WiFi, but come to the same conclusion. One of the “Golden Rules of Troubleshooting” is to know when was the last time something worked, and you clearly wrote:

Another rule is to find out whether other components have a positive impact or not. Does the issue occur with other networks, too?

So we can rule out an access point issue, too.

It is just that simple: A new software came out, it was applied, now things do not work anymore like they did before.

Do you have a security app installed that possibly monitors your WiFi networks?

So after installing the latest version using their tutorial I am so far running it without major issues. Let’s hope that I will be able to update.

Thanks again to all that helped or reached out to help.


Hi @phineas,

The Fairphone 3 and 3+ is technically capable of using VoLTE and VoWiFi technologies, however at the moment, we are still working on completing partnerships with some network providers. Here is a list of network operators we currently support.