English

Software update: 3.A.0066.20201119

The updater doesn’t like altered partitions, rooting might alter partitions.
If you rooted with Magisk, you can search the forum for the correct way to OTA update with this, it should be somewhere.

Depends on what exactly you deactivated.

4 Likes

Google, clock, duo, calc, agenda, contact,chrome., drive ,gmail, google play movies and TV, maps, Messages, photos, youtube, YouTube Music

In fact allmost all google apps.

I believe giving the exact names of the packets you disabled would be useful.

2 Likes

I think the rooting needs to be sorted out first as a source for OTA updating trouble.

Deactivating Google Apps (as in: you can launch and use them) should be fine, deactivating certain Google services (as in: you don’t usually see them) could break stuff.

1 Like

Well. I reinstall the 0054 from scratch and the update is now done. I have to reroot the phone, I’m so happy (spoiler alert:no).

Thanks for your help.

Reply to my self to add some tests results:

  • if your device, running the old 0054 OS version is rooted →the update process failed
  • if your is not rooted → update process work fine but you cannot root you phone after, because you don’t have the new boot.img to patch with Magisk_Manager.

Conclusion:
If you need a rooted phone stay on 0054 and ignore update notification. Wait for Fairphone to post the 0066 version reinstall version (with boot.img)
If you don’t need a rooted device, just update.
If you want to update to 0066 and your device is rooted, apply the Manually install OS on FP3/FP3+.

hope this help

2 Likes

Just out of curiosity:
Somebody already received the update on Vodafone network in Germany?

Will this may work?

Unchanged (unrooted) 0056 update to 0066. Then flash magisk 20.4 over 0066 with a manual bootet TWRP?

I have Vodafone in Italy and the answer is none, stuck on 0054. At last we have the same operator…

My Fairphone 3+ (rooted + TWRP installed + bootloader unlocked) did the update form 0054 to 0066!!!

If you try this (at our one risk), make a full backup (with TWRP?) before…

I connected the phone via USB to my Win10 PC. First i re-installed 0054 manually:
Install Fairphone OS on FP3/FP3+ (Windows) – Support

I flashed (0054) and keep the data with selection of: “2.Keep user data”

After this reflash root is gone… (The Phone reboot without root or TWRP Installed)

The phone rebooted with 0054. Then i did the “normal” systemupdate to 0066.

The update worked without any problems and finished with an reboot. After this systeminfo showed version: 0066

Then i used a minimal adb and fastboot pack with a command-tool in win10:

I manually rebooted the phone with “adb reboot fastboot” into fastboot mode.

I downloaded twrp-3.3.1-0_k4y0z-20200202-02-fp3.img (renamed to TWRP.img).

Then i booted manually into a TWRP (you will need the TWRP.img for the FP3+ for this step!):
“fastboot boot twrp.img”

Then the phone booted TWRP.img for one time…

I copied a different TWRP-installer-3.4.0.0-FP3.zip file to the SD-card from the phone.
After that, i flashed the different TWRP (3.4.0.0) permandly (with a TWRP.zip file from the SD-card).

Then i reboot the phone into the new TWRP-recovery.

Then i flashed magisk-v20.4.zip file.

finished… :wink:

My data and the apps were keeped with this procedure… Now my FP3+ is rooted an have version 0066 and TWRP installed…

4 Likes

@Frank_D Thanks for the detail :+1:

I’m not sure actually. AccuBattery gives me always screen off deep sleep around 85-90% of the time, which is good. But average consumption changes from 1.5%/h to 2.7%/h, I’m using always the same 3/4 apps such as twitter, reddit, whatsapp…
I don’t know what to think -before the update i rarely had screen off consumption at 2%/h or more, since the update i see it very often.

But maybe is an app update which caused the problem.

Hello,
I am a Fairphone 3 user from Germany with a contract from Vodafone. I got the cell phone together with the contract. I also have various problems with my cell phone and am waiting for an update. Since it has been available for 14 days and I still couldn’t download it, I wrote to Vodafone. Unfortunately no answer. I probably can’t find out here when they will make the update available, can I? I don’t want to do this manually.
Best regards
Jörg

1 Like

@Joerg67 As I reply to another user, I have Vodafone too (in Italy), and I bought it the same way as you did. Of course, I don’t receive the update yet. I’m sure that is Vodafone to make that delay. Just sadly wait…

1 Like

You right
Thank You!

Soooo…when will i be able to actually call with my 450 mobile phone?
I mean not that i want to Push you guys and Girls but it would be nice to use my Phone as a…Well Telephone.

2 Likes

Have you opened a support ticket already?
So, does the Fairphone support team know of your troubles.
While they are - of course - in general aware of the problems, they need to know ideally of each and every case, since the combinations of network provider, country etc. can make every case different. And therefore they should know it. Plus, they only know how widespread a problem is, if they learn of the cases.
I really hope, your troubles will get fixed pretty soon!!!

2 Likes

I had to remove my SIM card for a short time (for another reason) and suddenly the update finally appeared.

What I can say so far: It seems like the update brought new versions for the baseband processor. But on the application side I can not see any difference.
This means, even after the update, I have the same bugs than before: Missing options in the settings (wifi band switcher and wifi power settings), unstable wifi, settings-suggestions-bug, etc.
So there is no change for me.

I don’t know yet if this update enables me to do reliable phone calls now (without the mic problems discussed here in the forums).
Will have several calls today and I really hope Fairphone solved these issues with the update.

Fingers crossed :wink:

Well, the first post contains a list of things that have changed. I guess it’s safe to assume that other issues are not resolved in 0066.

3 Likes

Thank you for the suggestion, I got the update after removing the SIM. Anyway, full gesture bar still has a bug, they only moved a little up the icons row and the navigation bar shows both the two buttons and gesture layout (photo attached).

Edit:

Today I change the wallpaper and bug disappears (photo attached). FP should fix this bug but changing the wallpaper actualy is a workaround.