SMS arrive late

So I am very happy with my new Fairphone 2, there is only one thing causes me problems.

I use a mobile TAN for internet banking, that means for every transfer I get a SMS with a verification code on my phone. But since I have the Fairphone, these messages take awfully long to arrive, between 5 and 20 minutes. On my old phone, they popped up immediately (when the phone was turned on at the moment of sending and it has a network connection).
I had the same problem when buying credits for my prepaid SIM card. I thought there was a malfunction because they took my money without sending the confirmation SMS.

Now I am sitting here again, waiting for 10 minutes already to receive my TAN for a simple transfer (I tried re-sending it once, none of the two codes arrived yet).

It happens when I use just one SIM card (standard situation), but also when I have two in there (I use a German SIM just for my German online banking). I have a stable connection with both SIM cards (Dutch and German).

Does anyone have the same issue or could tell me what might cause this? Is it even related to the phone and can I do something about it?

Thanks for any advice!

Which of your SIM cards is using 2G-only? Maybe you can switch the SIM on which you need to receive a text message to also use 3G and 4G just before ordering the message (Settings -> More -> Cellular networks).

Also going into flight mode and connect again could help - maybe re-registering on the network triggers SMS delivery on the side of your provider. I’m just guessing here :wink:

Thank you for these ideas!
Both SIM cards are already using 2G/3G/4G and have 4G as the preferred network.
But I will try the tip with the flight mode next time.

Apparently it also does not happen every time (just very often). I just tried another transfer with my German SIM as SIM2 and it worked immediately, while the one mentioned before did not work until I put the SIM in Slot 1 and then asked for another code. The codes from before haven’t arrived at all.
But as I said, I also encountered this problem with my Dutch main SIM, and only on my Fairphone, so I am still curious what exactly triggers it.

As far as I know only one of the SIM cards can use 3G or 4G at a time and the other one will be in 2G only. Also note:

Absolutely right. Only one SIM slot can be in 3G/4G mode. The other gets only 2G.

I’m not sure if SMS messages are actually transmitted over 4G, I thought most providers still fall back to 3G/2G for SMS messages and voice calls, but this information might be outdated by now. If it’s still the case, dropping back to 3G/2G for SMS should be handled automatically. Just to figure out if there’s some weird problem here, you could try force your phone to use only 3G.

Does this delay only happen with SMS messages from your bank, or do you see the same behaviour with other SMS messages as well?

1 Like

I did not know that one SIM would be forced to 2G. I assume, that is the one not marked as preferred? But it still shows 4G (preferred) for both SIMs when I use both slots in the settings. Is the secondary SIM still forced to 2G then?

It is at least a possible explanation, though I also experienced this when I had only one SIM card in my phone, which was definitely set on 4G.

It has happened with SMS from my Dutch bank, my German bank and my Dutch phone provider.
They all are verification SMS that should be sent immediately after I clicked on the button in my browser, so I know that they take long to arrive. With other messages I can’t say yet, because I mostly don’t know when they were sent originally.

SMS shares with e-mail that we all take for granted that this stuff works, when nobody really guarantees that it does (in a fast way or at all).
That being said, 2G should be no reason for slow SMS reception, and every single SMS being late sounds really strange.

1 Like

It should not be possible to set both SIM cards to 4G in the “Cellular networks” settings. Or are you beta testing the Android M version? I remember there was a problem with dual SIM there…

In the messaging app, touch and hold on a text message, then touch “View Details”. This should show the sent and received time.

1 Like

You can do a longpress on a message select “show details” from the context menu. It should show you when the message was sent and when it arrived on your phone.

If both SIMs are active, only one should show “4G(preferred)”. At least on my phone, only one shows this. The other one shows “2G only” and the drop down menu is inactive, so i can’t even select anything else, as long as the other one is set to 4G.

1 Like

Hm, i can’t really say if the whole thing is fixed, but I did not have any problems with my SMS anymore since my last post.
If it appears again, I will try the tips given here and otherwise ask for help again.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.