Smartlock is unreliable

Now, after several days with this successful habit, it seems to me that it is most likely that there is an app active which interferes with my location.

Doe anyone know an app that can f.i. show which apps use locations? Some analyzing, forensic app, the app that can delve in my active apps to investigate their behaviour? That would be nice.


In my list of all apps, there are 71.
But this morning, with the system update, it found 126 apps to prepare.

So, actually I should take care of 126 possible culprits? Is 126 the sum of my active apps and those in my ‘bibliotheek’? Anyway, the upgrade did not solve my issue.


I have un-installed every app that uses Location, waited until that one proved to be not the cause, re-installed it, and went on to the next app. Now I arrived at the last app that uses Location, and I fear that this will prove unharmful as well.

What then to do next?

I think I am progressing. I fiddled with apps that use “location” quite a while, without success. Removed Location from almost all apps except Maps and Google services. No success. Given all apps Location, no success.

But now…

I had a look in the help about Location, found some remarks about wifi, and I tried my phone without wifi. Started yesterday at noon, and until now my phone behaves wonderful. Really amazing.

But how can this be? Is wifi unreliable? Here in my house I have enough of it, in every room. But I don’t know if my router sometimes disables it a second or so, which causes Location to loose it’s information?
Where should I look next?


1 Like


there was not much response on your problem here meanwhile. Maybe it´s not used very often or too less users has experience with it, yet.
Anyway it´s nice that you share your personal findings on this issue with the community which may be beneficial for others thinking of using it some day.

As it looks your are coming closer to the solution. Good luck.

Coming close to the resolution, or just circling around it?

I was so stupid to enable wifi for a little while, and was confronted with the locking problem again. Disabling wifi did not help, this time. This morning I removed my sim card physically, so that only wifi remained, plus the problem. Then I disabled wifi, re-inserted the sim card, and hoped for a better experience. But nope.

So, I come close to the ultimate step, to reset my phone, and see what that does (or not). But I try to avoid it…


Oh, that´s too bad. Well after having tried out so many different options there are hardly any left beside a factory reset. Hopefully this finally fixes your troubles and does not reveal a hardware problem being the cause at last.

Well, maybe.

But today I found a quicker work-around. Just disable and enable location in the settings, seems to do the trick quite charmingly. In smartlock I have only my home activated, nothing extra, as it should be.



My “quicker work-around” lasted only a day or two. This afternoon it refused to work anymore (the weekend is near :heart_eyes:). But now even my previous work-around (adding a trusted place in Smart Lock) did not do anything anymore.

I gave up. Disabled security.


After a Google maps update this week, I tried again. In vain.

Strange that you cannot get it working reliable. Also there remains hardly any response from others. Maybe this feature is not used very much, or others also had to give up after some trying. Another chance to try once Android 7 becomes available.

I remember to have read somewhere here, that due to some missing feature, it is impossible to update the phone from 6 to 7. But I can be wrong. I hope I am!


Yes, that was the common consensus here on the forum, but we were all wrong:

That indeed is marvelous news, and also much more in accordance with my expectations when I bought my FP2 about a year ago. lovely!

The first thing to try, when it arrives, is the smartlock function.

Nowadays, I let my phone open at home and when I keep it with me, locking it only when I leave it unattended. Less safe, but much more workable.

1 Like

Smartlock (location related) doesn’t work reliable any more on all phones, regardless of make and Android version. Google is even in the process of deleting this functionality in it’s upcoming P-version.
But don’t ask me why, I’m just a messenger.

Google is going to remove this feature from Android as it is unreliable. Supposedly it is already removed, or so I read reports. What LineageOS does with the feature I don’t know; it seems to still work.

That doesn’t mean smartlock at a whole doesn’t work well, but something like Bluetooth unlock is also unreliable because of the nature of Bluetooth.

Not sure why GEO-unlock should be unreliable. It did work fine for quite some time on multiple devices.

Well, Google removed the feature because it is unreliable. And it is unreliable (though differs per phone), especially in city with flats etc. Also, personally I’m a proponent of using _nomap on WLAN to opt-out of being included in WLAN DBs.

There must be more to it. Geo-smartunlock used to work well for me (no flat, no neighbours within 500m), but it doesn’t any more.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.