Smartlock is unreliable

I opened a similar topic, but that was closed in two days. I hope I have more luck (and replies, hopefully solutions) now.

The case is that my FP2 is locked even while I am at a trusted place like home. Smartlock has a list of places where the phone should be ‘open’, and these tend to work for some hours, but eventually my phone gets locked, and wants te be unlocked every time I try to use it.
In ‘Locatiegeschiedenis’ (Location history?) google shows where I am and was. I can disable and re-enable FP2 in this list, and sometimes this helps, for a while. In Smartlock I can remove my trusted place and create a new one, and also this helps, for some time.

I have the latest software updates.

Are there paople with similar experience? Is there a ‘known’ solution? I love to hear it.


1 Like

Sorry about that but the last paragraph of your post sounded like you found the solution yourself.

You’re quite right. Alas, I was wrong. The problem keeps coming up, and I did not find the ‘real’ solution up to now. The last two updates of the phone did not help either.

I use smartlock with my pebble watch and it works pretty well.
Afaik you can use it also with WLAN connection and bluetooth devices.
Would that be a workaround for you?

I usually have only my FP2 around. In theory having some other gear in the vicinity would provide a workaround, I agree. But it’s just a workaround. When I got my FP2, it behaved as it should. I want that back.

Now I tried to remove all trusted places, rebooted the phone, and added the trusted place that google maps provided. I went out, and when I came back, my phone was open. I thought that I had found the solution. But I was wrong again…

Maybe resetting it to factory default would ‘help’, but that would also give me much trouble, I guess. I don’t like trouble :smirk:

Fairphone support has given me help and instructions to reset the phone to factory default. I appreciate that. Nevertheless, if I do that, and the lock-problem is vanished, I will know it was one of my apps. But which one??? That will be the next question, or the phone itself has a problem and needs to be repaired.
I’m quite a lazy person, and I try to avoid trouble :roll_eyes:

Is it really only me who has this lock-effect with his phone? No-one else here?

My best ‘work-around’ so far has been: removing my trusted place (home), and adding a new one. Yesterday it worked during the whole day. At least this is less troublesome than resetting the damn thing.

Do you happen to know which app you installed last?

No, alas. When I got my FP2, I installed all the apps from my library (bibliotheek) that I had used with my previous phone. When my phone became unreliable, I uninstalled some and re-installed them. I also removed many apps that I did not need anymore, they are still in my library as uninstalled aps. The app-store doesn’t keep a date of (de)installation. :face_with_raised_eyebrow: If I recall correctly, the smartlock problem started some time after the stability-update and weeks before the last monthly update. But I can’t think of a particular app that I had just installed before the problem materialized.


Could you check if the un-installed apps are really removed from your FP2.
Go to the app Settings
In the section Device go the Apps.
None of the un-installed apps should be listed there.
If such an app is listed, tap on the app and uninstall it.

At first I didn’t understand what you mean. My phone speaks Dutch, just as I do, so I don’t see app Settings (where, in Google’s My apps and games?), and no Device. But I found in my FP2 Instellingen/Settings a section Apparaat/Device and Apps there, and see there all apps I have installed. Bit difficult to tell if some sneaky app hides in the mass.

In Library/Bibliotheek In Google Play I find only apps that are not installed, at least they all have that label. I must have made a list of all my installed apps a while ago. I think that I can use it if I find the time to do the ‘find the culprit game’.

Yes, I meant the app Settings on your phone. Nothing to do with the Play Store
If an app that you had installed, is not in the list at Settings, section Device, Apps, then that particular app is not there anymore.

Ja, ik bedoelde de app Instellingen op je telefoon. Dus het heeft niets te maken met de Play store.
Als een app die je eerder geïnstalleerd had op je telefoon niet in de lijst Instellingen, onder de sectie Apparaat, Apps staat, dan is die bepaalde app verwijderd.

My best workaround so far is: add a new location in Smart Lock, it doesn’t need to be the real place where I am. Then, if the phone locks again, do this again, and delete the previous added trusted place.

I have some 3 fixed trusted places around my home address, which I don’t change.

So far, this works best. It’s also a good practice when I go out and stay somewhere else, to add that place temporarily as a trusted place. And remove it when at home.

But it is still a workaround.

Now, after several days with this successful habit, it seems to me that it is most likely that there is an app active which interferes with my location.

Doe anyone know an app that can f.i. show which apps use locations? Some analyzing, forensic app, the app that can delve in my active apps to investigate their behaviour? That would be nice.


In my list of all apps, there are 71.
But this morning, with the system update, it found 126 apps to prepare.

So, actually I should take care of 126 possible culprits? Is 126 the sum of my active apps and those in my ‘bibliotheek’? Anyway, the upgrade did not solve my issue.


I have un-installed every app that uses Location, waited until that one proved to be not the cause, re-installed it, and went on to the next app. Now I arrived at the last app that uses Location, and I fear that this will prove unharmful as well.

What then to do next?

I think I am progressing. I fiddled with apps that use “location” quite a while, without success. Removed Location from almost all apps except Maps and Google services. No success. Given all apps Location, no success.

But now…

I had a look in the help about Location, found some remarks about wifi, and I tried my phone without wifi. Started yesterday at noon, and until now my phone behaves wonderful. Really amazing.

But how can this be? Is wifi unreliable? Here in my house I have enough of it, in every room. But I don’t know if my router sometimes disables it a second or so, which causes Location to loose it’s information?
Where should I look next?


1 Like


there was not much response on your problem here meanwhile. Maybe it´s not used very often or too less users has experience with it, yet.
Anyway it´s nice that you share your personal findings on this issue with the community which may be beneficial for others thinking of using it some day.

As it looks your are coming closer to the solution. Good luck.

Coming close to the resolution, or just circling around it?

I was so stupid to enable wifi for a little while, and was confronted with the locking problem again. Disabling wifi did not help, this time. This morning I removed my sim card physically, so that only wifi remained, plus the problem. Then I disabled wifi, re-inserted the sim card, and hoped for a better experience. But nope.

So, I come close to the ultimate step, to reset my phone, and see what that does (or not). But I try to avoid it…


Oh, that´s too bad. Well after having tried out so many different options there are hardly any left beside a factory reset. Hopefully this finally fixes your troubles and does not reveal a hardware problem being the cause at last.

Well, maybe.

But today I found a quicker work-around. Just disable and enable location in the settings, seems to do the trick quite charmingly. In smartlock I have only my home activated, nothing extra, as it should be.