Since last update, can't shut down fairphone 2

Dear all, the FP bug tracker now announces the issue is solved, “in the 19.02.1 releases of Fairphone OS and Fairphone Open”

I for one am still on Open 18.04.3 (to which I regressed because of the bug to be in line with the couple of people I support)… [edit : done the switch, it does work now!]

Now, I feel obliged to answer RSpliet post as, given the length of his reaction, I certainly shocked him/her a lot.
First Id’ like to remind the purpose of my post was to announce the bug was being addressed : so, a good news, and I was the first to announce it.
Second, I do assume my words ‘by lack of any interest’, but honestly, in my sentence this concerns the management of the bugs : not the devs in any way -the guy that decided that the only bug that attracted 76 watchers (vs one or two for all others) was to be allocated to a dev after six months.
IMHO this still means something worrying : at the very least this may mean the dev team is very small, even though they evolved a lot since the FP1 (where you just didn’t get a bugtracker anyway).
But at worst, I maintain that the guy in charge of deciding which concern is frontmost to be solved, may not be competent : from all the measurable data I see, he chose to spend half a year to solve issues that 1% of users complain about, and the remaining 99%, if I dare the comparison, the ones that all came and registered into the tracker just for that (which no single other bug triggered), these guys can wait.
Let’s be more polite : he has a wrong way to evaluate a situation.
And this decision, the only thing I criticized, isn’t dev stuff.
RSpliet, with my apologies…

:smiley: OK !! This is better than removing the battery !! But it would have been great if the shut down function actually worked !! :wink:

It works now.


Haha, turned off my fairphone for the first time in months. Now it can rest for a while.
Thx, works for me fine!

same for me ! :smiley:

Hi everyone,

I had the same issue - my Fairphone 2 couldn’t shut down unless using the “flashlight” trick or going through the recovery mode.

And after I recently updated to Fairphone OS v19.02.1, the problem seemed to be fixed :slight_smile:
…well, until a few days ago. :frowning:
Now, although I’m indeed using the latest OS version, the same problem re-appeared: my phone automatically restarts after shut down. This doesn’t occur systematically, but I would say about 50% of the time.

Interestingly, when this happens, I can briefly see what seems to be a simcard icon on the top left corner of the screen (right after I select “shut down”, before the screen goes black).

Also, this problem re-appeared after I had to kickstart my battery (which, for some reason, turned completely empty after charging it for one night). I have no idea whether these two problems are linked or whether this is just a coincidence.

Have other users experienced the same issue? Is there an easy way to fix this for good? Of course I can systematically re-use the “flashlight” trick to shut it down, but this becomes very frustrating…

Thanks a lot in advance for your help!

I’m experiencing the camera bug from the Android 7 update again: even though this was ‘fixed’ a few months ago, suddenly my FP2 has started to refuse to turn off unless i put the torch on. I’m not aware of having updated anything, or changed any settings on the phone or camera module, so why is this problem reoccuring, and how can I fix it? AFAIK I am up-to-date with all releases, patches, and so on.

I don’t know immediate help but in a related bugtracker entry a developer asked for additional information to pin down the root cause of the problem:

  • logcat during the power off process
  • /proc/last_kmsg after the rebooting
  • dmesg after the rebooting

If that sounds like gibberish to you, I can later try to update with a more user-friendly description about how to obtain those. Don’t have time for that right now.

Yes, that sounds like gibberish to me. I’m happy to provide info but it’ll need to be explained for a normal user!

Why does this remind me of this… :thinking:


(R.I.P. Grumpy Cat)


First of all there are some prerequisites. I’ll describe a way assuming you have a windows PC/laptop to do the steps.

First of all you need to install some drivers and tools. The easiest way is to install the “15s ADB installer and driver” from

Then the developer options on the phone must be enabled. In the developer options then “USB debugging” and root access for ADB need to be enabled.

After those prerequisites are done, the actual steps are the following

  • connect the FP2 via USB cable to the PC
  • on the phone enable USB data transfer mode (MTP) instead of “charge only”
    • that should prompt you to confirm that you want to allow access from the PC
    • mark the check box to remember the decision and tap OK
  • on the PC, open a command prompt
  • in the command prompt type adb root and once that completes without error adb logcat > logcat.txt
    • this will log things that happen on the phone to a file on your PC
  • now shut down the phone (without torch)
    • in your case you expect this to reboot instead of actually shutting down
    • at some point the command prompt will lose connection to the phone and stop saving the log to file
  • after the phone is rebooted, unlock it and enable data transfer mode again
  • in the command prompt, type the following commands one after the other
    • adb root
    • adb shell dmesg > dmesg.txt
    • adb pull /proc/last_kmsg
  • now you can disable the USB debugging in the developer options of the phone again

That should give you three files: logcat.txt, dmesg.txt and last_kmsg. Those might help finding out the root cause.

But just to make sure: I’m no Android developer, so I won’t be able to find and fix the problem myself. It might be necessary to create a new entry in the Fairphone bug tracker and hope they find the cause.

1 Like

Uh, OK. I use macs not PCs, is this going to be the same process? I can try but I’m not this sort of user normally so this is all new to me (I’ve never even reported a bug and I don’t know where/how to do that).

Ok, for Mac, don’t use the first link, but follow the instructions in section “How to Install ADB on macOS” of

The rest of the steps should be identical.

OK I’ve tried following all these instructions but it’s not working for me (adb command ‘not recognised’ apparently).

I’ve added a comment to the bug tracker but I am not sure any attention will be paid as it’s marked as ‘solved’. I still don’t understand why this issue has suddenly reappeared :confused:

Thank you urs_lesse brilliant of you to find that one out, and share with us.

I still had to use the flashlight method to shut down my phone, which is really annoying as I go to the cinema and theatre a lot! But now my flashlight and back camera don’t work at all (!!!) I can shut down my phone. But I’d rather have a working camera (yes, I’ve made a thread about it as I can’t find anyone else having that problem).

Needing flashlight to shut down was fixed in an update a while ago, for that reason there were no replies to this topic in the past months. Please check whether you are running the newest version.

If your phone is up to date (Fairphone OS 19.08.x or above) your problem is likely unrelated to the one discussed here. In that case, plase use the other thread you made to discuss your camera problem, so we can keep the discussion in one place.

It took a while before I could update my phone, but even after that I had to use the flashlight to turn off the phone, but now the flashlight doesn’t work at all and neither my camera.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.