Signature verification failed

Works like a charm, used the scatter file to Downgrade to 1.6 and then updated automatically to 1.8.5


The problem is I can’t install anything because the SD Card can’t be found.

One day or other all the people will have a working phone again ;-), I believe

Storage Upgrade is available again, so try doing this: first, download Storage Upgrade from Fairphone Updater. Then follow the instructions and restart your phone. This time update should be successful (not aborted installation or whatever). Finally, download GApps and restore your data with, for instance, Titanium Backup (you should have made a backup before all this :wink: ).

I hope this is useful for you!

Was the fix released? I tried several times to reinstall GAPPS, but after installing and restarting I still get the keyboard not working message.

This was the last official note from the Fairphone Team:

Does everything else but the keyboard work? Especially Google Apps?

If so try this:

In case you run into the problem of Android displaying the error “Unfortunately, Android keyboard (AOSP) has stopped“, thus robbing you the possibility to enter text in any form (short messages, emails, URLs in browser, etc.), simply follow these steps to get rid of it:

  1. Open up the menu
  1. navigate to Settings
  2. open Apps
  3. open option All
  4. find app Android keyboard (AOSP)
  5. choose option Clear data
  6. find app Dictionary Provider
  7. again choose option Clear data

In Google Apps can’t be reinstalled I have posted how I could solve this problem for me using the new Storage Upgrader and the Fairphone OS 1.8.5 for unified partition together with the tool ADB available for both Windows and Linux from Google Developer tools. Of course I cannot guarantee that it is working same way for you as it was for me, so I cannot guarantee anything. If you use my guide then you do at your own risk!

1 Like

I am quite sure I just updated to 1.8.7. But same problem with the same error message. You wrote there would be a new update by tomorrow, that was month ago … ?

Marco was talking about the hotfix for the storage upgrader which was released on may 27th.

As you didn’t post here before could you please tell us what the error message says.
Also if you are not sure if update to 1.8.7 worked open the updater app again. It will tell you your current operating system. If you are not on 1.8.7 go to settings > developer options, tick “stay awake”, plug in your phone and try updating again.

PS: Someone else just confirmed that the storage upgrade fix works with 1.8.7 too, so do that if you didn’t already.

Sorry, I thought my post would come up as reply under the one where I pressed “reply” …

I updated to 1.8.7, first with the updater, than again several times manually, whiping data factory reset bevore I did so. The updater app, tells me I am on 1.8.7. and wants to reinstall google apps. than restart lead to

I try going back to 1.6 know, and than try to deinstall the updater app, so it stopps telling me there is an update that does not work.
To be fair, I have to add, that I changed the storage layout earlier, and now have about 7GB Internal and 7GB Phone Storage. (I also would like to keep it that way. I don’t like the to have all the storage in the phone as internal storage, because I guess, that all app data will then be stored on the sd card, and if i take that out, all apps stop working. )

It’s your decision and I don’t know of an official way to get back from the unofficial storage layout, but let me assure you that app data is stored on the internal storage and not on the SD card. In fact there is an option (settings > developer options) called “protect SD card” that makes sure apps need to ask permission to even read the SD card. The only app I have that stores data on my SD card is Titanium Backup, which has root access.

1 Like