Signature verification failed

First I installed FP1_KolaNut_v1_8_5_OTA manually, then Storage_Upgrader_1_8_5. Now I can’t install any Update else because the Fairphone Updater don’t ask me for Superuser and if I restart, after downloading any of the FairphoneOS it can’t verify the Update, restarts and boots in the not updated System again. When I try to install manually from SD or Phone Storage in Recovery Mode, i can’t even browse the Storages.

-Turn off your phone by pressing and holding down the Power button.
-Go to ‘recovery mode’ by holding the Volume Up button, while at the same time pressing and holding the Power button. Hold these two buttons at the same time for about 10 seconds until the screen turns on, then release the buttons.
-You will see a resting robot lying on his back with an exclamation point.
-Now, select “Wipe cache partition”, and wait till you see “Wipe cache complete”.
-then "reboot system now"
and try to start your phone again

If this doesn’t work:

  • Try to connect your sd-card to your computer. (By taking the sd-card out of your phone and put it in separate usb-connector to your computer).
  • Take this file to copy/paste the .zip file (keep it as a .zip file, so do not unzip it!) to your sd-card. You need the file FP1U - Mid-2014 (2nd batch) & FP1 with unified storage because you already preformed the storage update. You only have to apply the storage updater once.
  • Put your sd-card back in the phone.
  • Restart the phone in Recovery Mode.
  • Apply update by going to navigate to the correct folder on your SD card where you put the .zip file.
  • After the installation, select “Wipe cache partition”, and wait till you see “Wipe cache complete”.
  • Reboot your Fairphone.

I’ll hope you will succeed this time.

1 Like

Hi Lidwien/*,

I’ve got same problems as described by fdblvw, but I have installed the files opposite way: First I’ve installed the Storage Upgrader, then I installed KolaNut, both from the page Manually install Fairphone OS software update version Kola Nut 1.8.5 of tab old partition layout. This was my understanding how to do on this page (I used this page because the Fairphone Updater showed me my 1.6 is current software as of May 15th).

I can’t tell if the installation of the second file was successful in some way or not. It should’nt have succeeded because I understand now that this used the old partition layout. But was is really in the Storage Updater OTA file? My impression is that it already contains a full 1.85 installation but with Storage Updater. Is this correct?

Anyhow, when I tryed recently to install virtually anything (e.g. whatever ROM provided by Fairphone) manually I got either “Signature verification failed”, or “Installation failed” (manually inside Recovery console after). Using old partition layout files tell me in Recovery Console that installation aborted due to non-fitting layout, this I can expect, of course. No wipe cache, no data clean before another update has helped so far.

Now I came to some state where It turned out to be quite hard to install anything from SD card, because I could not figure out, in which directory the Recovery console looks for SD card install. Its option just shows me an empty directory. Therefore I have switched now to install via adb sideload.

Trying to install Google Apps via either notification, Widget or Fairphone Upgrade App starts downloading from within Fairphone Upgrader App, then it asks to reboot, the green Android looks like it would install something, but in the end and after rebooting once more nothing obvious happened, Google Apps and Play Store are not installed.

Fairphone Updater software still tells me that 1.85 is installed, but in contrary to the description of Fairphone the telephone status still shows me the generic number 0123456789ABCDEF, system superuser has no entry.

How can I exactly identify which Fairphone version I have really installed (I don’t trust graphical program results much), why does Fairphone system / upgrade do not show up in system settings -> Superuser unlike in v1.6. And how I could manually install Google Apps into the system bypassing the graphical Updater?

My impression is that my issues may have same reason as fdblvw issues and same as Jonathan_Schwankenso in his forum post Google Apps can’t be reinstalled.


There’s a mixup about which file you need.
If you have applied the storage update you don’t use the file for the first edition Fairphones.
But you have to use the update for the second edition Fairphone.
See my other post.
Please try to update again with the correct file as it will probably solve your problems.

Dear Lidwien,

I can only re-apply via adb sideload, as I dont know where the recovery console looks for files when “installing from sd card”. But I get an error when adb sideload finished and tries to install the file after a few seconds it shows: “Installation aborted.” So I cannot update anything any more.

“installing from sd card” then it looks for your sd-card in your phone.
Try a ‘wipe data/factory reset’ in the recovery mode, reboot, stop,restart the phone and then try the correct update again.

Well, where is /sdcard (the place where the recovery console looks in for installing from sdcard)?

If it was the real sd card in the external sd card slot of the phone it was detecting at least some folders. If it was /storage/emulated/0 it would also detect something. I just detect that the plain start after wipe data deletes the symlink of /storage/emulated/0 which is present after using phone setup program which runs usually after wipe data. At the moment I run without. But whereever I could have the zip located, the recovery console cannot find the zip. This is why I ask.

I assume the “correct update” is something with new storage layout. This could then be either 1.85 or 1.6. But the result of either is the same: adb sideload file runs fine, then recovery console tries installing and ends with the message “Installation aborted.” after a few seconds of installing having the scrollbar running until approx 1/4 of its full size.


Hi all, the signature verification failed error is after investigation caused by a signature error in the google apps package for the 1.8.5 storage upgrade.

We temporarily halted the availability of the 1.8.5 storage upgrade. (everything else is available)

The developers are working on a new google apps package that will hopefully be available tomorrow to resolve the issue and enable all of you on the 1.8.5 single partition to re-install google apps.

A very dirty workaround might be to downgrade to 1.6 and then re-install google apps and then when the new package is available to re-upgrade.

1 Like

Hi there

After installing the new OS 1.8.5 I wanted to update the Google Apps, which goes smoothly, but the keyboard does not work. The error message is: The Application Android-keyboard (AOSP) has unfortunately stopped (translated into english). I installed Google Apps and restarted several times to no prevail.
Can someone please help?
Sorry if the same topic is already created but the other ones are for an earlier OS update.

Hi @McSkyMan, did you upgrade to the 1.8.5 storage upgrade? If so, there is a known bug that prevents you from reinstalling google apps at the moment. The dev’s are working on resolving it, I hope it will be fixed during tomorrow after which you can re-install.

I think, I am experiencing the same problem, installed the 1.8.5 update, then the 1.8.5 storage update (although not manually, but using the updater).
However, I can’t install anything else now, every attempted update ends with the “signature failed” error and upgrading from the sdcard also does not work, as there are no files detected on the sdcard.

Hi Nitram, this sounds exactly like the problem, tomorrow we hope to release a fix! :sweat:

Hi Marco,

good to hear, but the problem is, that I cannot install just anything from the Recovery console any more. I have described this behaviour in my postings before.

Also, please post where the Recovery console looks for its /sdcard folder. What is it, physically, and in which folder does it look, and if this is somewhat linked to (or from), from where to where would there usually be a link? I have written before that I have used adb sideload to circumvince the non-presence of /sdcard with the result explained before.


@Amber I tried also to update via ADB but this fails and the recovery tool doesn’t find the SD card or the internal phone storage…

Hi Marco, to be honest I do not know if I upgraded to the storage upgrade. I turned on wi-fi and my phone prompted me to update, I just tapped the notification and tapped “next” a lot (I don’t remember the process to the letter).
As far as I can tell I can install Google Apps. This may not be the problem. However, Google Store is not available - I can tell because when I go to settings by moving the finger from far left or far right to the right or left, respectively, and select the six dots, the “Play” symbol on top right is not there anymore. Whether this means Google Apps is not installed I do not know. During the last few hours I have installed the Google Apps multiple times - it downloads, installs, restarts, the android robot shows up, after some time black screen, then blue fairphone screen and then the phone seemingly works, except for the except for the ASOP keyboard not working message.

Hi, I’ve the same Problem like "fdblvw"
I downloaded the files from and there is the Storage_Upgrader still online, which causes the Problems…
Perhaps you will take it away…

I first installed the Storage Uprader and rebooted then.
Now I cant access any storages in the system recovery, not even my backup :frowning:

Tried with ADB to install the Storage_Upgrader / FP1_KolaNut_v1_8_5_OTA doesent work with the following error:
Invalid Partition setting
15:ebr2 3d80000:3d00000

Additionally, I have to say that I had installed CyanogenMod from chrmhoffman, but it doesn’t worked well and I installed the Original FP-OS again.

Hope that there is any solution soon :blush: thanks for your great work.

If I go to the Data Manager in the OS, and select the OS-Installation file, it’s opening it in the FP-Updater. It looks good until it reboots and the message pops up: is not correct
Perhaps this helps

Hi there!
I’m having the same troubles with the 1.8.5 storage upgrade. I tried downgrading, reinstalling manually and via the FP updater - none of that worked out…
I alway get the “signature verification failed” notice
Or when I try to Upgrade manually the SD Card isn’t detected at all.

So does anybody know when a new google apps package will be available?
Or is there any other solution to this bug?

Thanks for the good work, looking forward for some news on this!

Please see in the topic, there is a solution with the SP Flash tool:

1 Like

Works like a charm, used the scatter file to Downgrade to 1.6 and then updated automatically to 1.8.5


The problem is I can’t install anything because the SD Card can’t be found.