Shortcuts disappeared after reboot

Having never been able to reproduce the problem, yesterday / this morning I have at last done so. All the shortcuts I created back on 28th June (see above) and since, have gone. These were mostly web-related, either simple URLs or PWAs created from Firefox, but also one Contact.
What might be useful in this, is that I know what I did differently last night. As I’ve already said in this thread, I turn my phone off most nights and have never encountered the problem before, but last night I needed to check something in fastboot mode. So I turned off the phone, then turned it on in fastboot mode, and having done what I wanted to do, used “START” to boot into FPOS. I hadn’t done this since creating the shortcuts back in June.
Unfortunately I’m not able to reproduce this just by returning to fastboot and then STARTing, but this info might point to something related to boot conditions which could explain the apparently random occurrences of the bug.
I have an SD card but frankly I don’t think it’s related. Looking like a FPOS Android 11 thing as things stand. And to be clear: it’s not just web shortcuts, any sort seems potentially affected, all mine disappeared at the same time.
I have informed Fairphone.

4th occurrence this morning. Phone was running slowly and Ecosia kept crashing so I rebooted. All Internet shortcuts gone and all WhatsApp chat shortcuts gone, from the home screen.
Don’t know about Drive shortcuts because I hadn’t bothered recreating them after the 3rd loss. Box shortcuts survived this time.
I’m getting closer to giving Nova another try since Fairphone Support had nothing better to suggest than a factory reset.

It’s a long shot, but there has been a plethora of people complaining that launchers keep asking to be set as default, the problem being attributed to the ‘Well being’ app. Maybe something similar is happening here

Have you tried a) A Safe mode start and b) disabling the Well being app and as many others of the default you can?

The shortcuts disappear after a reboot so I’m not sure I see how using Safe mode would help?

First there was this

I thought starting in safe mode would first check out that no custom apps were dragging the phone’s ability to running slow and crashing, and at the same time internet shortcuts can be made from chrome, the default browser ~ then it can be assessed if the shortcuts and other issues survive an intentional or otherwise reboot.

How do I restart in Safe mode? Although if I do, and the shortcuts remain, it doesn’t tell me much because they only get deleted after some reboots (4 since opening this thread), not every reboot.

I’ve disabled Digital Wellbeing now, since I don’t use it, so we’ll see how things go for a while.

There’s a link in the post where I mentioned it :slight_smile: Let’s hope disabling Digital Wellbeing does the job.

Starting in safe mode would be a laborious option but you mentioned other problems too.

  • The phone may not run slowly
  • Using Ecosia as a search engine in chrome should require any custom apps.

The idea is that running in safe mode without any custom apps would help eliminate them as problems, whereas the disabling of Wellbeing can be done in either case. Hopefully the later is all that is required.

After taking some photos this morning, all of my chrome shortcuts, which i had saved in different folders to my homescreen have disappeared. The folder icons are gone leaving an empty space where they used to be.
Rebooting several times has not helped.
Luckily i use Bookmark Folder App, which has kept a back-up of the various shortcut links, but what an inconvience.
Running latest Software and Security updates.
Has anybody else experieced this?
Also is there anyway to get them to reappear?

Update: 8 reboots (including a security update on the 6th) since disabling wellbeing and still no loss of shortcuts. Pretty conclusive I’d say. I’ll reopen the support ticket and let Fairphone know. Maybe they will have a better suggestion than restore to factory settings now. Maybe not!

1 Like

Well thanks for the update. That well being app seems to conflict with a number of opp’s. (launcher request)Luckily it was one of the first things I disabled and then uninstalled, so never had an issue :safety_pin:

Unfortunately for me, disabled the Digital Wellbeing app, rebooted, and at the very first attempt all shortcuts were deleted again.

So while the solution may work for some, it is not a reliable workaround…

Apparently there are other apps that can be disabled . . .

True… At least 100… But since there were promising indications about disabling the Digital Wellbeing app, I thought I’d try this one and report that, unfortunately, no, that is not the solution

However… The very first reboot after disabling Digital Wellness removed the shortcuts, but after that, it has not occurred again. So maybe it does work, maybe not 100% but definitely the shortcuts are more stable now.

Update - about 16 reboots since disabling wellbeing. After two of them I lost the only Drive shortcut I had. I didn’t always have it there so I wouldn’t call it a 12% failure rate - it’s more than that.
If it’s just Drive shortcuts I’ll probably learn to live with it.

1 Like

For me, it’s any Spotify shortcut. Since I listen to many podcasts, it’s really annoying. Especially that I have to do the reboots caused by lack of audio functionality in WhatsApp from time to time.

Have you tried disabling the Digital Wellbeing app ?

1 Like

I’ve read about this solution in this thread, so next time I have this issue, I’ll definitely try this one and then write here if it works :slight_smile:

1 Like

Today I talked over the phone, the first time in weeks. And just afterwards I noticed that audio is not working again, so I rebooted the phone. Unfortunately, after that, Spotify shortcuts disappeared again. So even though I tried the Digital Wellbeing disabling trick, it didn’t work for me ;(

1 Like

I have the same problem since a couple of months. A friend of mine, too. All web shortcuts disappearing (sometimes - not every time) after reboot.
FP3+, standard Google launcher, my browsers: Firefox as well as DuckDuckGo.
Even a factory reset of my FP3 did not solve the problem.