Several issues - maybe core module broken? bad signal, bend to work, reboot loop, unexpected reboots

Hi,

I have several issues with my Fairphone 2:

A) bad signal (1 – 2 times a day)

B) Display some times only working if I bend the phone case (1 time a day, but recently more often)

C) cannot turn off phone, it always reboots (always)

D) Unexpected Reboots (~ 2 times a day)

Here are more details on each issue:

A) I am experiencing this since minimum 1 year (probably even longer). It only happens from time to time so it’s hard to nail it down. If it happens my phone indicates that I have signal but e.g. loading a webpage won’t work because I have no Mobil connection. Or I try to make a call, the phone dials but then after some seconds I get the message “no signal”. It also happens quite often that some one tries to call me but I’m not available. When the problem occurs I can usually feel that the phone heats up quickly in the top area and the battery is loosing power very quickly. There are 2 ways to fix: either just wait some minutes until the phone “recognizes” and starts to register to the network again. Or I enter flight mode for min 10 seconds then disable flight mode again. I already changed the Carrier and also reset my phone completely. I also tried different versions of FP OS as well as linage OS. None helped so far. I also checked connection of antenna cable, cleaned contact pins, disassembled and put together all modules. No success.

B) I see this issue since approximatly since one month now. The last 2 days it increased, so that it is hardly possible to use my phone. The problem is that the phone is acutally working fine but when I try to unlock it the display just stays dark when I press the standby button. If I bend the phone (not sure where or how excatly I have to bend) the display comes up. Some times it keeps on working fine – some times I have to bend it continuesly in order to make the display show something. If the display is once on and I relief the bend, the display either just freezes or shows stripes, greys out the screen. I first thought that the display module is broken again but I switched to a completly new display module and I can see exact same behavior. I have the feeling that it is somehow related to temperature. I‘m not sure but it feels like its working better when the phone is colder.

C) This happens since I switched to the new camera module. I‘m running Lineage OS. I just found this post while typing these lines and it seems that it really fixes my issue :slight_smile: Now I can finally encrypt my phone!

D) The phone just reboots. I think it happens like > 2 times a day but very often I do not even realize it because when I put it out of my pocket it is just as before. But I usualy realize it min. once a day.

Conclusion: I suspect that the core module is broken as the cause for A) and B) maybe also for D). Hence I would like to get a new core module. As far as I understood I have to write to the support team for that. But it also seems that the core module then costs arround 300€ which is too much for me. For 300€ I can even get a refurbished FP2 or any other phone.

Does anyone of you have different suggestions on what I can do? Or what the reason for one of the issues might be? Or maybe suggestions on how to fix one of the issues?

1 Like

If you happen to have #fairphoneangels in your vicinity, they might be able to help you check which module is at fault by swapping them.

Activating the flashlight is just a workaround.
The issue was supposedly fixed in LineageOS back in March, which build are you running?

You might be interested in the #rebootsguide .

1 Like

Thank you for your answer!
I will get in touch with a fairphoneangle regarding bad signal A) and bending the phone B).
C) Indeed I’m running LinageOS 15.1-20190227. I will also update to the latest build. However, the problem is fixed already by applying the workaround once (turning off phone while flash is on). If I now turn it off, it stays off. But it’s always a good advise to update to the latest version.
I checked out the #rebootsguide but I find it quite hard to narrow the reboots down to a specific situation. So far I wasn’t able to determine a specific scenario, location or app usage when the reboot occurs.

1 Like

Heyas, I have sent in my phone with quite similar symptoms. I will receive it soonish with a new bottom modul + new battery, both on warranty. I can let you know if things improved, also in case I get an answer from support how bottom module was related to the symptoms.

@sniggles thank you. Which of the issues described do you mean? I would be very interested to hear if your issues have been fixed by replacing bottom module and battery. Can you already give feedback? I already replaced display module for a test but that did not help anything.

I made the same experience; issues were gone for a few days but then reappeared quickly and frequently. will contact support again as soon as I catch the issue on video.
Mainly the lacky input is back. So I can’t type anymore and the phone freezes. Reboots, which I had pre-repair, didn’t reappear, neither the unexpected reboots. So reading your message again B,C,D didn’t come back yet, A I didn’t witness at all.
Seems like for your issues the fix did work so far :wink: For mine (which seems to be a different one) it didn’t fix it; which I was expecting to be honest.

Anyways, hope I could help. Good luck debugging :+1:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.