Serious WhatsApp blues


After some years of faithful service of my FP2, and lots of time on Fairphone Open OS (latest Update installed) I ran into a serious WhatsApp problem.

I have also opened a ticket with WA support at Meta, because it could be on the WA side.

When I start WhatsApp, which updated just a couple of days ago into (through Aurora) WA instantly displays an error message, that it encountered a problem and needs to be uninstalled and re-installed. Seconds later this message disappears and I land on the start screen (note: WA has not really terminated, a look into APPS shows it’s still running. It can be killed there, but that doesn’t make a difference). Unless killed in this fashion, a tap on the square button on the start screen will always bring WA on again, showing the “a problem” screen again…

Android displays a warning that WhatsApp terminates (i.e. crashes) often…

As I was told, I tried to unistall. But that fails, the uninstaller also “terminates often”. Even when I call the uninstall routine via APPS it doesn’t work. Also uninstalling through Aurora fails.

I can, however, install this version afresh over the old one, with no problem. But still it won’t run…

So far support from Meta did not bring a solution, asking questions of screenshots (which I sent to them), asking me about the “browser window” including the “address line” ??? I run WA as app, not in a brower.

And before anyone asks: Yes, I did a serious of cold starts of the OS, to be sure, but to no avail…

WA ran here for years, received several updates, with no problems whatsoever.

Thanks for any help

I also saw two instances of Aurora complaining about parsing errors (with Opera and with Komoot). Komoot left a broken Komoot. But Komoot could be uninstalled and re-installed, and runs again, and the update of Opera went through as well. I did open a ticket with Aurora on that, although the issue “seems” to have gone away. WA still won’t run or be uninstalled…

In the App Lounge of /e/OS you can install WA.
On my FP2 I am on /e/OS1.18-r-20231207360610-stable-FP2

I can install it via Aurora as well (no errors), but it won’t run afterwards… And I cannot UNinstall…

On which version of /e/OS are you?

hman2 is not running /e/.

I have a FP2 running FPOS though not FPOOS. Would it be worth checking?

Maybe you can deinstall using adb?

Thanks, I haven’t used adb for a long time. I have Linux Mint on the PC, so I could do that. What would be the command for that? So far I haven’t received a constructive reply from Meta…

Have a look here and the linked xda topic (there should be info about the commamd for which you need root, however try first as described the the FP4 Guide

To really remove it you might need roott, however that might be easy to approach on the FP2.

I wonder whether this could be an incompatibility issue of FP Open OS with What’s App ? But they list Android 5 and SDK33 as minimum requirement. The fact that G Play Services are missing so far never posed a problem with Whats App (in contrast: AccuWeather always complains after each and every startup that Play Services are missing, but besides this complaint AccuWeather runs fine).

Also, I’d like to point out that Aurora could be at fault here. Shortly after the WA issue came up, I saw two instances where Aurora complained about parsing errors while updating Opera and Komoot. With Komoot, the error messages disappeared after three times clicking OK, but left the Komoot installation damaged und dysfunctional. But Komoot could be uninstalled and re-installed without errors, and runs again now. While Komoot was dysfunctional, it was no longer listed as having a waiting update, while Opera, where the error never went away even after a dozen clicks on OK, constantly was listed as having an update.

After Komoot could be succesfully re-installed, the update of Opera went through flawlessly.

I have opened a ticket with the Aurora devs on that.

Hm, the article (thanks!) talks about debloating, i.e. removing preinstalled apps that normally can’t be removed. But to my understanding, this is just a blockage of removal introduced for marketing reasons, not a technical problem which my WA installation has. Normally, WA can be removed as it is no preinstallation.

Well the command should be still the same?

I’ll give it a try, once I’m back home (and Meta did not give me other advice). Thanks.

“Latest” here meaning “last”? I have run into many serious issues since installing the last FPOOS update, to the point of considering to dump it: Regular app crashes (of any app), random reboots, random touchscreen freezes (apps keep runnning, e.g., dictation continues until I reboot manually :slight_smile: - one of them once every hour of phone usage.

I have now managed to uninstall Whatsapp. It’s really strange, I found this in a discussion of some user with a different phone that also could not uninstall: The memory card had to be removed.

Without my SD card, I could successfully uninstall Whatsapp. First I was asked whether I wanted to keep 42+ Mbytes of data (which I do), then it got removed. I don’t have the faintest idea why this could have been a problem…

I could re-install it with Aurora. But - It still won’t run!

“Whatsapp has a problem and needs to be installed again”.

And yes, this also happens with the SD card removed…

Also interesting to note that the version of Whatsapp that Aurora offers is not what Uptodown lists as the latest. According to Uptodown, is the latest, dated Jan 12. Aurora offers me, which Uptodown doesn’t have. They got, dated Dec 21… Strange: There are version numbers that are higher than .25.84 that have been published before Dec 21?? Does Meta use a numbering scheme that I do not understand?

Some Youtube videos suggests that an outdated WA version could be the problem?

Wow. Whatsapp’s homepage lists ?!?!

I have Version on FP4+5 from Aurora so the Version isnt really outdated or making problems with Android 13 and is dd. 18.12.23…