Serial Number, IMEI1, IMEI2 gone missing

Hey,

I got my fairphone 3 on Saturday and first tried out Android, updated to Android 11, everything worked.
Then I decided to install ubports which failed as in it didn’t go past the boot splash screen.
Okay, back to Android 11 using the manual restore tutorial from the support page, which got me back Android 11 or “Fairphone OS”. But when I tried to sign into Google it failed. After some investigation I found out that the serial number now shows “no_custer_serial_number”.
After some more investigation I deleted modemst1, modemst2 - which (with the knowledge I have now: obviously?) deleted the IMEI 1 and IMEI 2 serial numbers (both showing “0”).
So then I tried a QDL reset yesterday using the “Fairphone 3 unbricking” post here in this forum.
The ‘edl wl unbrick’ command passed, but the edl reset command failed.
When restarting in qdl mode, only running the edl reset command succeeded.
However still no serial number or imei1/2.

Am I on track to recover the serial numbers using QDL and the combination of the two commands is supposed to work without a restart?

Or is there a totally different way to get them back (i.e. send the phone in).

Thank you in advance.

Hi @lastc, the serial number is stored on the prodinfo partition. It might get lost when custom flashing tools/scripts touch the wrong partitions… See also the discussion here: FP3 after installation /e: wlan always off, MAC 2:00:00, phone number not identified, no ringtones, no lamp - #16 by dk1978 - Easy Installer - /e/ community. So the serial can be recovered, assuming you still know what serial number your device had.

We don’t have any official tool to recover the serial, since the partition is not supposed to change after factory production. But if you know how to work with C code: Related sources you can find here: app/aboot/devinfo.h - kernel/lk - Gitiles. Essentially you would just need to write a file set up like that struct prod_info via fastboot flash raw to the prodinfo partition.

As for the IMEI/IMSI, I’m currently not aware how this can get lost on a FP3.

2 Likes

Thank you. I will try to patch the prodinfo partition:
This is what it looks like right now:
Screenshot_20220620_112450

I guess I have to patch ISN and SSN?

SSN = Serial Number? (Which I still have)
But what is ISN?

Hey lastc, where is the BOX - packing of the FP? because there is a sticker on the backside with IMEI1 an IMEI2 and a barcode, what is the serial No., on.
Did you throw them away?

SSN is the relevant value indeed, see target/msm8953/init.c - kernel/lk - Gitiles. ISN is a “factory serial number” and not really relevant for Android. For sake of consistency, you could write your serial to both entries though.

1 Like

I guess the primary interest here is to get these numbers back into the software, but anyway, you can also find the IMEIs in the battery tray of your FP3 (scroll to “Non-working phone”):

The photo there can be magnified.

I did exactly that. I patched the ISN = SSN. Now I can log into Google again! Thank you!
Now to the IMEI problem… :smiley:

The barcode is there with IMEI1/IMEI2 and anoter Barcode which does not seem the be the serial number. But I had saved the serial number and have patched it successfully now.
The question is how can I can the IMEI back into the system…

Ups, sorry, my misunderstanding.

As for the IMEI/IMSI, I’m currently not aware how this can get lost on a FP3.

Where is the IMEI stored typically? In the qualcomm chipset? Or/and in modemst1/modemst2?

Hey @lastc, late reply on this topic: If you erase modemst1/modemst2 on FP3, your IMEIs are gone indeed. So it’s very likely that this is where it broke for you. I don’t know of a way to restore those partitions on FP3 without access to proprietary tooling though… it’s not as simple as the serial number.

FYI, this is very device specific. On FP4 for example the modemst* partitions get removed in the regular manual/factory flashing.