Sent SMS incorrectly marked unsent after FP restart (Do you also have this issue?)

Continuing the discussion from Sent SMS incorrectly marked unsent after FP restart:

Hey guys! I am also having this issue:

Does someone else get this? Please post here, to find out, how many people are concerned.
Thanks!
Stefan :slight_smile:

No, this never happens on any of my messages

Is there anything in common between the messages that this happens on?

I can’t see anything. It happens randomly. My contacts are stored in a Davdroid account and not in the phone memory, but I think it shouldn’t be this.

I will see if the problematic messages have something in common.

Edit: I’m trying to get to the root of this. What I noticed today was that with some messages the little tick (with the send time) does not appear after pressing “send”. Instead the little turning wheel stands still and the sentence “being sent” does not go away. Next time I restart, these exact messages are falsely marked unsent.

@m1234 I would like to find out, why apparently this only happenes to us two. Which operator do you use? I am on A1 in Austria…

Edit2: I think, I found a reason. I have the habit of killing apps immediately after I stop using them. This is the same with the sms app: I normally don’t wait until the SMS is marked as sent, but I press and hold the home button and kill the app. When I open the SMS app like 1 minute later, the turning wheel below a message is not turning and the send time won’t be displayed. @Chris_R could you please try to reproduce this (Killing the SMS app before the SMS has been marked sent)?

My contacts are stored in the phone memory, so I guess that’s not causing it. I also went through my messages but couldn’t make out any things they had in common (the only “special” characters used were “,” “.” “(” “)” “:” so this should not be an issue)…

But I’m using YESSS (Austria) which is also a part of A1 - so could this be an operator problem?

Weirdly enough I couldn’t reproduce this bug with SMSdroid.

@Edit2: I could reproduce this only to some extent - the sms is shown as “sent” but not as “received” when I immediately kill the app, then restart my phone and open the sms app again. The sms was received though. This happens only in some cases (probably a matter of how fast the sms can be sent vs. how fast you kill the app?)

OK thanks for your input. So two theories here:

  1. Its caused by the operator / mobile network (A1 in Austria)
  2. When the default SMS app is killed too soon, the SMS does not get marked as sent (although sent correctly).

I tried the second theory with a SMS longer than one page and killed the SMS app immediately. When I checked back some minutes later, I could reproduce the issue. So I think the following is indeed the case:

My conclusion: The task for sending the sms gets fullfilled correctly, but when the app is closed, it does not notice it and thus marks the SMS as “not sent”. If that’s the case, it shouldn’t be too hard to fix this. But let’s wait for some other opinions.

####Steps to reproduce

  1. Write a SMS with more than one page. (It should take the phone some time to send it.
  2. Don’t wait until it is marked sent. Kill the app immediately (press and hold the home button and swipe it away).
  3. Check back some minutes later. The label below the SMS will still say “being sent”.
  4. Restart your phone. A notification appears saying “Message could not be sent.” (Or similar).

Edit: Could someone please try to reproduce this issue to see if it is a bug?
@paulakreuzer @Chris_R

1 Like

Will have a go later today and post back…

1 Like

I’ll try when I’m back in Austria. Don’t want to roam “just” to test your theory. :wink:

1 Like

I just tried but couldn’t reproduce it.

Which operator are you on? Maybe it’s really an issue with A1 and its MVNOs.

I work around by not killing the SMS app too soon.

1 Like

I’m with “3” and I have the current beta version of Fairphone OS.

OK, so either it is resolved in the beta (I’m on 1.8 still), or it indeed is an issue with my operator…

I get same notification every time i open the app messages ‘message not send’ and it says that 5 messages are not send. I deleted them long ago but the notification keeps coming back…
Be great if there was a work around

Okay, we need some more information here: to clarify, you experience this on a FP1? What exactly happens? Can you share a screenshot?

These “ghost SMS” are a quite common problem on Android phones. In order to get rid of them, you need to install an app. Have a look at this topic:

Okay, its a FP2 software 1.2.8.
When i open the message app (standart android), i get a notification saying: ‘message not send, 5 messages could not be sent’. (See screenshot in danish). These massages no longer exists in the app, i deleted then long ago. The problem started with some of my first messages, I can’t say if it was a certain kind of messages, but it has not been a problem since sending - only the same notification repeting.
I hope this clearifies it… Let me know if you need more info
Best regards
Morten