Sensors won't show after water incident

So I had a little water incident with my FP3.

Luckily, after sun-drying it for several hours, most of the features are working normally again: Display, Wifi, mobile data, microphone, GPS, Bluetooth, speakers, light, fast charging, both cameras. All fine.

But, every sensor is not available. Proximity, Accelerometer, Gyroscope, light sensor. All sensor apps either report missing sensors or firmware problems.

I figured, that light and proximity sensors are on the top module and therefore could be replaced. But Accelerometer? And I wonder, why all sensors broke, while everything else is fine, maybe the problem is some other core component?

Are there any further checks I could do or can I hope, support may be able to repair this?

Thanks in advance

Welcome to the Community Forum.

First things first: Did you remove the battery right after the water incident?

1 Like

Well, the problem was, that it was on and got sprinkled in the garden for 30 minutes or so. It was off when I found it and didn’t turn on
Then I removed the battery and dried it .
Off course it’s likely, that during this time some components were damaged

1 Like

I don’t know how exactly you got the sensor tests. If you downloaded and installed additional apps for that, you might also want to do the “official” built-in tests (only in Fairphone OS) available by calling * # * # 6 6 # * # *

2 Likes

Thanks, that was helpful.
But it provided the same result:

  • Proximity switch: not detected
  • Compass: all values 0 and not changing
  • Accelerometer and Gyro: “It’s fail! SensorType = 1 /4 no value”
  • Ambient light sensor: shows no value

All other tests worked

Your drying regime seems minimal, some 24 hours in a flow of air would be more appropriate. Hours in direct sunlight can make the phone too hot. There’s no other decent way to dry.

Did you dismantle the phone into separate modules and as the warranty will be void you can also dismantle some of the modules to dry and clean more effectively.

Note: the proximity sensor only shows as working when you obstruct it, otherwise the test shows ‘Proximity Switch Not detected’

The compass, gyro etc. are very small and part of the core module and it is likely they are still wet and shorted.

https://forum.fairphone.com/search?q=water%20damage

2 Likes

Thanks for your answers.
Yes, my drying maybe was a bit short. Of course I needed the phone (what else :wink: ) and was happy, that the main functions all seemed to work.

Today I opended the phone and disconnected all modules - everthing looked normally. Also the one “white dot” visible didn’t turn pink/red like suggested in the other thread.
I couldn’t get the cover off the core module as I didn’t have such a tiny torx screw driver.
I also didn’t want to open the modules as I don’t want to risk any more damage.
So for now it looks like I will have to live with it…

1 Like