SD card problems although formatted as portable storage

In the beginning, I suspected the FP of somehow corrupting the card’s file system during formatting which would have made it necessary to do a fresh format on a computer when giving it another try. Don’t know if this makes any sense but it seemed to help with my SanDisk together with the latest updates.

Well, maybe in older firmware versions, but not the newer ones. I checked the filesystem with CHKDSK on my computer: all okay.

I’ve tried several fresh formats (with the correct data format, checked this) on computer, but none helped.
Although that was before the most recent update and now I don’t know if I would want to try :sweat_smile:

1 Like

Not the filesystem but the partition table, at least in my case. For one of my Transcend cards, the Fairphone kept destroying the partition table during formatting. After creating a GPT partition table and adding an exFAT partition using a PC it works fine.
It also kept formatting my 32GB card to FAT32 instead of exFAT, that had to be fixed on a PC as well.

So something is definitely broken there, would be interesting to know what the Samsung SDs are doing differently. Are they shipped preformatted in a way the FP4 accepts? :thinking:

1 Like

I have used a SanDisk Extreme 1TB microSD card in my old Motorola Z3 Play for 2½ years with great success. I transferred it to my new FP4 this week and the FP4 will not read it. It can see all of the folders under root but the contents appear empty.

This microSD card is C10, U3, V30, 4K, A2.
Occasionally, FP4 prompts to initialize the card either internal memory or external. I have selected external and it will not read it even after an apparent initialization.

I have put a 256GB Sandisk Extreme and the handset will successfully read it.

Is there a known issue with this 1TB card in the FP4?
Should FP4 read it?



You may also like to read


Welcome to the community @UCTfp :wave:

I’ve moved your post to the general discussion about FP4 SD card problems.
SanDisk cards so far seem to be the most problematic regarding compatibility, interesting that your second SanDisk card works without problems :thinking:

If you have the time, please add your problematic card to the wiki @anon9989719 linked to :pray:


Any luck with the new update that was released yesterday?

I wanted to ask the same question and also wanted to give an update about two things I noticed.

First, I discovered that actually the VLC player I’m using currently reads all music on my SD card, as opposed to what I first thought. However, it does not read correctly as many albums and/or tracks are filed under unknown which wasn’t the case with the player I had used before (which was Pulsar). So I think that is connected to the reading issues.

Another thing from today: I wanted to try to move my huge Spotify music collection (40 GB) from internal storage to the SD card, which I had bought initially for this purpose (and the other music files I have). Might have been a try after the new update, and there too I discovered that I had previously made a mistake (save spaces in Spotify labelled as “SD card” despite being internal storage, just discovered this today too).
Anyway, after the whole transfer process I get a notification that something has gone wrong and I should check the SD card (also permissions). I did that and thought it might have been coincidence, so I tried again. Then, the transfer process went through, the transfer notification disappeared - now Spotify does not work anymore.
When I start it, the logo appears and then a black screen and nothing else. After a while, the system notification “Spotify is not responding” appears and I can wait for a reaction (to no effect) or close the app.

This might be a bit off-topic (and maybe warrants a new thread for a solution), however I wanted to share the information for others, maybe it helps.
I will probably de-install Spotify now and only re-install it when the SD card issue is (hopefully soon) solved, so that I can put all music on my SD card then (I don’t know of any other solutions I could try right now that don’t involve de-installing).

Edit: Taking photos with the camera and storing them on the SD card seems to work good so far.

Best regards and have a nice evening!

Sorry, my phone no longer receives updates.
I’m stuck on A.107… :frowning:

Any idea how to upgrade when “Check for updates” tells me that “no updates are available”?

Contact your carrier or #contactsupport for that. I’m not super familiar with the releases, how far are you behind? If it’s just one release than usually it takes a few days.

Did you use Spotify with a SD card the last years? I gave up on trying as Spotify over and over again lost all downloads when I selected the SD card as storage location. The SD card itself was always working well for all other use cases. so when it comes to Spotify and issues I would always blame Spotify first😉 for curiosity I just tried it on the FP3 and see the exact same issue as you described, the APP is crashing…

Thank you very much for your quick response!
On my previous mobile phone (my first with Spotify), I had used it without downloads at all bc internal storage was 16 GB there and my old SD card had 16 GB too iirc. So I can’t really compare.

I forgot to mention that the app system still shows my downloads stored on internal storage so I think they’re not exactly lost, but I can’t access anything in the app anymore.
(Might be worth it to ask Spotify Support about it? To give it up with SD cards and SD cards completely would be kinda sad to me - I could stop using the app altogether then bc I mainly use the downloads there :confused: )

I contacted the spotify support once when the APP was completely useless on Android (different versions) while it workwd well on iOS…they where responsive, but… At the end I dont think they really care (else they could just look at the play store reviews) and almost with each update it deteriorates somehow…

What a shame… I really like the app. There also was a notification so I thought most of it still works. I still de-installed and re-installed Spotify, it works again, I logged in and noticed that also now the SD card is selected as storage space, playback works and internal storage also shows less.

Today, finally, I received A.128, too (update is running).
Updates between A.107 and A.128 have been skipped (

I’ll check if my SanDisk SD card becomes usuable with this update and report the results.
However, the release notes contain no hint regarding SD cards:


I can confirm that A.128 brought NO improvement to the (my?) SD card issue.
Sorry, SD card is still not working.

Here is the Fairphone support response to my ticket on this topic:

Regarding the SD card issue, unfortunately, currently, we can’t provide a time estimate on when your specific problem will be fixed. Updating to build A.128 may bring some minor improvements to SD card functionality. If you don’t see an improvement, let us know and we’ll look into how else we can help.

So had my FP4 since March - transferred over my old SD card from my Nokia (music & photos & downloaded podcasts) and it worked fine - until this Monday when it stopped working & couldn’t be read. Attempted to read it via my laptop & it hung for ages / got very hot and then died.
Ordered a SanDisc 64 as been happy with them previously then found I was in the same place as a lot of you - worked fine last night when I downloaded a load of my music files but then this morning it said can’t be read / showed up as empty. Re-formatted it using my other half’s Samsung as it kept falling over at 20% on FP4.
Now working for about 15 minutes at a time. Then shows as ‘empty’. Reboot phone - all okay again. Repeat.
Having read to the bottom of this thread, I’ve put the SanDisc back in its packaging for return & ordered a Samsung. Fingers crossed that works.

1 Like

Neither firmware version A.142 nor A.149 brought any improvement to this issue.