SD card problems although formatted as portable storage

Hmm, interesting, skipping through this topic it seems most reports are talking about SanDisk cards.

:wave: Who in this topic is having problems with SanDisk cards and who experiences problems with another manufacturer? :thinking:

Maybe it’s me filling up this thread? If so, please apologize.

I think the Samsung Evo has most positiv reports and yes def SanDisk seems to be most problematic

Else we have a wiki


I know about the wiki, but according to the wiki apart from me, no one else seems to have problems with their sd cards :smirk:


1 Like

I think many had issues with SanDisk and bought a Samsung Evo instead…else looking at the wiki (after sharing :see_no_evil:) it does not cover all experience, because interestingly not 1 SanDisk is documented under problematic…so indeed not that helpful

1 Like

I did a quick (rough) count of the reported brands in this topic:

Manufacturer # of reports
SanDisk 10
Samsung 2
Transcend 1

I wouldn’t call that a SD card problem, I’d call that a SanDisk problem… :thinking:

You are right, a lot of people who initially reported having problems with a SanDisk card switched to Samsung and seem to be happy :+1:


OK I don’t have files that big, no great videos :slight_smile: but thanks for the warning, which I ought to know :blush: I’ll reformat some for future proofing. Thanks.

I don’t even have a website that uses that much :slight_smile:

Yeap all mine are SanDisk too

Don’t know if it was just me, but I understood the wiki was mostly for working SD cards.

In the beginning, I suspected the FP of somehow corrupting the card’s file system during formatting which would have made it necessary to do a fresh format on a computer when giving it another try. Don’t know if this makes any sense but it seemed to help with my SanDisk together with the latest updates.

Well, maybe in older firmware versions, but not the newer ones. I checked the filesystem with CHKDSK on my computer: all okay.

I’ve tried several fresh formats (with the correct data format, checked this) on computer, but none helped.
Although that was before the most recent update and now I don’t know if I would want to try :sweat_smile:

1 Like

Not the filesystem but the partition table, at least in my case. For one of my Transcend cards, the Fairphone kept destroying the partition table during formatting. After creating a GPT partition table and adding an exFAT partition using a PC it works fine.
It also kept formatting my 32GB card to FAT32 instead of exFAT, that had to be fixed on a PC as well.

So something is definitely broken there, would be interesting to know what the Samsung SDs are doing differently. Are they shipped preformatted in a way the FP4 accepts? :thinking:

1 Like

I have used a SanDisk Extreme 1TB microSD card in my old Motorola Z3 Play for 2½ years with great success. I transferred it to my new FP4 this week and the FP4 will not read it. It can see all of the folders under root but the contents appear empty.

This microSD card is C10, U3, V30, 4K, A2.
Occasionally, FP4 prompts to initialize the card either internal memory or external. I have selected external and it will not read it even after an apparent initialization.

I have put a 256GB Sandisk Extreme and the handset will successfully read it.

Is there a known issue with this 1TB card in the FP4?
Should FP4 read it?



You may also like to read


Welcome to the community @UCTfp :wave:

I’ve moved your post to the general discussion about FP4 SD card problems.
SanDisk cards so far seem to be the most problematic regarding compatibility, interesting that your second SanDisk card works without problems :thinking:

If you have the time, please add your problematic card to the wiki @amoun linked to :pray:


Any luck with the new update that was released yesterday?

I wanted to ask the same question and also wanted to give an update about two things I noticed.

First, I discovered that actually the VLC player I’m using currently reads all music on my SD card, as opposed to what I first thought. However, it does not read correctly as many albums and/or tracks are filed under unknown which wasn’t the case with the player I had used before (which was Pulsar). So I think that is connected to the reading issues.

Another thing from today: I wanted to try to move my huge Spotify music collection (40 GB) from internal storage to the SD card, which I had bought initially for this purpose (and the other music files I have). Might have been a try after the new update, and there too I discovered that I had previously made a mistake (save spaces in Spotify labelled as “SD card” despite being internal storage, just discovered this today too).
Anyway, after the whole transfer process I get a notification that something has gone wrong and I should check the SD card (also permissions). I did that and thought it might have been coincidence, so I tried again. Then, the transfer process went through, the transfer notification disappeared - now Spotify does not work anymore.
When I start it, the logo appears and then a black screen and nothing else. After a while, the system notification “Spotify is not responding” appears and I can wait for a reaction (to no effect) or close the app.

This might be a bit off-topic (and maybe warrants a new thread for a solution), however I wanted to share the information for others, maybe it helps.
I will probably de-install Spotify now and only re-install it when the SD card issue is (hopefully soon) solved, so that I can put all music on my SD card then (I don’t know of any other solutions I could try right now that don’t involve de-installing).

Edit: Taking photos with the camera and storing them on the SD card seems to work good so far.

Best regards and have a nice evening!

Sorry, my phone no longer receives updates.
I’m stuck on A.107… :frowning:

Any idea how to upgrade when “Check for updates” tells me that “no updates are available”?

Contact your carrier or #contactsupport for that. I’m not super familiar with the releases, how far are you behind? If it’s just one release than usually it takes a few days.

Did you use Spotify with a SD card the last years? I gave up on trying as Spotify over and over again lost all downloads when I selected the SD card as storage location. The SD card itself was always working well for all other use cases. so when it comes to Spotify and issues I would always blame Spotify first😉 for curiosity I just tried it on the FP3 and see the exact same issue as you described, the APP is crashing…