SD card problems although formatted as portable storage

Same with my support ticket. I’m inclined to buy the Samsung Evo just to have my peace.

1 Like

@Zr4 have you tried this:

1 Like

I tried that earlier but not yet on A.0103 … Groundhog Day :chipmunk:

1 Like

Hi, I was wondering if my suggestion fixed it for you. It did work for me back then.

1 Like

FP4 256 GB with firmware A.103
SD card: SanDisk Ultra 200 GB

SD card doesn’t work.
Waiting impatiently for a fix.

This topic is about use as portable storage, but it seems you are saying the SD card doesn’t work at all?

If the latter is what you mean then have you seen

1 Like

Please be more verbose about what’s not working and what you tried to get it to work. Did you already try to format the SD card on a computer first to exFAT before you format it on your phone?

1 Like

I tried everything of the above. Please see my previous emails in this to thread. They were quite verbose.
I just reconfirmed that A.103 brought no improvement.

Ah okay! To make these connections easier it may be a good idea to either reply to your own message or leave a URL to that reply in your update. Otherwise it becomes hard to keep track of information.


Those two reports seem quite contradictory to me:

Is it working but you still have problems with MediaMonkey? :thinking:

If that’s the case this might be a MediaMonkey and not a Fairphone problem…

1 Like

Doesn’t sound contradictory to me. My impression after the A.0103 update was that the card seems to work at first and I/O errors only manifest after a couple of days and start with specific apps. See also my earlier posts (#98 and #99).

I bought a Samsung Evo now which has worked out of the box and without any major issues for the last three days … with OsmAnd maps on external. So, at least for me it doesn’t seem to be app-related.

I’ll check on my SanDisk card again after formatting to exFAT using my Linux machine in a couple of days, I guess. For now, I’m just happy that everything works with the Samsung Evo and I haven’t been overly motivated to fiddle with it once more.

1 Like

I can confirm that the status “got the SD working for a short while after exprimenting for hours with formatting with different options in the phone and also on the PC, rebooting the phone etc.” as well as the status “SD card is not usable” always is related to the status shown under “Settings/Storage”.

Any arbitrary app being able to access the SD card or not being able to do so in any case matches the status shown under “Settings/Storage”.

So, from my observations, the issue is not related to any app, neither my MediaMonkey app nor OSMand nor the stock files app nor the TotalCommander app (which I all use, too).

All of these apps work perfectly fine with the same SD card on my previous phone.

Hence, I can only conclude that the issue is related to FP4, either the OS, the firmware of the SD card device or (this would be the worst case) the hardware of the SD card device or its integration into the phone.

FP Support are telling me it was fixed on Feb 4th in v.099. The phones are running FP4.FP3S.A.103.20220221. However, I don’t have a spare SD card to test with.

Looking at the comments from others, there is still an issue even running FP4.FP3S.A.103.20220221. I’m not seeing an issue since I replaced the Sandisks with Samsung EVOs.


I just tried to write a video using the stock camera to my Sandisk 200GB. I’m very sure, that no video was written to the device. My FP4 ist running FP4.FP3S.A.103.20220221.
So, the bug isn’t fixed yet! Definitly :roll_eyes:

1 Like

Thanks. I’ve given that feedback to Solveig in FP support and they have passed it on to the development team.

1 Like

Thank you very much.

And again, just for the sake of completeness, another confirmation that the issue is still present:

Firmware A.103

BRAND NEW MicroSD card:
SanDisk Ultra microSDXC UHS-I class 10 512 GB

Inserted, formatted as “portable” drive
→ shown as “working”
→ started to copy come data to it
→ unusable as per errors reported above…



Can you retry with the latest update?

I gave my SanDisk to another FP4 user a week ago or so. On his device, it seems to work without issues; even before today’s update. Maybe it was just me :see_no_evil:


It works fine for me as well.

I have updated to A.107.
The SD card was mounted imediately.

Now I am heavily copying data from and to the SD card for ~2 hours now.
Stable and fast so far!

Looks very promising.