Screen can not be activated by pressing the power button

Hey, I have the exact same problem with my Fairphone 1! I can see or hear notifications, and my music would continue playing etc, but it’s impossible to activate the screen. It’s getting a bit annoying; I sometimes take out the battery to restart but it’s not the most healthy way of getting back control.
I contacted fairphone support months ago but they didn’t get back to me :confused:
Cheers,
Hannah

I have this issue too, but I can confirm it is not related to the problems mentioned in the wiki. Rebooting seems to be the only solution when this happens.

I am also having the same very annoying problem, happens most days. I also have to restart phone each time.

I also did have this issue after updating to the beta 1.4.2, but only for 2 days. It didn’t occure anymore since then. I did nothing to fix it, it just disappeared.

I also have this issue. It started appearing not long ago.

I have also had these crashes at night when charging a few times which left the phone with black screen and the alarm clock not going off, which can be quite a big deal if you only use the phone alarm to wake up.

Hello,

I think your problem is the one I posted last February.

I still have the problem, and no other workaround than restarting the phone (pushing for 15 sec on power button)…

@paulakreuzer
If relevant, can it be added to the #blackscreen wiki please?

Thx
Clément

1 Like

This is a different issue.

Just to be sure, here we are talking about the screen not turning on by clicking the power button, but you still get notifications. If your phone crashes you don’t get notifications and alarms.

Like you said it’s a #wiki, so you could have added it yourself. But I did it now. :slight_smile:

I’ve owned my Fairphone 2 for about a week now, and installed Fairphone Open on it (using the OTA package) around twelve hours ago, having no problems until about an hour ago.

Now, every time I lock the phone (or it locks itself, going to sleep while unplugged etc.) the screen remains black, with no response from the lock/power button. The phone is not frozen - if I touch the areas of the screen where the various icons should appear, I feel the force feedback, messages etc. are still received, the LED in the top left behaves as it should - but the screen is black. The only way to make the phone usable again is to reset by removing the battery or long pressing the lock/power button.

I also noticed that, for a brief period (during the last hour) the top quarter of the phone growing very warm when nothing appeared to be happening, although this is no longer the case.

Also, the phone is no longer recognised by Minimal ADB and Fastboot, although it is recognised normally by Windows 7.

I have tried dismantling the phone, to no change. All connections appeared to be fine before, and appear fine now.

Apologies if this should be posted elsewhere. I found descriptions of similar problems, but none really matching.

Any ideas? Thanks in advance!

Just checking, is there any link to using a 4G network? (just wondering whether this more recent post is describing the same issue)

Hi Johannes,
this is a different issue than this. After a system crash after logging into a 4G network the phone doesn’t ring any more when the mobile number is called. And the caller doesn’t hear the ring indicating tone. The FP2 doesn’t do anything as if the battery had been removed without logging off the GSM network.

Cornelius

Aye, mobile data is completely turned off for the phone. I am connected to a 5GHz WiFi network, but disabling this makes no difference.

I rather believe it’s the same issue described here, so I moved the posts into this thread.

Unfortunately there is no solution yet…

1 Like

My phone has started working perfectly normally again - and I have no idea why.

The only thing I’ve done since the problem arose is taken a backup using the built-in recovery mode, didn’t clear the cache or anything like that.

And now it’s doing it again. It started when I turned my screen brightness to minimum - the screen went black as if I’d locked it the moment I dragged the slider to the far left.

Sounds like some of the reports in the bugtopic below. Which software version (i.e. 16.xx) are you using?
https://forum.fairphone.com/t/black-screen-after-reboot-if-brightness-is-set-to-zero-or-adaptive-fixed-with-1-4-2-16-06/18752?u=johannes&source_topic_id=19478

1 Like

I’m using 16.06 - it seems to be working normally now, after two reboots.

A post was merged into an existing topic: Fairphone 2 touchscreen suddenly freezes

My FP2 freezes during black screen. It won’t come out of Black Screen anymore, unless I restart using the start button. It happens both during charging and without charging, but never when the screen is activated. It’s like a sleep mode that doesn’t reactivate.

Anyone experiences this and found a cause?

I moved your post here in accordance with the #blackscreenguide.

PS: It could be a connection problem, so try taking off the screen and carefully cleaning the contacts.

I have thought about that too, but that didn’t help. Interestingly, I have my FP2 since last year April and this issue has only come up since the update before the last. Currently I run Fairphone OS 1.10.1. It happens seemingly randomly, sometimes when the phone is lying on my desk.