Screen Auto-rotate not working

My FP1 has just been repaired. All fine now but I’ve noticed the autorotate on the screen isn’t working.

I have ticked the box in Settings | Display | Auto-rotate screen but it seems to be stuck in portrait mode. Anyone else had this issue?

1 Like

Seems like an issue of the gyroscope / e-compass.
In the best case, something went wrong during the configuration of the software, so you should try to reset your phone.

Worst case scenario is a broken gyroscope / e-compass.


I’m having the same issue after my FP1 has been repaired. (It was send back to me on oct 16 2014).

Only while using the original camera app the screen and photo taken is turned to the correct orientation after a bit of shaking/tapping on the side of the phone. If I only turn the phone around from portrait to landscape (or vice versa) the screen or photo doesn’t turn.
Also in all other apps the phone the screen doesn’t autorotate and is stuck in portrait mode.
In my case it makes no difference wether I turn the Settings/Display/Auto-rotate screen option on or off.

Perhaps the camera software uses another software to turn, regardless of the settings?
@JPL, could you give the camera a try?

I’m using FP1 with Android 4.2.2 Build W20-HL.V0025 (if this is of any use to anyone)

1 Like

Hi Arie
The camera app doesn’t rotate for me either. I am pretty sure it’s a software problem as the Check my Android app suggests all the sensors are working. However, I can’t be bothered to reinstall everything again - I’ll do it when I next upgrade the OS. Until then I am rotating the screen manually when I need to using a rotation control app
I’m using FP1 with Cherry 1.6 Android 4.2.2


Here’s another story fitting the issue. My FP1 was returned yesterday (11th feb.2015) from repair (motherboard defect, screen switch). After I went through the tedious process of restoring my backups I realize that the auto-rotate feature doesn’t work, independent on wheather the auto-rotate button is active or not. I assumed a broken gyroscope. But, it was only when I found this thread that I realized all sensors work fine (check my android app) and that in the camera app the auto-rotate feature is working (kind of).

Btw. the phone was factory reset when I got it with FP OS 1.6. I upgraded to 1.8 before I started restoring.
FP1 / android 4.2.2 / kernel 3.4.5 / build W20-HL.V0035

That’s interesting. So it’s still occuring even after you installed 1.8? Have you tried reinstalling it? I haven’t tried yet, by the way.

Hi there,

because of other trouble with my FP I did a factory reset and a downgrade to FP OS 1.6. I applied the unified storage update as well. The auto rotate issue is still there. What’s wrong here?!

Edit: I think it would be a hell of coincidence that all three os us have this problem right after we get our phones returned from repair. Wheres the connection. What was wrong with your phones and what was done?
My GPS and micro USB slot were defect. They diagnosed a motherboard fault and suggested to change it. I realized they just sent my a used replacement phone instead of changing the motherboard (i.e. it’s not the same serial number than the one I sent in).

I don’t think they sent you a used phone. It is rather that the serial number is stored on the motherboard and thus will change if the motherboard is replaced.

You should definitely contact Fairphone and tell them to check the replacement motherboards. Maybe they are faulty and cannot handle the auto-rotate?


Today I checked my FP with the ‘Check my Android’ app, as you suggested. It seems like the sensors are giving a quick reaction on turning the phone around, although from the app I’m not sure if it the turning data is correct.

With the ‘Ultimate Rotation Control’ app, I’m able to set the screen to ‘landscape’ or ‘portrait’ manually. However, even with the ‘forced automatic’ option turned on there is no rotation.

The only app where automatic rotation is, sort of, working still is the original camera app. With a bit of shaking, the screen turns, but sometimes not as intended, so it takes a few shakes to get the camera in position. Quite annoying, but doable.

I’m still using FP1 with Android 4.2.2

@Florian_Martys and @Stefan,

I also checked the serial number. The number on the motherboard I send in is indeed different from the one which was returned. From the scratch marks on the rest of the phone I can see that at least the front with screen and the plastic part of the back are the same, so the exterior of my phone was returned after the repair.

I send it in because it was bricked and I wasn’t able to repair it myself. For full details please see my support request #27792. In short:
What happened: the phone battery was drained while using the wifi-hotspot and other apps at the same time.
Problem: after re-charging the phone or putting in a different full battery, the phone does not start nor does it start in recovery mode (volume up + power button for 10sec.) Also i’m unable to reach it via usb or flash it.

I’ll send a note of the problem and this thread to Fairphone support. Have any of you done so too?

I have photographic proof (scratches and dents on the white front frame) that the phone sent in is not the one I got returned. Also, I was talking about the serial number printed on the back of the FP under the battery, not the serial number in the Android About Screen.

I’ve just opened a support ticket explaining my problem referencing to this thread.

I think only you can see the support requests, you opened.

I’ll check with the FP team, what they say about your comments (if they really send back second hand phones).

I’ve heard back from FP Support and they supplied me with a fix that worked for me with one slight adjustment (see below):

Luckily there is a way to fix this!

Below is explained how you can do this:

  • Power off your phone
  • Hold the volume down button (and keep pressing it)
  • Hold down the power button (and keep pressing it)
  • Wait until a screen appears that is called “Factory Mode” (now release both buttons)
  • Use the volume down button to go to “Items Test" and push the power button after that
  • Use the volume down button to go to “G-Sensor calibration" and push the power button after that
  • Put your phone on a flat (levelled) steady service (a flat floor or table)
  • Use the volume down button to go to “20% Do Calibration” and push the power button after that (the G-Sensor will calibrate)
  • When you see the yellow text “Cali done” you know that the calibration is done
  • Now push the volume up button to go back in the menu
  • Use the volume down button to go to “Gyroscope calibration” and push the power button after that
  • Use the volume down button to go to “20% Do Calibration” and push the power button after that (the Gyroscope will calibrate)
  • When you see the yellow text “Cali done” you know that the calibration is done
  • To stop keep pushing the volume up button until you get back in the main screen
  • Use the volume down button to go to “Reboot” and push the power button after that

Note: if anything goes wrong or you don’t know what to do, you can simply stop factory mode by taking out the battery.

At step #8 - doing the 20% calibration - I got returned “Cali failed”. I tried it a couple of time with no sucess. However, the 40% calibration worked (on the second try). I rebooted and auto-rotate worked as before.

Although FP provided a quick fix for the problem (thanks!) they did not reply in a word to my question concerning the return of a different used phone and the similar cases that I presented providing the link to this discussion.


Hey! It works! Many thanks Florian.


I followed the same steps (both 20% calibration gave “Cali done” in my case), and now all works fine again!
Thanks for sharing the explanation!

I also got a reply from the FP support team quickly stating that I could send in my phone on their costs so they could investigate the issue. But since it’s working again now I’ll let them know it isn’t necessary anymore and they can send the same instructions in future cases.

1 Like

I set the topic on auto-close. Glad to hear that you found a solution! :slight_smile:

Hi all,

As one of the owners of FP’s repair process I wanted to quickly pitch in with some feedback on this topic:

  1. We are aware of the issue that some repaired phones come back with auto rotate not working after repair. We investigated this matter and in the repair center every phone is carefully calibrated, this is tested two times (by separate technicians on separate moments) and noted down on the test form you receive back with a repaired FP.
  2. Unfortunately in some pretty rare cases the auto rotate stops working and you need to re-calibrate it manually as posted in this topic. We’ll always help you do this and if it does not work make sure the FP get’s returned to us so we can fix whatever is wrong.
  3. As for @Florian_Martys getting a wrong phone, as replied in the ticket you sent in, both your screen and motherboard was replaced. This might explain why the dents in the screen are gone, and why the S/N and IMEI numbers are different. With a new motherboard we re-sticker a new S/N/IMEI sticker on the back of the screen to reflect the numbers belonging to the new motherboard. If there is still something that shows that it cannot be your original FP, please do let us know, these kind of mixups we take very seriously and should not happen.

Hope this brings a bit of clarity!


This topic was automatically closed 9 days after the last reply. New replies are no longer allowed.