SanDisk 32GB MicroSD not detected

Hi, this might be a dumb question: I bought a SanDisk 32GB MicroSDHC UHSI card (to be precise) for my FP2. Put it in the slot, but phone does not seem to recognize it. Do I need to follow a certain procedure? Or did the shop sell me a wrong card (just said: "I need an SD-card for my smartphone."
Oh, rebooting/turning phone on and off does not help.
Thanks for ye answers,


1 Like

I created a new topic for your post as everybody else with that problem has a Samsung 64GB SD which seems not compatible with the FP2.

I hope you get some answers here.


I formatted the SD-card - that went well. It is mounted on my desktop when I put it in the card-slot (mac).
When I put it in the FP2, however: nothing. Does not show up and the ‘erase card option’ (under storage) remains grey.
I go to amaze I see ‘storage’ with a date jan 07, 1970, and underneath
four maps, two of which are called: sdcard0 (03, 2016) and sdcard1 (07,
1970) - last one is empty.
What is going on/wrong?


Did you already try to format your SD card (backup your files!) with the FP2? I had to do it with a brand new Sandisk Ultra 64GB. Now it works as it should.

Edit: Sorry, I just saw that the option is greyed out on your phone. I think the file system has to be fat32.

Have you had a look at all the topics about SD card problems that are already available? See 2nd and 3rd post of the following topic for links.

A forum search might even result in more helpful topics.

Yes I did have a look, and the discussion you mentionned was really the same as I have, but it is closed for comments, so I had to open a new one for my situation. No solution yet :frowning:

I have exact the same problem. Fairphone? Where are you?

1 Like

I plugged a new microSD card:
SanDisk classe 10 32gb UHS-1 ultra microSDHC
but when I go in parameters -> Stockage -> SD card, the two options ‘install’ and ‘format’ are not active (in light grey)

this cards works perfectly on a computer (Ubuntu) with a USB card reader

I tried another card, also SanDisk, it did not work either.
Of course, I cannot see my SDcard in Amaze

I tried to reformat my microSD in ubuntu using FAT file system, without any success in the FP2 :frowning:

Did I miss anything, do you also have troubles, is my FP2 defective for the microSD plug ?!?

Thanks for your help,

While Fairphone staff is occasionally on the forum, support tickets are still the best way to get their attention (even though it takes a long time for them to be answered…), see the quote from the pinned welcome topic below.

(And no, the community moderators are not Fairphone staff)

All, to no avail.
SD still not recognized. After formatting: nothing.


  • By default large cards (32, 64 and 128 GB) are sold formatted in exFAT format (That’s the only distinction between SDHC and SDXC cards. The wire protocol itself is is the same, only the data format written on the actual flash is different).
  • Some cards are even sold non-formatted (that might be the case with some 32GB SDHC cards. It’s certainly the case with those produced by Transcend. Maybe Sandisk too ?)
  • exFAT is a proprietary and patented format by Microsoft. Because of this, not all constructor do pay for it and thus don’t support it (e.g.: Jolla, even Nintendo, etc.) I strongly suspect that Fairphone doesn’t have a license for it neither
  • Again, it’s not that the device are not actually compatible with SDXC card (there’s no difference). It’s that they technically can’t advertise it as they won’t be compatible with the partition format
  • Windows it self will refuse to format big supports as FAT32, it will only format them as exFAT or NTFS. (There are no technical reasons. It’s possible to format 32GB and bigger using FAT, it’s just that Windows refuses to do it for you)
  • So you need to format them with another tool (e.g.: gparted is available on the SystemRescueCD boot disk).
  • Just keep the same partition alignment. i.e.: if the stick 's data partition begins at sector 8192 or 32768, keep the same beginning.
  • Also keep in mind that the partition it self must be the correct format in the partition table (e.g.: the Nintendo 3DS won’t see a partition even if format in FAT32 if the wrong type is indicated in the partition table, though GNU/Linux OSes tend to autodetect it correctly. No idea what is Android’s behavior):
  • Partition in NTFS or exFAT are of type 7 in the partition table.
  • Partition in FAT32 are of type c in the partition table

Useful link:

This page contains full details how to format a USB flash with perfect alignment using Linux.


DrYak, thanks, but - wow - that is very technical.
And I am on Mac, any tips there?

Saddly, I’m not very experienced with Mac OS X. But’s a BSD under the hood, so you still must be able to use standard UNIX command.

You should still have:

  • fdisk - to edit partition table (and set the type to FAT32 (LBA) i.e.: c)
  • something like mkfs.fat or mkdosfs to format the actual partition

fdisk on OS X:

diskutil (apparently the command line tool used for formatting in FAT on the OS X shell):

I’ve read your postings again. Well, if you see an sdcard1 in Amaze, that means your SD card is recognized by the FP2. It’s just empty.

One question: is or was your FP2 connected via USB to your computer when you tried to format the SD? Because the default usb setting is “mount SD card”, which means that the computer can use it as an external hard disk, but when the phone is connected via this mode, the SD card is invisible for the phone.

So disconnect your phone and try it again.

If it works, in order to avoid future trouble, you could do the following: When your phone is connected to your computer, swipe down the notification bar and of the left side you’ll find a notification to change USB options. Choose “MTP”. This will show your internal storage and your SD card on your computer, without hiding the SD to your phone. Since you have a MAC, you’ll need to install Android File Transfer.

It does not work, alas.
I formatted the card again, disconnected.
Put it in the slot: does not recognize it.
Darn :slight_smile:

Did you already try to format your SD with the FP2 with the “erase SD” option when the phone is NOT connected to your computer?

I have the same problem. I already followed every advice I could find in there, including re-formatting the card as MS DOS FAT and then erasing it on the phone. After that it worked for a while but now it’s gone again. I can still see it on my computer so the card itself is obviously fine and the phone recognises it too - it just won’t mount it. Whenever I try nothing happens. Very frustrating … and no change after the new update, alas.

Same here. Problem still exists.

Continues here: