Sailfish OS 3.3.0.16 release1 for Fairphone 2

please keep me updated on that forum when this happens :wink:

1 Like

@mal i see on the testing tree that you released the latest version 3.4.0.24 - many thanks.
Sadly on the update i made a mistake and now my fp2 is dead :pensive:. I think was my fault - i skiped two previous versions … now on boot i got a black screen.
I can boot to recovery mode, but telnet returned ‘connection refused’, so i’m not able to repair the SailfishOS on phone :thinking:.

Do you have build an image (e.g. .zip) file for the new version for a ‘TWRP’ installation? So i can install it without the whole upgrade path from some old 2.x.x.x version?
Many thanks :smiley:

EDIT: I can use ssh to connect via USB on my FP2. On the journalctl i see that there is a problem starting lipstick and some other features. Is it possible to start the WLan on command line? I hope that i can reinstall some packages then …

@gabs I hadn’t yet verified the updating to new release properly and hadn’t officially released the new version because of that. Maybe you could check that patterns-sailfish-device-adaptation-fp2-sibon, patterns-sailfish-device-configuration-common-fp2-sibon and patterns-sailfish-device-configuration-fp2-sibon are installed on the device. Those could in theory cause issues because that was the part I was about to verify.

@mal after installing some pkgs manually the phone is back to live :sweat_smile: and i can finish the update successful. On my second phone the update went smooth :smiley:.
I think my problem on the first phone was, that i skip some versions - i made an update from 3.1.0.12 direct to 3.4.0.24 :thinking:. On the second phone i update from 3.3.0.16 to 3.4.0.24.

The only problem i have, that poweroff did not work on both phones. On Jolla phone and Tablet and on Gemini PDA the poweroff work without any problem. On the FP2s the phone always reboots regardless if i press the power button, or i shutdown on command line (shutdown, systemctl, … do you have any hint how to correct this problem? Open the phone and pull out the battery every time is not very comfortable :face_with_raised_eyebrow:.

@gabs I think the reason why the second device updated without issues was that I found and fixed a problem related to those packages yesterday.

I will have a look at the poweroff issue but as a workaround you can force poweroff by pressing power and volume up buttons for 10 seconds until it vibrates 2 or 3 times. I would do that while it restarts after trying to shutdown the device so the full system is not running at that time.

1 Like

Try to turn on the Torchlight before turning off the phone :wink:
This was a known bug on LineageOS and /e/ for a long time. It is fixed since the 19.02.1 releases of Fairphone OS and Fairphone Open, according to the bugtracker :slight_smile:

EDIT: I just read the first two messages of this post where it is said that this bug is unrelated to the Torchlight old one… :frowning:

1 Like

@oli.sax The thing is that I know of that fix and I added it to my kernel already about 2 years ago. Unless I messed up something during my rebuild and lost it, I will check my kernel sources for that again and try to debug why shutdown is not working.

2 Likes

@oli.sax and @mal the trick with the Torchlight is working on SailfishOS also :wink:. Many thanks.

1 Like

Thanks as always @mal. 2020 was crazy so I am only now getting to update my FP2 from Sailfish 3.0.1.11 (so beta4 I assume) to 3.3.0.16.
I followed the OTA inststructions without flashing the modem partiotion first (as it clearly says I can do so, not I should or must and I figured it was safer to first update the OS to a version that can handle the new firmware than the other way around).

ssu lr gave me the following:

WARNING: ssu.ini does not seem to be writable. Setting values might not work.
Enabled repositories (global):
 - adaptation-community        ... http://repo.merproject.org/obs/nemo:/testing:/hw:/fairphone:/fp2-sibon/sailfishos_3.3.0.16/
 - adaptation-community-common ... http://repo.merproject.org/obs/nemo:/testing:/hw:/common/sailfishos_3.3.0.16/
 - apps                        ... https://releases.jolla.com/jolla-apps/3.3.0.16/armv7hl/
 - hotfixes                    ... https://releases.jolla.com/releases/3.3.0.16/hotfixes/armv7hl/
 - jolla                       ... https://releases.jolla.com/releases/3.3.0.16/jolla/armv7hl/

Enabled repositories (user):
 - store ... https://store-repository.jolla.com/fp2-sibon/armv7hl/?version=3.3.0.16

Disabled repositories (global, might be overridden by user config):

Disabled repositories (user):
 - home ... https://download.jollamobile.com/home:/honeybadger/latest_armv7hl/

Ignoring the warning, I followed up with the devel-su zypper commands that seemed to finish just fine.
However, version --dup keeps failing on me with the following error:

Error: nothing provides patterns-sailfish-device-configuration-fp2-sibon needed by pattern:jolla-configuration-fp2-sibon-0.0.68-1.69.1.jolla.noarch

I tried twice, each time all nine re-attempts fail with the above message and ultimately I am now left with

The upgrade could NOT be finished. Make sure you have
a working Internet Connection and SSU is propertly set up. In
case the repos are changing rapidly (e.g. during development),
just restarting the upgrade might fix the issue.

REBOOT AT YOUR OWN RISK.

At this stage I am not sure how to best proceed.
I have the phone attached to a charger now to make sure it won’t run out of power but eventually I’d like to get it to a stable working state. :wink:

Any clues on what I could try?

Thanks in advance!

Silly question but you are running as “root”, as you didn’t show whole line?
[root@Sailfish nemo]# ssu lr

@mschilli87 I noticed a problem in the repos which might cause the problem you had, could you try again but first update to 3.2.0.12 and then to 3.3.0.16.

1 Like

No, I did run the exact command provided in the section I linked:

# on host:
ssh nemo@fp2

# on FP2:
ssu release 3.3.0.16
ssu lr
devel-su zypper clean -a
devel-su zypper ref -f
version --dup

Thank you so much! That solved the issue. :tada:

My FP2 power cycled three or four times during version --dup's download phase (though it was connected to power all the time) but I was always able to reconnect and restart the process with version --dup picking up the download it was interrupted in. Once it reached the actual installation, it completed in one go and after rebooting into 3.2.0.12 I repeated the whole procedure (without random reboots while downloading) for 3.3.0.16.

I’ll leave flashing the modem partition for another day. I had enough excitement for today. :wink:

Thank you so much for the super fast and spot-on reply. :heart:

1 Like

Successfully updated from beta9 to release1 :slight_smile:

,—
| Sailfish OS 3.3.0.16 (Rokua)
'—

“On the FP2s the phone always reboots regardless if i press the power button…”

Same with me, constantly.

@mal are you working on providing SailfishOS 4?

Yes, I will also make Sailfish 4 available for Fairphone 2 once the new version is release. The previous release to 3.4.0.24 for FP2 has been delayed quite long and maybe I should just release it and not try to get kernel updated for that and do the kernel update for 4.0.

7 Likes

Any Sailfish version for FP3 would be great! Does the kernel update solve the issues you mentioned on #sailfishos-porters?

Sailfish OS for FP3 needs to wait until the next Sailfish OS release is public because it will be 64-bit build and some parts are only properly supported in that release.

3 Likes

And now that SFOS 4.0 is out? :wink: SFOS for FP3? :wink:

1 Like

My Sailfish OS 4.0.1 FP3 test build has everything working except webgl in browser and fingerprint support based on initial testing. Need cleanup some things and do some more verification and hopefully fix those remaining issues.

6 Likes