Phone won't stay off

This is one of the ugliest work-arounds ever and I’d prefer to get any thechnical information, WHY this helps and perhaps then find the real cause and solution :).


Of course this would have to be looked at, and ideally quickly … but this is not an ideal world we live in, and LineageOS is a spare-time community effort.

From the LineageOS point of view the most time-saving approach should be to hope for Fairphone staff to figure it out for good in their Android 7 and then analyze or ask what they did.

In the meantime … whatever hack works :slight_smile: .


I just installed LOS15.1 (14nov2018 nightly version) on my FP2 (with new cam module) and got the same issue (instant reboot after shutting down).

Solved when I turn ON the flashlight just before shutting down ! :thinking:

I had the same problem but with a new Fairphone with the original OS (Android 7.1.2 build 18.09.2). Your workaround work well too ! Thank you.

The very same problem with a brand new Fairphone2 with Android 7.1.2, and turning on the flashlight before power off prevents the automatic reboot for me as well. Weird, but it works

to avoid duplicate topics please continue here: was released:

This includes the Shutdown fix, I’m currently downloading and testing…


Yipeeee! The fix works!


Indeed, it’s fixed, WOW!

Wohooo. Thanks to Fairphone devs for the fix. I just applied it to lineage!


I applied this update (as previous ones), but since November 2018, although I download the release and install it, it seems that the upgrade does not work.

Where can I report this issue?!

What does it say in Settings - System - About phone - LineageOS-Version?

How do you try to install the update … automatically via the Updater or manually via the TWRP recovery? Is there an error message along the way?

Does your FP2 reboot to TWRP when installing? if not it just reboot normally and display a error message…
You could force the reboot to TWRP by maintaining VOL UP during the OTA install process or by turning on Torchlight before starting OTA installation. :slight_smile:

I’m not an expert but from my experiences I would say: If your screen looks like this, the latest patch was downloaded only but not installed yet. You have to press install to start the installation. If your phone does not boot into recovery mode automatically you have to press vol.up when the Fairphone restarts.

@oli.sax I thought you were jocking concerning the torch light… So I tried it first, off course. ANd it worked. For the first time since November, the phone rebooted in TWRP during the installation.



Actually my girlfriend was laughing at me each time I turn on the torchlight to shutdown the phone… I’m glad fairphone finally fixed the bug :smiley:


Same here, she couldn’t believe THAT!


Where’s the problem? “He oughta make me laugh.” … technology for the win :slight_smile: .